WinFF problem

I am using openSUSE 11.2 with KDE 4.3. I was using WinFF successfully. Then I reinstalled openSUSE to use the ext3 file system instead of ext4. (I don’t know if this is relevant to my problem or if the new trouble with WinFF is a coincidence.) All my other applications work as well as before but now WinFF fails. I can get the starting window but when I click the ADD button, a new window flashes just briefly, then WinFF shuts down. I deleted it and reinstalled but still the same results. Any suggestions appreciated.

I think it’s buggy. Report it to packman.
PackMan :: Informationen zum Paket winff

Thank you; I’ll do that.

The problem is solved with the help of feedback from packman and some postings on the WinFF site. If you use KDE and openSUSE 11.2, and you get these messages:

Out of OEM specific VK codes, changing to unassigned
Out of unassigned VK codes, assigning $FF

then the trouble is the GTK style in KDE.
The recommendation is NOT to use qt-curve, and the best bet is to change to clearlooks.
Go to Configure Desktop>Appearance>GTK style and fonts> then select Clearlooks.
I did this and now WinFF works fine. I hope this info will be useful to other users who might have the same WinFF trouble.

I want to install winff but can’t find it either in the repos (pacman enabled) or at Search Results

I am using openSUSE 11.4 Gnome 64.

It’s not there for 11.4 yet

Thanks for your reply.

The problem is while trying to encode some 1080p videos to 720p using avidemux I am getting severe audio/video sync issues.

The same thing happened in Ubuntu too. So, I moved to Winff.

Now, since Winff is not available for openSUSE 11.4 yet I wanted know,

Is there any other frontend for ffmpeg or any other video encoding tool other than avidemux which I can use to do similar tasks ?

I’m not sure, but will Handbrake do it?

Yes. Handbrake worked. :slight_smile:

What d’ya know :slight_smile:


Resurrecting an old thread, but I ended up playing with winff last night. I found a packaged version by searching here: Search Results

This provides winff-1.3.1-2.7.x86_64.rpm which is not quite the most recent version (as 1.3.2 is most current according to WinFF - Free Video Converter ). This packaged winff comes with a number of presets for different hardware (ipod, blackberry … ).

I gave it a try to convert a .flv downloaded from youtube, but immediately had a failure. Checking the conversion code (it uses ffmpeg) I noted it was use ’ -ab 128kb ’ where in fact the code should be ’ -ab 128k ’ with current ffmpeg versions. So I removed the ‘b’ from that and tried again.

I then had another failure in that it could not find the audio codec ‘libfaac’. I recall that libfaac codec support was removed from ffmpeg due to proprietary versions, but it appears the presets assume ffmpeg is built with ‘libffaac’ support. So I changed the ‘libfaac’ entry to ‘aac’ and tried again.

I then had another failure noting that ‘aac’ was an experimental codec, and to use it I had to also use the code ‘-strict experimental’. So I tried again, replacing ‘libfaac’ with ‘aac -strict experimental’ and the conversion worked.

I then went into /home/oldcpu/.winff/presets.xml and with a text editor replaced ALL occurences of ‘libfaac’ with ‘aac -strict experimental’ and also searched for all ‘-ab’ occurences and ensured the following number had no ‘b’ beside it. That took a bit of time, although I did find a way to optimise that had had that conversion completed in ~ 5 minutes of effort.

winff is now running nicely. :slight_smile: