Wine with openSUSE 12.1/11.4

I have a Windows application which is a must have app (I use it every day). It works fine in openSUSE 11.4 with Wine (and versions before 11.4) but fails to load in openSUSE 12.1 with Wine. The only difference between my installs is that 11.4 (and earlier) were installed from a DVD, whereas 12.1 was installed from the Live CD.

Is it possible to downgrade my Wine to the one in openSUSE 11.4? How to do this? Can I just copy my wine from 11.4 to 12.1? Which folders do I need to copy?

Any help would be appreciated. It’s stopping me from upgrading to 12.1

On Sat, 19 Nov 2011 03:36:03 +0000, stubble wrote:

> It works fine in openSUSE 11.4 with Wine (and versions before 11.4)
> but fails to load in openSUSE 12.1 with Wine.

Perhaps if you describe how it fails, someone might be able to help
determine what the problem is and address that, rather than trying to
downgrade. WINE is one of those programs that tends to add compatibility
rather than take it away as it progresses.

Jim

Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

You could also try the Wine repo, which is what I had to do.
Unfortunately they decided to switch the wine version during the later stages of development in 12.1 (and we ended up with a turd version)

You could also try the Wine repo, which is what I had to do.
Unfortunately they decided to switch the wine version during the later stages of development in 12.1 (and we ended up with a turd version)

Good advice Carl. I like the way you put that :slight_smile:

Trying to load the program I immediately get the message “The program has encountered a serious problem and needs to close. We are sorry for the inconvenience.” appears in a Wine Program Error Window. Closing that closes the program.

What is the address of the Wine Repo?

look in yast repos
add

community list

it is in there

make sure you then use the switcher to switch to that repo

OK. I found the wine repo. Actually I already had it installed. I also added the wine repo for 11.4. So I now have two wine repos, 12.1 and 11.4. the 12.1 wine repo only offers me the current (1.3.30-2.1.2 turd) version. It doesn’t offer me any other versions. (Am I missing something). When I disable 12.1 enabled/autorefresh and enable the same on 11.4, I still only get the turd version. I refreshed the repos. So I guess I’ve missed a step. What is “the switcher” and how do I use it to switch to the 11.4 repo, so I can downgrade my wine installation? Or if there is an earlier 12.1 wine repo version that works, I’d use that. Do I need to remove my installed wine first?

This is the address for the 12.1 wine repo: Index of /repositories/Emulators:/Wine/openSUSE_12.1
Just substitute 11.4 for 12.1 for the earlier repo.

OK I deinstalled wine. When trying to reinstall, I’m offered version 1.3.33-1.1 but when I try to install it I get a warning that libgnutls.so.26()(64bit) is required for this version. Where do I get that from? I have libgnutls28 installed.

Remove thee wine repo
Be careful, but try and add wine by using the 11.4 OSS repo
You may have to roll back the package that supplies libgnutls.so so as to get v26

This is a process you need some experience to undertake. I’m busy right now, otherwise I’d walk you through it.

If you succeed you should lock wine packages and remove the 11.4 OSS repo

OK. I switched back to the 12.1 wine repo (by enabling/autorefreshing and disabling the same in 11.4), since I figured I had the libgnutls28 from my 12.1 installation, and it was expecting libgnutils26 (presumably from 11.4). Thinking that might solve the problem. Well it did. I no longer had the warning about libgnutls26. But I had another warning this time about breaking wine-gecko, because it was looking for an earlier driver for something (looking for 1.4.0 and I has 1.4.26) the warning said don’t install or break wine-gecko. So I chose to break it. Installation went ok. My windows program now working again. When loading I get some squiggly lines across the screen (which I never had before) but they go away and the program seems to be working ok.

Thanks to everbody for their help.

I reported the wine-gecko issue last week
But it’s still not been dealt with.

Well done
I’d lock your wine packages if I were you

How do I do that?

In software manager, right click the package > Choose Protected Do Not Modify

Apply

Thanks again.