wine repositories

"I found this page:

Index of /repositories/Emulators:/Wine/openSUSE_11.0

I’m a little confused
I need more information, but then again, so do you, that isn’t very descriptive
Edit/Delete Message Reply With Quote Quick reply to this message
View Public Profile
Send a private message to imachavel
Find all posts by imachavel
Add imachavel to Your Contacts
#2 (permalink) Add to imachavel’s Reputation Report Post
Unread Today, 03:27
imachavel imachavel is online now
Student Penguin

Join Date: Dec 2009
Posts: 81
imachavel hasn’t been rated much yet
Default Re: wine repositories
do I have to download all of those?

ARGH, I want to shoot myself

maybe I’ll move this thread to applications"

I moved this here from games, don’t know why I’m having such a hard time with wine

originally decided not to mess with it too much, but now I’m wanting to use it
anyway the page didn’t look too confusing at first, but now I am struggling with it a little bit

i looked for a video on how to do this, and it only showed me the ubuntu installation version, i guess i start with ‘applications’ which I don’t see on opensuse

I should really just reformat with ubuntu but I don’t have a blank cd-rom and get the feeling I’d screw up the installation somehow

i guess you could say I’m a monkey with computers

oh well

Lets start from the scratch.
1- Why you need that repo. Its for current updates of wine. Wine is there in the software management.
2- What you want to achieve by use of Wine.
3- You can find it in Kickoff menu. Just search for wine in the search bar.
4- What problem do u face?

with wine I can use some demos, I wanted to play f.e.a.r. combat

where is the kickoff menu?

I appreciate the help

It is the menu thingy on the bottom left

Have you installed wine?

Do you know how to? Hint Yast-Software Management

The best place for information on if and how to run a Windows program will be found on the wine site.

WineHQ - Run Windows applications on Linux, BSD, Solaris and Mac OS X

omg back to square one

no i haven’t installed it, i’ll have to look at that link

so the kicker is the same as ‘start’ basically

why did this guy tell me just to access the kicker then? I got that list of repositories from the wine website to install it in the first place

i’ll have to check out the link you showed me

oh i think i get it

wine comes with opensuse? I just have to install it?

let me see if I can figure this out

how will I know if it’s working properly?

btw how do I delete things in linux?

and do downloads take longer with linux than in windows? Or is there something wrong if downloads are taking too long?

i tried this with not much luck in the konsole:

danel@linux-xfc5:~> su -
linux-xfc5:~ # wine program.exe
-bash: wine: command not found
linux-xfc5:~ # winecfg
-bash: winecfg: command not found
linux-xfc5:~ #

My kickoff menu (lower left) doesn’t have wine because its not installed. If you don’t find wine, try this:

open a terminal (also called console or konsole)
type su
it will ask for your root password. Type it in and press enter.
Finally, type
zypper in wine

Wait for it to install, it takes a couple of minutes.

lol i thought it was su -

i’ll try it right now, thanks a lot, let you know if it worked

ok it worked, awesome

still don’t see it in the kicker
lol i’m guessing restarting my computer would do nothing

Now that its installed, you can try two things.

  1. The kicker menu has a box at the top. Type wine in there and it will find it.

  2. Press Alt+F2. In the box that opens up, type wine

well i tried launching it

wouldn’t launch

no message or anything telling me why it wouldn’t launch

just won’t launch

lol and i got so far

lol **** computer

oh well

probably nothing i can do

this thing gives me a load of problems
no idea

was thinking about replacing the hard drive
don’t know if that would fix anything

alt f2
type konsole
then at the command line type winecfg
after that you should be able to see it in the kicker menu or start the windows program by typing wine windows .exe file name in the directory where it resides

It won’t lanuch, until u run its configuration like in terminal:


And in openSUSE we called that **start button(windows) as Kickoff menu.
And if you want to check either an application is installed or not, type this in terminal, for example:

whereis wine

There are other commands too. You can Google it.

linux-xfc5:/home/danel # whereis wine
wine: /usr/bin/wine /usr/lib/wine /usr/bin/X11/wine /usr/share/wine /usr/share/man/man1/wine.1.gz

that’s where it is, lol still not in the kicker, but it’s configured now

lmao how do I get to that directory? Lol use yast? Or what is the equivalent of dir in windows? I know that with windows for some reason you can’t open things with the command prompt like you could in dos, can you open things with cmd in linux?

Which directory? you mean where are the wine applications and wine itself. If yes, you can find it in your home directory. It will be hidden. Just unhide from the menu in view. You will see .wine there.

BTW if you want to run an application, just right click on it and select run with wine or run with other application and then type wine. OR you can in terminal like:

wine combat.exe

wow some thing are easily downloadable and openable with wine?

nice, just right click on it and then type the name of the application when it asks you what to ‘open with’


ok i’m sorry but im confused about linux directories compared to windows

in windows you can right click on something and use explorer, or in run type explorer.exe
or even on the desktop right click and type explore

but how do i find these directories in linux?

so far wine is in home
but i have to be in the directory to open it right?

i showed you where it is, but i don’t know how to navigate to there

i was wondering if yast is where i go, but guessing from the fact that it’s in home directory… you know what I’ll stop while I’m ahead I just don’t know