.Wine Regression

I’m not sure if “regression” is the proper term for this, but what I want to do is go from the current version of .wine found in YAST to the older version 1.23 or 1.22.

Is there a way to overwrite the newer version?


I’m no expert so maybe I’m missing something here… but can’t you just use the uninstall update button in the “version description” of YaST?

Oh snap. I’m assuming you had an older version installed and then updated via YaST. Re-reading your post it seems you’d prefer an older version than what YaST offers altogether. Hmm…

It would be helpful if we knew what version of openSUSE we are dealing with. What version of wine you currently have.

On 12/23/2011 02:56 AM, crypkema wrote:
> older version 1.23 or 1.22

the current stable version is 1.2.3 and the latest development version
is 1.3.35, so i’d guess 1.22 or 1.23 won’t be out for some years yet…

so, it is unclear exactly what you want to do–but if i assume you wish
to install WINE 1.2.2/3 you could go to
http://software.opensuse.org/search, type wine in the search block, spin
the openSUSE version number to 11.4, press “Search” and then look down
the list and spot wine-1.2.3-1.1 which is available in both 32 and 64
bit versions…i’m not exactly sure what will happen if you press the
1-Click, but i guess it will ask if you really want to install older
software over your newer software…

hmmmm…why not go into YaST > Software Management BEFORE you go to
software.opensuse.org, and search there on wine, then right click and
mark it to be deleted, then click Options > Cleanup when deleting
packages and accept all the uninstalls it offers…and then click
the 1-Click and when you get to the part where it asks if you want to
keep the repo, answer NO…

also, the next time you run YaST Online Update it is gonna ‘see’ that
there is a newer WINE than you have and it will try to install it…it
WILL install it if you just click Accept instead of doing your job as
The System Administrator and not automatically install everything the
script want to install…

what you can do is, in YaST > Online Update right click on the newer
WINE package(s) and mark them “Taboo – Never Install” and then click
“Accept”…that red don’t install symbol should persist over boots,
but i have seen it NOT do that, so everytime the machine wants to
automatically update your software you must make sure it is not going
to move back to the newer WINE…

btw, since i’ve not done this myself, and i’m not 100% certain it will
work as i think it will, read my sig’s caveat before you begin…

DD http://tinyurl.com/DD-Caveat
openSUSE®, the “German Engineered Automobiles” of operating systems!

I knew you would have the answer! Thank you! There are several ways to get there, but I think DenverD’s suggestions will get me in the right place quickly. I was using Linux Mint 12 earlier and had Wine 1.22 installed. The program I was trying to run, The Word, worked fine with that version of Wine with no modifications. When I installed openSuse 12, YAST wanted to install 1.3.30. Like a fool, I let it. Just like I’ve heard before, the newer versions don’t always retain compatibility with programs that worked under older versions.

And when I went to try finding an older version, I was having a problem installing over the newer files. Uninstalling in YAST, ended up also uninstalling several other programs like DOSBOX, which I can see having a desire for later.

My wife just let me know it is well after 11pm, so I’ll try this tomorrow, but I just want to let everyone know how much I appreciate the help. I am a power user at least in Windows, but a newbie in Linux. Your help is very much needed…and appreciated.

Merry Christmas!


On 12/23/2011 08:26 AM, crypkema wrote:
> The program I was trying to run, ‘The Word’
> I am a power user at least in Windows

keep it up and you will earn a power user (or higher) badge here
also…it just takes time to work through all the
differences–understand them, know how to use them…and THEN: forget
everything you ever knew about MS-Windows (like me)…

with that in mind see if you can’t find a replacement for ‘The Word’
which is FOSS/linux native software (and not dependent on WINE) here are
2 million hits, several must be good for you:


DD http://tinyurl.com/DD-Caveat
openSUSE®, the “German Engineered Automobiles” of operating systems!

If you like
I can give you a link to a free version of Crossover.
It may work for you

After hours spent trying to get the older 1.2.3 version to install, I went back to the 1.3.35 latest release. There were numerous dependencies that wouldn’t resolve. From what I can tell, the latest openSUSE 12 software has later versions that the older Wine 1.2.3 installer wouldn’t recognize. The Word program still crashed immediately. I had a separate application setting for it in the Wine Configuration. Everything from WinXP and earlier crashed…whereas it has worked earlier with WinME and Win98 with an earlier version of Wine.

So out of desperation, I decided to start at the top of the windows version list and started with Win 2008. It worked immediately! I’m a happy camper now.

Thanks to everyone for your help on this.