wine problem after kernel update


I updated to the last kernel for opensuse1.
I rebooted thereafter and found a problem with wine
With the preceding kernel I could start with windows application via wine using my normal login (non- root);
After the kernel upgrade I can only start wine with root or via konsole + su or kdesu

When i start wine in konsole with my normal user I receive the following error
"wine /diskfat/wingames/wg2/arachnid.exe
err:dosmem:load_winedos Could not load winedos.dll, DOS subsystem unavailable
winevdm: unable to exec ‘Z: \diskfat\wingames\wg2\arachnid.exe’: DOS support unavailable

Is there a solution?
System is
opensuse11.1 64bit + Xen kernel


I hope this helps. I had a similar problem with running DosEmu after upgrading to It turned out that the value of /proc/sys/vm/mmap_min_addr is now set to 65K whereas previously it was set to 0. This prevents DosEmu from running and appears to cause your problem with wine in one of the Ubuntu versions as per this link:

C&C Red Alert under WINE on Hardy Heron

Look under the subheading of ‘Run’ in the above.

I have seen a link that says a very temporary solution is to do:

cat 0 > /proc/sys/vm/mmap_min_addr

as root but I haven’t tried that. I rolled back to the previous kernel version instead, which cured my problem.

After a security upgrade, my Dosemu was busted.
Found this post:
“The temporary solution (lost on each reboot) is to type sudo sysctl -w vm.mmap_min_addr=0
echo 0 > /proc/sys/vm/mmap_min_addr
in console. The permanent solution is Change
vm.mmap_min_addr = 65536
vm.mmap_min_addr = 0
in /etc/sysctl.conf (this file needs to be edited with root permissions,…”
It works. I added the last above line to sysctl.conf. BTW /proc/sys/vm/mmap_min_addr is an empty document!


it worked,:slight_smile: I added vm.mmap_min_addr = 0 in /etc/sysctl.conf.