wine - how to enable multiuser?

Hi lads,

I’m just an end-user, so I apologise if there are stupid questions.

I’m looking for a fair and simple solution to get my wine-programmes working on different user accounts (on one single computer). Is there a special how-to for opensuse?

As far as ubuntu is concerned, I found Howto: Install Wine applications for Multiple Users - Ubuntu Forums yesterday. But beforehand, I had already performed the first steps of LINUX • Thema anzeigen - Tipp: Wine Multiuserfähig machen: created a user “wineuser” and a group “wineuser”, installed wine 1.4 from source within “wineuser”, created /opt/winec, put the /home/wineuser/.wine-directory in it and set permissions (by GUI; I had had a rather annoying accident when using chmod :\ ).

But which type of link from the home directories is required: soft or hard link? And by which command should it be created?

And how do I create a fake-wine-environment for each user?

Thanks for your advice! Have some more happy days of Easter!

#########
Notebook: Lenovo G530 4446-25G — Dualboot: (1) Windows 7 32bit; (2) openSUSE 12.1 KDE 32bit - wine 1.4 (compiled from source)

This should do it, in every user’s homedir do:


ln -s /opt/winec/.wine ~/.wine

If you’re smart, you create a “testdir” first, “cd” into that testdir, and create the link there. Then “cd” into it and you should see the content of /opt/winec/.wine. If that works OK, do it like above in the users’ homedirs.

Thanks, Knurpht! The command worked fine.

Anyone who wants to take part, please look here: WineHQ Forums View topic - Problem: enable multiuser wine

Hallo, folks,

in openSuSE 12.1, I installed wine from the Wine CVS Builds repository. I knew it would work perfectly as of my experience on 11.4. In the end, it does! BUT I tried a different thing - it does run the programme, but only for one user!

To get the programmes installed under WINE working for every user (one single laptop, different accounts), I tried the following recommendation (LINUX • Thema anzeigen - Tipp: Wine Multiuserfähig machen). Each user is supposed to have his own environment and home-directory, but all of them are supposed to share drive_c and the installed programmes.

  1. set up wine for one user (‘wineuser’ who is supposed to act as wine-administrator) and created a group ‘wineuser’
  2. created directory /opt/winec
  3. moved directory tree from /home/wineuser/.wine to /opt/winec/.wine (of course, one can savely choose /opt/wine; and of course, one can create a separate partition for that folder).
  4. set a link from /home/wineuser/.wine to /opt/winec
    Code:
    ln -s /opt/winec/.wine ~/.wine
    Set permissions to owner (wineuser) rwx, group (wineuser) r-x, others r-x

for each $USER
5. built each $USER’s .wine-environment with the fake drive_c by logging into each $USER’s GUI and running ‘winecfg’, but didn’t install any software.
6. moved each $USER’s ~/.wine/drive_c/users/$USER (except ‘wineuser’s’) to /opt/winec/.wine/drive_c/users/$USER. Ownership remained (set permissions via GUI, an abler man should have used chmod). So each $USER is supposed to have his individual profile on drive_c (“C:”).
7. a. deleted each $USER’s ~/.wine/drive_c to replace it by a soft link to /opt/winec/.wine/drive_c (command: see step (4.))
b. deleted each $USER’s ~/.wine/system.reg to replace it by a soft link to /opt/winec/.wine/system.reg (command: see step (4.))
c. left ~/.wine/user.reg for individual registry entries.
d. didn’t perform the following: “if useful or necessary, initialise by a copy of /opt/winec/user.reg”.
8. left any files or folders in ~/.wine untouched.

The author of the above guide argues that there might be problems with system.reg.

  1. installed MS Office 2007 SP3. Word processor etc run fine on ‘wineuser’s’ account, but don’t start on any other account.

Is there a way?

Thanks for any help!!!

#########
Notebook: Lenovo G530 4446-25G — Dualboot: (1) Windows 7 32bit; (2) openSUSE 12.1 KDE 32bit - wine 1.5.1 (installed from community repository Index of /repositories/Emulators:/Wine/openSUSE_12.1 )

Thanks, dimesio, for the quick reply! … Well, if there’s no support, there’s nothing we can do

But in the end - strange enough after what I wrote - it works on any account!!!

However, there are still some problems: I had to try step (7.d.) and initialised the desidered programme by ‘wineuser’s’ user.reg. Then, I still have to find a way how to lauch programmes easily. As for now, on one account, there were no real problems creating links to the *.exe. But on a different account, lauching is only possible if you’re an adavanced user (e.g. via krunner, filemanager or terminal).

Best regards!

WineHQ Forums View topic - Problem: enable multiuser wine