Wine-doors not starting

Hi all,

I’m running OpenSUSE 11.1/KDE 4.2 and Wine runs fine, but I can’t get Wine-doors to work. I’ve tried several of the 1-click installs but after installing it just won’t start. Here’s the terminal output :

PCLinux:~ # wine-doors
Started logging session
/usr/share/wine-doors/src/ DeprecationWarning: the md5 module is deprecated; use hashlib instead
import md5
Checking wine drive: /root/.wine/
sh: --version: command not found
Traceback (most recent call last):
File “/usr/bin/wine-doors”, line 137, in <module>
ui.winedoors = ui.WineDoorsGUI()
File “/usr/share/wine-doors/src/”, line 1106, in init
self.tree = PackTree( self.window’tv_packlist’], self.window )
File “/usr/share/wine-doors/src/”, line 597, in init
File “/usr/share/wine-doors/src/”, line 311, in UpdateAll
File “/usr/share/wine-doors/src/”, line 318, in TidyPacks
wine.WineVersion().split(".") >= pack’versions’][0][0][1].split("."):
AttributeError: ‘NoneType’ object has no attribute ‘split’

Any ideas ?

Uninstall wine-doors.
Add openSUSE BuildService - Wine CVS Build repo.
Install wine-doors version from that repo.

Hm, already tried that, but checked again to be sure, and still the same problem…

Same thing on my side. May be something wrong with python version?

Just for the record.

Running wine as root ist completely insane!

As a temporarily solution could remove this lines of code in the script:

File “/usr/share/wine-doors/src/”, line 318, in TidyPacks
wine.WineVersion().split(".") >= pack’versions’][0][0][1].split(".")

File “/usr/share/wine-doors/src/”, line 323, in TidyPacks
wine.WineVersion().split(".") >= pack’versions’][0][0][1].split(".")

because wine.WineVersion() returns nothing.

There’s someting wrong in /usr/share/wine-doors/src/
this script can’t detect “winebinary” properly
make the detection of wine-version (in fail

manually add “winebinary” value in

same problem, workaround worked for me, thanks!


this workaround worked for me too,

thanks a lot! :wink:

Worked for me too, good job swyear!

same issue here, Ill try that workaround