Wine, Counter-Strike and openSUSE 10.3

Hi all, I’m trying to run Counter-Strike 1.6 in Wine on openSUSE 10.3. The wine install gave me some headaches, but I got past all of that and managed to download and run CS, however, I cannot change the screen resolution from 640x480, even when passing “-gl -width 1024 -height 768” to CS. In the video options dialog, there are no selectable resolutions, just a blank drop-down.:confused:

Any help would be quite appreciated.

I’m not familiar with CS 1.6, but I had similar problem with Team Fortress that turned out to be a driver issue.

I searched the Wine database for 1.6 and found this Wiki.

I hope that helps.

If you need more help, the Wine Application Database would be a good place to look.

Thanks for the quick reply, unfortunately I wasn’t able to find any solutions on said Wiki, and I’ve checked the AppDB to no avail. When you say its a driver issue, could you be more specific? I’m using the One-Click Install nVidia Legacy drivers (96.43.05)

I’ll keep drudging through the net for solutions, sadly passing the -gl and -width -height options seems to have worked for everyone else.

I was and still am using Nvidia 1-click drivers (I don’t currently have Team Fortress installed), but with the wrong drivers, the game had artifacting and showed up like this. As for the no options for screen resolution being available, that I’m not sure about. Does the dropdown look large, like it could fit a couple of options, but doesn’t show any of them, or is there just no space there? I’m sorry I couldn’t be more help, but I’m not too familiar with the ingame problems through STEAM, I’ve only worked with the driver-side issues for STEAM.

So, I figured it out. After extensive digging through the webs, I came across this which in turn pointed me to a solution found here and, while not the best, it works.

In a nutshell: disable your second monitor (I was running TwinView through nvidia-settings) and start your Steam app. If its running windowed, you won’t see any resolutions (and no, its not as if there are options, its completely empty and the dropdown list looks like 1/10 the size of any item that would fit) - at least I didn’t see any modes, but after I switched to fullscreen it went straight to 800x600 and gave me a full list of resolutions to choose from.

NB: I don’t think passing command line arguments helped me at all in this as they seemed to have no effect.

Glad you found it. :slight_smile:

Sorry I wan’t able to be of a help to you, but glad you got it fixed.

How to configure the YaST Firewall so I can join the local LAN server?
I have tried insert in TCP 27020:27039 and in UDP 1200 27000:27015, but still can’t detect the local server.

Anybody knows?