Wine + Command & Conquer

I have EA’s Command & Conquer: The First Decade. I managed to install it via wine and didn’t get any noticeable errors. I can run the “launcher” with wine successfully. When I click on one of the option for which game version both my screens go blank/black and nothing happens and no audio either.

psyber@bitslip:~/.wine/drive_c/Program Files/EA Games/Command & Conquer The First Decade> ls -l
total 40
drwxr-xr-x 3 psyber users 4096 2010-02-15 00:03 Command & Conquer Red Alert(tm)
drwxr-xr-x 3 psyber users 4096 2010-02-15 00:06 Command & Conquer Red Alert(tm) II
drwxr-xr-x 3 psyber users 4096 2010-02-15 00:06 Command & Conquer Renegade(tm)
drwxr-xr-x 3 psyber users 4096 2010-02-14 23:59 Command & Conquer(tm)
drwxr-xr-x 5 psyber users 4096 2010-02-15 00:16 Command & Conquer(tm) Generals
drwxr-xr-x 4 psyber users 4096 2010-02-15 00:18 Command & Conquer(tm) Generals Zero Hour
drwxr-xr-x 3 psyber users 4096 2010-02-15 00:03 Command & Conquer(tm) Tiberian Sun(tm)
drwxr-xr-x 2 psyber users 4096 2010-02-15 00:19 Internet
drwxr-xr-x 2 psyber users 4096 2010-02-15 00:19 Launcher
drwxr-xr-x 3 psyber users 4096 2010-02-15 00:19 support
psyber@bitslip:~/.wine/drive_c/Program Files/EA Games/Command & Conquer The First Decade> ls -l Command\ \&\ Conquer\ Red\ Alert\(tm\)/
total 1333548
-rwxr-xr-x 1 psyber users       1674 1996-11-07 12:16 EDDOS.EXE
-rw-r--r-- 1 psyber users    1161235 2005-10-10 16:03 EDIT.DAT
-rwxr-xr-x 1 psyber users     869888 2005-10-10 16:03 EDWIN.EXE
-rw-r--r-- 1 psyber users     469922 2005-10-10 16:03 EXPAND2.MIX
-rw-r--r-- 1 psyber users     458242 1997-03-17 15:46 EXPAND.MIX
-rw-r--r-- 1 psyber users    2476183 2005-10-10 16:03 GAME.DAT
-rw-r--r-- 1 psyber users      90264 2005-10-10 16:03 HIRES1.MIX
-rw-r--r-- 1 psyber users      83152 1995-05-17 04:10 HMIDET.386
-rw-r--r-- 1 psyber users     261425 1995-02-05 21:00 HMIDRV.386
-rw-r--r-- 1 psyber users      57076 2005-10-10 16:03 LORES1.MIX
-rw-r--r-- 1 psyber users 1331073921 2005-10-12 19:07 MAIN.MIX
-rwxr-xr-x 1 psyber users    2705599 2005-10-10 16:45 RA95.EXE
-rw-r--r-- 1 psyber users       1078 1996-10-15 03:50 RAEDIT.ICO
-rwxr-xr-x 1 psyber users       1678 1997-03-08 16:39 RA.EXE
-rw-r--r-- 1 psyber users       1078 1996-10-15 03:50 RANOTES.ICO
-rw-r--r-- 1 psyber users        995 1997-03-07 07:59 RA.PIF
-rwxr-xr-x 1 psyber users     108498 1996-10-31 11:59 RASETUP.EXE
-rw-r--r-- 1 psyber users      87552 2005-10-10 16:03 README.DOC
-rwxr-xr-x 1 psyber users     244874 1995-08-22 07:31 README.EXE
-rw-r--r-- 1 psyber users      43182 2005-10-10 16:03 README.TXT
drwxr-xr-x 2 psyber users       4096 2010-02-15 00:03 RED ALERT
-rw-r--r-- 1 psyber users         93 1996-11-07 20:06 REDALERT.INI
-rw-r--r-- 1 psyber users   25046328 1996-11-09 17:49 REDALERT.MIX
-rw-r--r-- 1 psyber users      14848 1996-01-04 07:31 RESLIB.DLL
-rwxr-xr-x 1 psyber users      87552 1996-10-28 17:48 RUNGAME.EXE
-rwxr-xr-x 1 psyber users      97792 1996-10-28 17:49 RUNMAP.EXE
-rw-r--r-- 1 psyber users       4192 1996-11-06 11:31 THIPX16.DLL
-rw-r--r-- 1 psyber users      40960 2002-06-03 19:40 THIPX32.DLL

Might not be relevant:
If I run wine RUNGAME.EXE it says that audio needs to be setup up.

I have a laptop with extra an external monitor and sound card.

Have you configured wine using winecfg yet?

I haven’t changed the defaults if that’s what you mean. I’d need to know what’s wrong to find out how to configure around it.

I had to choose an audio device in winecfg.
So choose ALSA and check whether the test-sound is working. Just run winecfg

it is using alsa and the sound does work

bump bump bump bump bump

Fudge it…

Virtualbox+Win XP