WINE can't run LTspice.exe

Hi:

openSuSE 12.3 x64; installed pkgs:
wine-32bit-1.5.31-249.1.x86_64
wine-gecko-1.9-2.1.1.noarch
wine-1.5.31-249.1.x86_64

Attempting to run:
> wine LTspiceIV.exe
fails with an error dialog from the LTspice installer:
Unhandled exception: page fault on read access to 0x00410964 in 32-bit code (0x00410964).
Register dump: [etc. …]

Some past openSuSE versions packaged a WINE which did not work with this program, but the vanilla one from winehq.org worked. Trouble is, this time things are very complicated with all the multi-arch confusion, so I am a bit confused as to how to go about installing or building vanilla WINE.

Thanks if you can help.

On 05/26/2013 12:16 PM, crobc wrote:
>
> Hi:
>
> openSuSE 12.3 x64; installed pkgs:
> wine-32bit-1.5.31-249.1.x86_64
> wine-gecko-1.9-2.1.1.noarch
> wine-1.5.31-249.1.x86_64
>
> Attempting to run:
>> wine LTspiceIV.exe
> fails with an error dialog from the LTspice installer:
> Unhandled exception: page fault on read access to 0x00410964 in 32-bit
> code (0x00410964).
> Register dump: [etc. …]
>
> Some past openSuSE versions packaged a WINE which did not work with
> this program, but the vanilla one from winehq.org worked. Trouble is,
> this time things are very complicated with all the multi-arch confusion,
> so I am a bit confused as to how to go about installing or building
> vanilla WINE.
>
> Thanks if you can help.
>
>

I am not sure if this will help but I had a similar error trying to run
a different program in openSUSE 12.3 and wine. Look at how your home
partition is mounted.

code:

cat /etc/fstab

/dev/disk/by-id/ata-xxx-xxx-xxx-xxx-partx /home ext4
acl 1 2


*much info deleted from the output.

mine had it mounted with the user option. I removed that option by
editing the fstab file as a root user. Then I was able to install the
program with wine.

I hope it helps you.

Eric