windows XP failed, need help accessing the partition!

hey, i just installed opensuse because windows XP broke, but thats not my real problem. the problem is that i can’t access the windows partition. i looked in /windows/c, but all there is is an empty 1.2 gb partition. in the partitioner utility, it says that there is a 131gb partition mounted at /windows/c, and there is an asterisk next to the entry in the list. i assume that it’s because windows didnt shut down correctly, but how do i get to that partition? i have really important data there. if it helps, im running opensuse 11.1 gnome.

Open a terminal and type su, then your root password

Now type:

fdisk -l

post result here

Now type:

cat /etc/fstab

post result

for fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x38eedf0e

Device Boot Start End Blocks Id System
/dev/sda1 1 784 6297448+ 12 Compaq diagnostics
/dev/sda2 2286 19457 137934090 7 HPFS/NTFS
/dev/sda3 * 785 2285 12056782+ f W95 Ext’d (LBA)
/dev/sda5 785 808 184747 83 Linux
/dev/sda6 1285 1380 771057 82 Linux swap / Solaris
/dev/sda7 2034 2285 2024158+ 83 Linux
/dev/sda8 808 1284 3831471 83 Linux
/dev/sda9 1381 2033 5245191 83 Linux

Partition table entries are not in disk order

for cat /etc/fstab

/dev/disk/by-id/ata-WDC_WD1600BB-98FTA0_WD-WMAES3516050-part6 swap swap defaults 0 0
/dev/disk/by-id/ata-WDC_WD1600BB-98FTA0_WD-WMAES3516050-part9 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/ata-WDC_WD1600BB-98FTA0_WD-WMAES3516050-part8 /home ext3 acl,user_xattr 1 2
/dev/disk/by-id/ata-WDC_WD1600BB-98FTA0_WD-WMAES3516050-part2 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

also, thanks for the fast response.

in a terminal type:

kdesu kwrite /etc/fstab

enter password as requested

Change the line for windows to

/dev/disk/by-id/ata-WDC_WD1600BB-98FTA0_WD-WMAES3516050-part2 /windows/C ntfs-3g defaults 0 0


N.B,
if using gnome you may need to use:

gnomesu gedit /etc/fstab

to edit the file

reboot required

no, that didnt work…

i tried twice, the file is edited the way you told me to, but it didnt fix anything.

Posr result of

cat /etc/fstab

/dev/disk/by-id/ata-WDC_WD1600BB-98FTA0_WD-WMAES3516050-part6 swap swap defaults 0 0
/dev/disk/by-id/ata-WDC_WD1600BB-98FTA0_WD-WMAES3516050-part9 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/ata-WDC_WD1600BB-98FTA0_WD-WMAES3516050-part8 /home ext3 acl,user_xattr 1 2
/dev/disk/by-id/ata-WDC_WD1600BB-98FTA0_WD-WMAES3516050-part2 /windows/C ntfs-3g defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

Check this
FSTAB - Editing Manually - openSUSE Forums

and
HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE 10, 11

hmm… i tried everything in those articles, and it still isnt working.

does the fact that the last windows shutdown was a bluescreen have anything to do with the problem?

Unlikely.
Things to check:
Did you make sure there was a empty line at the bottom of fstab?
Did you reboot.

What actually happens?? Doesn’t work is not much to go on.

Yes. Look in the tutorial for these two things: The Force Option and Failed Mounts – Resetting the “dirty” bit.

Here’s a quote from the tutorial:

…Sometimes the drive will fail to mount, as mentioned immediately above. You might get a messages like this one beginning “$LogFile indicates unclean shutdown. Mount is denied because NTFS is marked to be in use…”. These are symptomatic of disorderly processes previously interrupting a clean dismount or shutdown. If you have Windows (2000 or higher) installed or handy, boot the drive in that and allow Windows to right the situation either automatically by running a consistency check on booting or by running chkdsk /f yourself from the command prompt. You can also run chkdsk /f from the repair facility after you boot from the Windows install CD and run to the end where you select to repair the installed system. Failing that you can use the force option outlined just above, but that’s not the preferred option.

The force option tries to force the mount rather than correcting the problem. Resetting the “dirty bit” corrects the problem. I’d recommend you try the reset method before the force method.

that worked perfectly! thanks for all the help you guys.