Windows Shares Samba Issue

Ok, I will try to make this explanation simple. I installed the suse disk, and ran it as a test, everything worked great, wifi, i could see my ms workgroup (other windows pcs), and get into their shared folders, so i fully installed suse. I now cannot access my windows shares. I go to places/networkservers/windows network and nothing shows.
I have not reconfigured or changed any settings in samba, any suggestions are appreciated. i am not to familiar with command line use, so if anyone suggest i try accessing samba from the command line, they may have to tell me the cosmmands to use.


Hi. Welcome to the Forums.
It could be the firewall. Or it could be inability to resolve network names.
Is this openSUSE 11.1?
Did you install it from the live CD?
When you say you could see windows shares and now you can’t, what did you do in between those two situations – what changed, what’s different that you can think of? Did you browse windows shares from the live CD perhaps? Or after installing openSUSE?

1 - firewall: Have you configured the firewall to let Samba communications through?
If that’s a “no”, does browsing in Nautilus improve if you switch the firewall off temporarily with this command in a Gnome terminal:

sudo /sbin/rcSuSEfirewall2 stop

2 - browsing: Please post here the contents of your Samba configuration. You can view the file with this command in Gnome terminal

gedit /etc/samba/smb.conf

Thenyou can copy/paste it back here.

What is the response you get to this command in Gnome terminal:

sudo /usr/sbin/rcnmb status

ok,the firewall termination worked, and I can access mshome (workgroup). however, the suse seems to be running slow and the cursor constantly spins, like it is working on something or locked-up. any sugestions as to how I might speed up things. I am running a notebook, acer, with a pentium dual core 1.73GHz, 5.33 MHz front side, 1MB L2 Cache, 358 Mobile Intel Graphix, and 2GB DDR2 RAM - A 120GB hardrive
I am not running a dual boot so suse is the only software on the notebook.:expressionless:

Thanks for the info, it worked for the network.


This is what I get after using the commands you provided.

rcnmb – here’s a quote from the man page:

nmbd is a server that understands and can reply to NetBIOS over IP name service requests, like those produced by SMB/CIFS clients such as Windows 95/98/ME, Windows NT, Windows 2000, Windows XP and LanManager clients. It also participates in the browsing protocols which make up the Windows “Network Neighborhood” view
rcnmb status shows yours is turned off. So goto Yast → system → system services runlevels: find nmb and smb in the list and toggle them to on, then exit and save.

There are two main things wrong with the [global] stanza in smb.conf.

  1. OpenSUSE has been set to be a “wins server” but no other computers on the LAN have been set to look to it for naming services- so browsing will fail.
  2. You have been into the area in Yast where Suse is configured to be a domain controller – then that was disabled somehow. But the residual settings have remained and will confuse the issue because you don’t have a domain controller – you have a workgroup.

To cut a long story short I recommend you edit the [global] stanza:

printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \%L\profiles.msprofile
logon home = \%L%U.9xprofile
logon drive = P:
usershare allow guests = No
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain logons = No
domain master = No
security = user
idmap gid = 10000-20000
idmap uid = 10000-20000
workgroup = MSHOME
passdb backend = smbpasswd
wins support = Yes
ldap suffix =

to look like this:

printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
usershare allow guests = yes
workgroup = MSHOME
netbios name = network_name_of_your_choice
name resolve order = bcast host lmhosts wins
usershare max shares = 100
usershare owner only = False
local master = yes
preferred master = yes
os level = 65
use client driver = yes

Where do I go to edit global stanza? As you have suggested that I do.

Thanks, Tim :open_mouth:

Open terminal window:
for Gnome:

gnomesu gedit /etc/samba/smb.conf

for KDE:

kdesu kwrite /etc/samba/smb.conf

just wanted to point out the Samba Web Administration Tool (SWAT). It comes bundled with the samba server. Its a web-based interface for setting up your samba server.

First you have to make sure it is on bu going to

Yast → system → system services runlevels: find swat in the list and toggle them to on, then exit and save.

Then, all you have to do is point your browser to:


it can make configuring the smb.conf much eaisier.

in addition to configuring the server, you can start/stop/restart the samba/nmbd/winbind services, view connected machines and clients, disconnect active machines/clients etc.

check it out