Windows OS not present in grub menu

in my new installation of leap 15.6 grub doesn’t show the windows OS, I tried to launch yast>boot manager>check other OS but no success.
I installed leap 15.6 formatting the previous partition where was installed leap 15.5, not formatting the /home and the windows partitions.
how can I see the windows OS in my grub menu?

@pier_andreit Hi, what does the output as root user say for os-prober command.
Can you advise booting method and can you show the output from lsblk command

Hi malcolmlewis manythanks :grinning:
here is 1

localhost:/home/camera # os-prober
393.837084 | DM multipath kernel driver not loaded
localhost:/home/camera #

for the booting method you intend UEFI? is UEFI

here is 2

> localhost:/home/camera # lsblk
> NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
> sda      8:0    0 476.9G  0 disk 
> |-sda7   8:7    0  39.1G  0 part 
> `-sda9   8:9    0 286.2G  0 part /data
> sdb      8:16   0 465.8G  0 disk 
> |-sdb1   8:17   0   500M  0 part /boot/efi
> |-sdb2   8:18   0    16M  0 part 
> |-sdb3   8:19   0  58.6G  0 part /
> |-sdb4   8:20   0  29.3G  0 part /home
> |-sdb5   8:21   0  31.3G  0 part [SWAP]
> |-sdb6   8:22   0 248.9G  0 part /dati
> `-sdb7   8:23   0  97.2G  0 part 
> sr0     11:0    1  1024M  0 rom  
> localhost:/home/camera #

@pier_andreit Can you as root user show the output from efibootmgr -v

Also ls -la /boot/efi/EFI I suspect windows may not be happy trying to boot from sdb…

here is 1:

localhost:/home/camera # efibootmgr -v
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001,0000,0003,0002
Boot0000* Windows Boot Manager HD(1,GPT,ca793884-2a31-4d30-ab68-10a1b1ed0f2b,0x800,0xfa000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS…x…B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}…
Boot0001* opensuse-secureboot HD(1,GPT,ca793884-2a31-4d30-ab68-10a1b1ed0f2b,0x800,0xfa000)/File(\EFI\OPENSUSE\SHIM.EFI)
Boot0002* UEFI: CT500MX500SSD1, Partition 1 PciRoot(0x0)/Pci(0x17,0x0)/Sata(3,65535,0)/HD(1,GPT,ca793884-2a31-4d30-ab68-10a1b1ed0f2b,0x800,0xfa000)…BO
Boot0003* opensuse HD(1,GPT,ca793884-2a31-4d30-ab68-10a1b1ed0f2b,0x800,0xfa000)/File(\EFI\OPENSUSE\GRUBX64.EFI)…BO
localhost:/home/camera #

here is 2:

localhost:/home/camera # ls -la /boot/efi/EFI
total 40
drwxr-xr-x 4 root root 8192 Jun 17 18:18 .
drwxr-xr-x 3 root root 16384 Jan 1 1970 …
drwxr-xr-x 2 root root 8192 Jun 17 18:18 boot
drwxr-xr-x 2 root root 8192 Jun 17 18:18 opensuse

if it could be useful with the previous system (leap 15.5 updated from previous leap) windows booted correctly

@pier_andreit So there is no Windows (Microsoft) folder… You need to get the Windows iso, and run the restore routine to re-install the bootloader/efi files, not sure if it will like not being sda…

What makes you think Windows has been installed in UEFI mode in the first place?

…nothing, I only supposed on the actual UEFI installation and that in leap 15.5 windows worked

@arvidjaar Because the user indicated that this was a previous Windows and Leap install, there is a 16MB partition a sign of a previous windows UEFI install, there is a nvram entry present for both Windows and Leap pointing to same device.

@pier_andreit just to confirm, you just over-wrote the previous Leap 15.5 install… this would indicate on fresh install of Leap you didn’t select expert partitioner and to “not” format the efi partition…

@pier_andreit can you also post the output (as root user) of fdisk -l /dev/sda to see if the disk is type dos or gpt.

yes, I selected to format the old 15.5 partition and installed on it the 15.6
selected to format the swap partition
I selected to NOT format all the other partitions included the UEFI one

here is:
it seems gpt

localhost:/home/camera # fdisk -l /dev/sda
Disk /dev/sda: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: HFS512G39MND-351
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 024D9FE4-0D3C-4846-9BBB-8324AAD10D9B

Device Start End Sectors Size Type
/dev/sda7 317145088 399065087 81920000 39.1G Microsoft basic data
/dev/sda9 400089088 1000214527 600125440 286.2G Linux filesystem
localhost:/home/camera #

@pier_andreit so sda7 is the windows install?

So, AFAIK to fix missing windows UEFI files;

  1. Boot from Windows install media
  2. Open a terminal
  3. Run bcdboot C:\Windows /s Z: /f UEFI (NOTE: Where Z: is the efi esp, in this case sdb1)

You need to see how in Windows to verify Z: is correct.

Suggest you check above is valid, it’s from some notes I had from way back. But it is a Windows issue (now), I’ve never seen the files gone from a Leap/Windows install, but I only have one system with a single disk and have always upgraded…

manythanks I’ll try