Windows not seen in grub


i have two ssd

sda with tumbleweed
sdb with windows 10

boot loader: grub2 for efi
probe foreign os is enabled
osloader return nothing

yast boot-loader don’t see windows

I’m able to access windows disk under suse.

I can see:


it’s a machine i bought (used) and installed tumbleweed yesterday.

NAME                                                     FSTYPE        SIZE MOUNTPOINT                          LABEL
sda                                                                  953.9G                                     
├─sda1                                                   vfat          156M /boot/efi                           
├─sda2                                                   btrfs         408M /boot                               
└─sda3                                                   crypto_LUKS 953.3G                                     
  └─cr_ata-Samsung_SSD_850_PRO_1TB_S252NXAGA13358L-part3 LVM2_member 953.3G                                     
    ├─system-swap                                        swap            2G [SWAP]                              
    ├─system-root                                        btrfs        51.3G /                                   
    └─system-home                                        xfs           900G /home                               
sdb                                                                  238.5G                                     
├─sdb1                                                   ntfs          500M                                     System Reserved
├─sdb2                                                   ntfs        117.9G /run/media/collinm/78E4D7CEE4D78CAE 
└─sdb3                                                   ntfs        890.1M                                     

/dev/sda1: SEC_TYPE="msdos" UUID="440D-FF8F" TYPE="vfat" PARTLABEL="primary" PARTUUID="7108279d-4930-4938-a677-1ff17d0352f8"
/dev/sda2: UUID="24e991d1-861f-4758-9244-923857dd706b" UUID_SUB="59a130ab-e79c-4ad4-8f34-48ac0532883d" TYPE="btrfs" PARTLABEL="primary" PARTUUID="2856bfd2-ac22-44c8-bc22-77bdf22e05f2"
/dev/sda3: UUID="e0eaf3e7-dc99-4ba1-ae96-a38f14370572" TYPE="crypto_LUKS" PARTLABEL="primary" PARTUUID="7633c784-e48c-46ce-8afd-e38052584d1f"
/dev/sdb1: LABEL="System Reserved" UUID="CAB4D479B4D46A09" TYPE="ntfs" PARTUUID="0d538aa6-01"
/dev/sdb2: UUID="78E4D7CEE4D78CAE" TYPE="ntfs" PARTUUID="0d538aa6-02"
/dev/sdb3: UUID="7E50C86950C829AB" TYPE="ntfs" PARTUUID="0d538aa6-03"
/dev/mapper/cr_ata-Samsung_SSD_850_PRO_1TB_S252NXAGA13358L-part3: UUID="WLYXJh-6s9N-GfLj-yRjd-gIwt-Zq2Y-2a6SwJ" TYPE="LVM2_member"
/dev/mapper/system-swap: UUID="4ac61341-8279-4b46-9caa-dfbdc3f168e7" TYPE="swap"
/dev/mapper/system-root: UUID="03d7931a-1729-4df4-a581-6fe41796afeb" UUID_SUB="9b4aa657-ac8a-4216-b45b-c8a702567958" TYPE="btrfs"
/dev/mapper/system-home: UUID="145d1bb3-ee4b-42cb-9af7-9b832a5f989e" TYPE="xfs"

Your drive “/dev/sdb” appears to be using legacy MBR partitioning. And that implies that Windows is set for MBR booting.

You cannot mix and match. If you use UEFI for linux, the grub2 menu cannot boot using MBR legacy booting. It is best to use all UEFI or all MBR booting.

Your choices:

  1. Work out how to manage with the current situation;
  2. Reinstall Windows for UEFI booting;
  3. Switch openSUSE to use MBR booting.

Depending on the BIOS, there might be a key you can use during boot to indicate which system to boot. On some computers, that is F12.

For the third option, you would probably have to reinstall Tumbleweed. You can’t just convert it to MBR booting. Or, at least, you cannot easily convert. You can’t install grub2 to boot from the MBR, because that requires a BIOS-boot partition (sometimes called a grub-boot partition) on a disk with GPT partitioning. And you cannot boot from the root partition, since that is encrypted. I’m not sure if you boot from “/boot”, since that is using “btrfs”.

I guess you could try the third option and see what happens. Go into Yast bootloader. Change the boot loader from “grub2-efi” to plain “grub2”. Tell it to boot from “/boot”. If that gives an error, you are out of luck. If it does not give an error, make sure that there is a box checked to install generic boot code into the MBR. And then you have to tell your BIOS to use MBR booting.

in the windows 10 entry when i clicked on it, get this error…

error file /grub2/x86_64-efi/ntldr.mod not found
error: no such deivce: 78e4d7cee4d78cae.
error: can’t find ocmmand ntldr

think i will just use f12 option… it working anyway