windows network with suse 11

ive got windows xo pro on my office computer on my network through ethernet and a belkin router. i have suse 11 on my laptop (dell latitude d520) which is using wireless through the router.
i need to be able to access my windows pc via my laptop. i also have a epson d78 printer connected to my xp machine i need access to
can someone help me out please

please someone help me

Do you want to share folder and printer?
If yes,please add a user for suse in windows and then check permission.
The folder and printer will display after select Remote Places and then choice SMB Shares on opensuse.

right got my user but cant see any permissions or anything like it.

Searching the web for this same reason I came across this how-to:

Samba and Suse: HowTo Set up an openSUSE-Windows Home Office LAN/Network

But is actually quite long and I thought there should be an easier way to do it.

Basically what I did - and so far it worked for me -, picking-up some general advices from that how-to, was:

  1. Go to System Menu >*System > YaST
  2. Under “Security and Users” choose Firewall
  3. Disable Firewall

Then, still under the same YaST*Menu
4. Under “System” choose System Services

There will be a long list of services
5. Look for “smb” (this stands for Samba) and activate it.

OK, you should be able to “see” your windows network. *At least this worked for me.

Then, if you’re concerned with security, you can go back to your Firewall and mark mark Samba as an authorized service. Please be aware this is how “I” managed to solve my problem (share files under a Windows network), but I actually have no idea of security issues that this might bring.

Hope this can help you!

PS: advanced users, please advice whether this is a “good” solution security-wise.

yes thanx that worked for the network share
just trying to print set up now
thanx again

i can see and enter my xp shared folder but am unable to set up network printer?
in printer set up i chose epson but my d78 isnt listed?
does anyone know how to set up network printers via xp pro sp3

Your driver issue can be fixed by this driver.

sorry to be a pest but the link opens with real player?

got the turboprint, il set it up later, post back if i have any trouble

ok ive tried this turboprint and configured it as best bi know but all im getting is
unable to connect to CIFS host

please anyone help set up my network printer

You can also find out d78 driver here.
Download Inkjet Printer [AVASYS CORPORATION]](