Windows memory dump causes "error 17" in grub 1.5...

Hi all.
I am dual booting windows and opensuse11.
Each partition is a separate drive. Three drives total.
sda - windows C
sdb - windows D
sdc - linux

The problem occurs when windows throws a bluescreen, writes a memory dump, I restart the computer and GRUB throws error 17. Every time.

I am able to fix my MBR and boot loader, but its really annoying and I would like to know why a memdump would cause grub errors. It shouldn’t be writing anywhere near the boot loader.

Is anyone familiar with this or a similar scenario?


Is there a setting in the environment (computer properties) or registry
to disable that feature?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 23:42, 2 users, load average: 0.00, 0.00, 0.00
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Yes there is. I will try this later.
The default path for a memdump is c:\windows\minidump.

As far as I can tell this shouldn’t affect GRUB in any way.
So I’m baffeled as to what exactly is affecting GRUB.

Thanks for the reply.

I wonder if it sets a flag in the MBR to force a check when the system
is restarted?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 1 day 0:44, 1 user, load average: 0.10, 0.06, 0.10
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Hmm, Like a chkdsk…
That is possible. I’ll look around for ways to disable/alter that.

i think its a diagnostic process that happens at bootstrap after anomalous shutdowns and i dont really think it can be disabled. Also, it might cause other problems if you disable it.
I do realize its very annoying, you are right.
Maybe completely unpowering the computer after the crash, that is unplugging, removing batteries if its a laptop, or switching off the feeder if a desktop, would help, as it would discharge the chips (this has the effect of resetting SOME settings to the default, i dont think that flag is reset but it might be. Worth a shot)