Windows media streaming not quite working in Firefox

Hi folks, I have followed the instructions which I have found, and have nearly got Windows media streaming working okay … but it’s not quite there.

For example, the WMV video at plays fine in Firefox, but without sound. There is a volume control button, but nothing happens when it is left-clicked, and a right-click bring up the config menu for mplayer plugin.

However, checking the page source I found the URL for the video stream, and at the command prompt the following played the video fine without sound:


The next thing I tried is the WMA-steaming radio station, where live audio is in a popup window at When the window opens in Firefox, the play-progress box briefly flashes a blue progress line, but then is replaced by a grey-backgrounded word “stopped”.

Again, I checked the stream URL, which in this case is … and at a command prompt a vlc command worked fine:

vlc vlc

So this appears to be an Mplayer or Mplayer-plugin problem, and I haven’t found any specific guidance. Can anyone help to point me in the right direction?

I don’t know how relevant they are to this case, but the following is the result of the diagnostic tests suggested in the sticky post at the top of this forum

linux-mnmh:~ # uname -a                
Linux linux-mnmh #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux
linux-mnmh:~ # rpm -qa | grep alsa                                                                 
linux-mnmh:~ # cat /etc/modprobe.d/sound                                                           

options snd slots=snd-hda-intel
# u1Nb.iJWhLrosxI5:ThinkPad T61
alias snd-card-0 snd-hda-intel 
linux-mnmh:~ #

… and the following is the diag output requested in the Check your multimedia problem in ten steps post:

linux-mnmh:~ # LC_ALL=C zypper ve
Loading repository data...
Reading installed packages...
Dependencies of all installed packages are satisfied.
linux-mnmh:~ # rpm -qa --queryformat '%{NAME} -> %{VENDOR}
' | grep -i VideoLAN
libdvdcss -> VideoLAN Project (
linux-mnmh:~ # rpm -qa --queryformat '%{NAME} -> %{VENDOR}
' | grep -i VideoLAN
libdvdcss -> VideoLAN Project (
linux-mnmh:~ # rpm -qa --queryformat '%{NAME} -> %{VENDOR}
' | grep -i VideoLAN
libdvdcss -> VideoLAN Project (
linux-mnmh:~ # rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} -> %{VENDOR}
' libxine1 libxine1-codecs -> ->
linux-mnmh:~ # rpm --verify --query --all '*xine*'
linux-mnmh:~ # rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} -> %{VENDOR}
' gstreamer-0_10-ffmpeg gstreamer-0_10-fluendo-mp3 gstreamer-0_10-fluendo-mpegdemux gstreamer-0_10-fluendo-mpegmux gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly -> -> -> -> -> -> -> -> ->
linux-mnmh:~ # rpm --verify --query --all '*gst*'
linux-mnmh:~ # rpm --verify MPlayer
linux-mnmh:~ # rpm --verify --query --all '*vlc*'
linux-mnmh:~ # rpm --verify w32codec-all
linux-mnmh:~ #

About no-sound-in-Firefox: are you tried to change your mixer settings? I’m also faced with this problem, everything was on full-volume (Master, Front) except the PCM.

I’ve just put one of your streams into Kaffeine and it played straight away. I always use Kaffeine for streaming and have never had any problems.

Thanks for the suggestion. PCM was only set at half-volume, but moving it to the top made no difference. Still no sound from mplayer-plugin:(

No joy for me in Kaffeine. The video won’t play at all, and the audio stream gets as far as saying that it is buffering, but never produces any output.

this plays, with sound on my Dell Studio 15 laptop, running openSUSE-11.1 on kde-3.5.10 with Firefox-3.0.5 and and

In my case the vlc workaround is not necessary.

I also need vlc for this.

I think for the vlc code, you meant instead one less vlc. … i.e. :


Just checking, but did you download your restricted format files from here? That should ensure you get everything needed to play those streams.

What about checking to see firefox can see mplayer ok by typing about:plugins in the address bar.

There is a new plugin for mplayer that is actually developed by the same person who developed the original mplayer plugin - it’s called gecko media player plugin

it will more than likely solve your problems as the original mplayer plugin chokes on many streams.

Not at home right now so not sure if it is in the repos but here is the developer web page.

kdekorte - gecko-mediaplayer

I got a lot of stuff from packman, per the instructions here. What packages should I download from the Restricted _Formats repository?

I have done that, and it listed mplayer-plugin for all the relevant media types.

Just use the 1-click button and install the whole package for either Gnome or KDE (personally I install both because I use Gnome and KDE multimedia software and its the easiest way to ensure you have all you need for restricted formats).

Which 1-click install for what? b

Thanks for that suggestion. It’s now installed from Packman, but it too plays without sound.

Looking at about:plugins, I see that I now have both gecko-mediaplayer and mplyer-plugin listed as handlers for the same list of media types. When I try playing, it plays with the Gecko-mediaplayer plugin, but although the volume control slider is visible and responses to the mouse, its settings have no effect (silent whatever I do). The process is listed as

gnome-mplayer --window=40380803 --controlid=46689 --width=384 --height=282 --autostart=1 --showcontrols=1

The call to mplayer is:

mplayer -quiet -slave -identify -framedrop -noconsolecontrols -osdlevel 0 -nomouseinput -wid 0x3c0003b -cookies -ass -embeddedfonts -ass-font-scale 1.0 -vf-add screenshot mms://

I have tried calling mplayer from the commandline, but withiut success, so it looks like the problem may be with mplayer itself

They all stream fine for me in Firefox with mplayer-plugin.

All I have for streaming pluginsare mplayer, mplayer-plugin, win32codecs.

Nothing more. :wink:

Choose open
Click next
Choose Customise
Click next
Add Mplayer to be installed (as well as the others already selected)
Click next

enter root password and so on…

Thanks for clarifying that, I had tried that as my first step and it didn’t let me stream anything.

That was when I used the ten steps outlined in my first post, which finally gave me at least some way of laying something … but so far as I can see it will overwrite the libdvdcss and a few of the other packages from VideoLan. And it was installing those which first gave me any working WMV or WMA stream.

Is it relevant that I am running a 64-bit system?

Sorry ClaireM, I have no knowledge of 64bit. Googling brings up a few posts where 1-click of restricted formats has tried to downgrade to 32bit but I’m not sure if that is still a problem. Perhaps someone else can help there.

As a thought, try playing the streams you mentioned after opening kaffeine or mplayer in a terminal. What errors are you getting?

I’d remove mplayer plugin if you have gecko installed. There’s really no need for it as it is superseded by Gecko.
If you right click on the gecko media player once you have a stream loaded there are some configuration options there for audio and video - worth a try