Windows installation giving error :Invalid Partition Table

I have OpenSuse 11.0 installed. when i installed suse i had windows too. but for some reasons i had 2 format windows. since then, after windows setup copies windows files and reboots, i get an error message :** Invalid Partition Table**. also, the grub is gone. i install the grub thereafter , but i really want 2 install xp.
i hv 2 ntfs partitions namel C: n D:
please help me or tell me how 2 play counter strike 1.6 on suse

Are we to assume the partitions C and D are 1 and 2 in the table? XP and Vista need to use the First partition to boot. It sounds like they will be but we need to be sure. And is one the XP actual and the other a Recovery partition?

You said Format. So are we clear here. You Formated the 2 windows partitions as NTFS using the windows cd?

Have look here
GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.

Further to what caf4926 said: can you post the return you get to this command, so I can understand a bit better:

sudo /sbin/fdisk -lu

Plus: were the C & D vista partitions?

And: when you formatted C & D, what tool did you use to format them and what filesystem did you create on them when you formatted them?

yes C and D are partition 1 and 2. D drive just some data…which i dont wanna lose.
this is the output of the command u mentioned:

Disk /dev/sda: 82.3 GB, 82348277760 bytes
255 heads, 63 sectors/track, 10011 cylinders, total 160836480 sectors
Units = sectors of 1 * 512 = 512 bytes
Disk identifier: 0xcfd6cfd6

Device Boot Start End Blocks Id System
/dev/sda1 * 63 20964824 10482381 7 HPFS/NTFS
/dev/sda2 * 20964825 160810649 69922912+ f W95 Ext’d (LBA)
/dev/sda5 20964888 83875364 31455238+ 7 HPFS/NTFS
/dev/sda6 83875428 85401539 763056 82 Linux swap / Solaris
/dev/sda7 85401603 105498854 10048626 83 Linux
/dev/sda8 105498918 160810649 27655866 83 Linux

Disk /dev/sdb: 4072 MB, 4072668672 bytes
255 heads, 63 sectors/track, 495 cylinders, total 7954431 sectors
Units = sectors of 1 * 512 = 512 bytes
Disk identifier: 0x0e440e43

Device Boot Start End Blocks Id System
/dev/sdb1 38 7839719 3919841 b W95 FAT32

In short: install Windows first. If you install it afterwards the code for the bootloader is overwritten.
After Windows install, install openSUSE, it will create a bootloader menu for both Windows and openSUSE.

so do i have 2 format linux partition and then install windows? I dont wanna do that coz there is lot of important data there.

You do not need to reinstall XP. If you look at your output from fdisk , you will see 2 partitions marked Active/Bootable. MS’s boot code in the MBR only permits 1 Active partition or “invalid partition table” will be seen. If you still have XP’s boot code in the MBR, use linux’s fdisk to remove the boot/Active flag on
/dev/sda2 * 20964825 160810649 69922912+ f W95 Ext’d (LBA).

thnks but can u tell me in detail how wud i do that? is there a command for it?

Note: I’m new to linux and not sure if it is fdisk /dev/sda or fdisk /dev/hda. Use the below if you want to boot only into XP at this time.

sudo /sbin/fdisk /dev/sda

this will put you into the fdisk program, at any time you can press m for the help menu.
The commands you will be need are

  1. a–toggle a bootable flag (in Windows it is called Active flag)
  2. w–write partition table and exit
press **a** 

it will ask what partition #

press **2**
press **w**

reboot and if you still have the XP boot code in MBR and not grub , you should boot directly into XP. Later others can help with getting GRUB into MBR and working correctly.

wow. it worked. u all r genius. we did u learn all this.

Your problem is only half fixed, you still can not boot into Suse. It’s likely an easy fix. I have to make a guess, due to Suse making SDA2 Active it would seem that GRUB was put there. If so to get GRUB to work you need to toggle the boot flag off on SDA1 and turn on the flag on SDA2. To do so run fdisk again and enter commands :

partition: 2
partition: 1

That should get you GRUB- boot into Suse first than try XP. You may get the partition error again on the 3rd reboot, if so just do prior fdisk commands on post #10, and post back.

ya…after i installed xp…grub was gone. but i installed the boot loader again using suse dvd. i added windows to the boot loader as a chainloader. now its working fine. suse is default in boot loader.

Good to see it’s all working.rotfl!