Windows flicker & shutter while scrolling down

OR scrolling up. The install was fresh, on a Dell Vostro 1500 Intel dual core(32 bit) which ran opensuse 13.1 perfectly. I noticed the problem started last night after software upgrades listed below. The problem also leave behind a fragmented window until you move the page up/down. I tried switching the kernel back, and it made no difference. Happens with all windows, including Firefox. One strange thing, the problem does not happen when I go into Firefox about:config and scroll down. As soon as I go back to any webpage, it happens.

All installed packages from opensuse & Packman repos.

Tumbleweed 20171205
kde plasma - 5.11.3
kde framework - 5.40.0
qt - 5.92
kernel - 4.14.3-1pae

Also have a problem of crashing once in a while, and keyboard short cuts don’t work…etc…cut, paste , copy


libqt4, libkde4, kernel, and kde4 packages.


what graphic card and driver do you have

sudo lspci | grep VGA

according to these sites,2817,2218214,00.asp
your cpu is 64bit the down side is low amount of ram your laptop has (only 2 GiB)
according to pcmag their Dell Vostro 1500 came with nVidia GeForce 8400M
plasma 5 does not work well with the noveau driver you need the nvidia propitiatory driver
the 8400 uses the G03 driver which needs patching before installing on TW and it needs to be installed the hard way, as I haven’t done that I’ll leave it for someone more experienced to comment about it
for a system with so little RAM you need the propitiatory driver so you can offload a lot of processing to the GPU as pcmag and intel say your cpu is 64 bit I would recommend installing LEAP and getting the G03 nvidia driver for LEAP

you could also go for a lighter desktop I can recommend lxqt with openbox it’s not as flashy as plasma 5 but it will run smoother then plasma 5 on a system with 2 G or RAM and no hardware acceleration

Thanks for the reply. I have 4GB ram, not 2GB.

Output in terminal:

01:00.0 VGA compatible controller: NVIDIA Corporation G86M [GeForce 8400M GS] (rev a1)

This computer worked perfectly with opensuse 13.1. Also, when installing packages, I received a warning about a package that was known to cause system instability and crashing. I forgot what it was. Any idea? Because it was installed. I’ll remove it.

if you have 4 GB of RAM why not install a 64bit OS, the warning you probobly got was regarding the opensource nouveau 3D driver which is known to cause issues with plasma 5 and afaik that’s the reason the 3d mesa driver Mesa-dri-nouveau is packages separately and is not installed by default
there is an issue with older nvidia hardware and the latest kernels the G03 driver needs patching to get it to work see this mailing list post for more info and a howto
I’d still recommend going the LEAP way

To be honest, I thought the Intel Core 2 Duo CPU for my Vostro 1500 was a 32 bit, which is why I installed the 32 bit. The Mesa-dri-nouveau package was the one I saw! Glad you said that. Let me try removing the package.