windows emulation


I’d like to start windows applications especially the Altium Designer whit my openSuse, but that’s not so easy. I tried many programs…
Crossover says, that he can’t load some modules, and if a choose a tutorial under the help menu, it get a message like this
System Error. Code: 161.
Path is invalid at 004142B5.
dxp.exe, Base Address: 00400000.
So i tried to run it whit wine. It dies whit a runtime error, and says that i should visit winehq for futher information.
After that, i launched virtualbox and installed windows xp.The program runs fine, but like slow-motion… this time a think the problem is, that only one processors works under the virtualization and its not enough.
Playonlinux, wine-doors, cedega fails.

Is there any way, that i could use this software without installing a second operation system? I thought about copying the whole windows folder into wine, and somehow rebuilding the registry, but its just a new idea, whit no hope…
Is there any difference if i use for example debian or opensuse whit wine? could it be, that under debian, the programs will certainly run?

System info:
Intel Core Duo processor T2250(1.73GHz) , 2000MB RAM, Intel 950 (graphics card)


You barely cover the basic requirements. System requirements

But the real issue I suspect will be the direct 9.0 stuff. Rather than trying to force the round peg into the square hole use a native app for example gEDA Project’s Homepage no I don’t know whether this is like for like.

My tuppence if your not interested in alternative apps to go with the alternative OS then stick to the OS as well. Virtulisation works but is exceedingly ram hungry and will never utilise the chip to its full capacity. You’ll have a better experience and won’t leave linux with a bad taste in your mouth. With linux you’ll find a lot of times you’ll have to look for alternatives for some that doesn’t work for others it is fine. As for wine, winedb is the best place to look but many times it will involve a few tricks even to get acceptable performance, and sometimes you’ll even get better than native.

In the end it comes down to the commercial software houses write a complaint let them know they lost a sale because of it. The more people that do the more chance in the future Linux will be accommodated.

i use the '08 version, and it worked fine under windows xp. So that’s why i hoped it will run under linux as well.

i used windows and linux together since 1-2 years. i spend most of my time under linux (before suse i used debian and ubuntu). at university there are many programs that we have to use and have no alternative chooses. thats for the altium too. at the laboratory we use this stuff, so i should get used to it. but i dont want to get away from linux. its very boring to reboot the system every time is want to use this program, and after, get back to suse to do everything else. i could also run just windows but we know that is a bad way :slight_smile: so i’m trying to find a solution, even if i have to “force the round peg into the square hole”.

The direct 9 stuff will always be problematic, this was only a brief google DirectX-ToDo - The Official Wine Wiki.

IMO you’ll find less trouble with graphic apps that use opengl due the linux implementation of it. My crude understanding is you’re translating to opengl which can be either fallback mesa(Which I suspect is happening to you) or in driver. Then combined with the fact the minimum reqs it says not to use an onboard, I’m not surprised it is struggling. You have layers on layers and are below the reqs.

You could try vmware-workstation as it has directx support. Check you
host with the following command;

glxinfo | grep direct

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 18 days 19:25, 3 users, load average: 0.06, 0.06, 0.01
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

ok, i’ll give it a try
david@linux…:~> glxinfo | grep direct
direct rendering: No

Well that may be the issue then, on this system I get;

malcolml@oscar-sled:~$ glxinfo | grep direct
direct rendering: Yes

You need to investigate how to enable on intel. I’m using nvidia on
this machine (and SLED11, but equiv to openSUSE 11.1).

My netbook runs intel 945 and it support direct rendering although it’s
running 11.2 RC1.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 18 days 20:29, 3 users, load average: 0.15, 0.05, 0.04
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18