windows doesn't work after first install attempt of opensuse


i bought a computer that is compatible with linux i put a opensuse cd in the cd drive before switching it to the booting drive and now when i try to boot the computer thier is an error message that says pci device not compatible and windows doesnt boot anymore can this be fixed i tried to put a recovery cd that came with the computer in the cd drive but still the same error message and windows cant boot.
thank you for the help

Tell us more about the computer, desktop, laptop??
Compatible with Linux? How did you determine this?

What happen when you boot, with no cd
do you get the green boot screen to choose Suse or Windows?

Does Suse boot OK
If it does, we can work from here

i looked at Hardware for Linux - Systems to find a computer compatible with linux. it is a dell optiplex gx280. the error message that says:

Broadcom NetXtreme Ethernet Boot Agent v7.5.14 copyright 2000-2004
Broadcom Corporation all rights reserved
press ctrl-s to enter configuration menu…

PXE-E01:unsupported pci device!

pops up if thier is a disk in the drive or not

before putting the opensuse 11.0 disk in the computer worked ok

the computer doesnt boot up anymore just the error message

I found this

Set NIC to on with PXE, wont boot to OS, dell dimension 8400 - Cyber Tech Help Support Forums

thank you it worked

Come back if you have any more trouble.