Windows disabled my OpenSuse partition

Hi Friends,

I need some help getting back my OpenSuse OS/partition.

I had a dual boot system, Win XP followed by OpenSuse 11.1 install. I tweaked it a lot to get my wireless card and Nividia card working. Finally got it to a stage where it was working great.

What happened:
For some reasons windows XP had some issues and I had to reinstall the OS. Since I have the openSuse install DVD lying around I took the bold step of reinstalling windows knowing that it will blow away the Grub from MBR. However, during the windows setup, the setup said something about setting the Linux partition as inactive (I think so). Unfortunately, I don’t remember the exact message.

After finishing the XP install, I booted in with the XP Cd and tried the repair option to repair the MBR. That really messed up the MBR. So much so that booting back with XP boot CD and running fixmbr didn’t work. Finally reinstalled windows again.

Now I am not sure what should I do next. I tried using the superGrubDisk but it gives the following error:
Error 15 File not found.

Sorry for the long post, but any help recovering my Linux partition and resetting GRUB?


Some more info:

I tried booting in with the OpenSuse 11.1 DVD and chose repair -> Advance Repair tools
When I select the partition manager, I can see my Linux native and Linux swap partition (along with the Windows partition).

However, when I try to select, boot into existing linux OS (or something similar), it fail to boot giving an error root partition not found.

If you have the openSUSE install DVD, boot from it and on the first menu of options select the Rescue System option. That will start an elementary Linux Live operating system and bring you to the login prompt. Enter the username root and you will be at the command prompt with rootly powers and ready to proceed.

First find the openSUSE installation:
You enter this ---------------- grub
Computer returns like this ---- grub>
You enter this ---------------- find /boot/grub/menu.lst
Computer returns like this ---- (hd1,6)

Here, (hd1,6) is Grub’s pointer to my openSUSE installation on drive number 2, partition number 7. Your pointer will be different from my example (hd1,6). Substitute your correct values for my example (hd1,6). Now that you have your pointer, proceed like this:
You enter this ---------------- root (hd1,6)
Computer returns like this ---- Filesystem type is ext2fs, partition type 0x83
You enter this ---------------- setup (hd0)
You see 4-5 lines like this — Checking if /boot/grub/stage1 exists … yes
Computer finally returns this-- Succeeded…Done
You enter this ---------------- quit
You enter this ---------------- reboot

The computer should reboot and present you with the Grub boot menu, from which you can boot into openSUSE.

Credit @swerdna from here:
HowTo Boot into openSUSE when it won’t Boot from the Grub Code on the Hard Drive

What I usually do when that happens is:

  1. Run the DVD install.
  2. After some steps, there will be a choice called “start/boot the installed system”. It will start the opensuse on the hard disk directly.
  3. Inside opensuse, start yast.
  4. Go to “System->Boot loader”
  5. Directly click ok.
    This will reinstall the bootloader.

This is a bit longer than the solution up there, but at least it doesn’t need you to remember which commands to type in grub.

Thanks caf, yesterday night I followed the same exact steps from Swerdna wiki and it worked like a charm. Sorry, should have posted the success earlier. Thanks for the reply.

Vince, I tried the approach you suggested. However, the boot Disk won’t boot into the installed OpenSuse.

You should not select the “Boot from Hard disk” grub menu item, but go through the regular openSUSE installer, until it provides a selection like “new installation”, “upgrade installation” and one is “boot existing system” (might be hidden in advanced/other).
Not sure whether I made it clear before.

Another way which might work is also to boot a live CD, mount the openSUSE root partition, then chroot into the mount point. Then in the chroot env, also mount the boot partition (if available), then mount the proc partition to /proc. Then run yast to restore the boot loader. I don’t remember exactly whether that worked, I just remember doing the chroot some time before to fix some boot issues.

metalinjury want the link or the steps coz I have problem like this , thank you

What is your problem…