Windows 98 failed to boot very early (Grub, OpenSuse 11.0)

I’m not sure yet if it’s a bug when Grub was installed, so I’ll ask here first.

For the first time since I installed OpenSuse 11.0 (to replace Suse 9.3) about a month ago, I tried to boot my old Windows 98 from Grub. But now, as soon as Windows start booting, it stops with error messages saying Windows cannot find EMM386.EXE and HIMEM.SYS, and end with a DOS prompt line. From there, I could check and see that the files AUTOEXEC.BAT, CONFIG.SYS, WINDOWS\EMM386.EXE and WINDOWS\HIMEM.SYS are really there where they should. :frowning:

At first, this is looking like a problem from Windows and has nothing to do with Linux. BUT my Win98 partition was properly booting from Grub (Suse 9.3), and I haven’t touched the partition since I upgraded to OpenSuse 11.0.
THAT makes me wonder if there was something wrong when v11.0 installed the newer Grub.

Actually, /boot/grub/menu.lst has this:

###Don’t change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd1,0)
chainloader (hd0,0)+1

(I’m pretty sure the older - 9.3 - menu.lst had “root (hd0,0)” as first line for the Windows section. But I don’t remind what else was following.)

From /boot/grub/ :

(fd0) /dev/fd0
(hd1) /dev/sda
(hd0) /dev/sdc
(hd2) /dev/sdb

Any clues on what could be wrong and/or where/what I should check?

I’ve just seen that someone else has already reported a similar problem to mine.
See the “10.3 install screws up W98SE dual boot” thread at
10.3 install screws up W98SE dual boot - openSUSE Forums

One of the suggestion I read is to edit CONFIG.SYS and add the option “/A20CONTROL:OFF” to the HIMEM.SYS line.

Maybe I’ll try that…
But why is it I have to edit now a Windows config file that was working fine until the OpenSuse 11.0 installation.

Could have the installation modified the BIOS ?

(Maybe a stupid question but ) Is it safe to edit the CONFIG.SYS file from Linux ? (I read in the other thread that the poster has lost his config.sys)

Other chap has same problem. I think you’ll need to find a Windows guru to explain this one. Obviously the BIOS is involved and the best I could do was point the other chap to some articles that might be of help.

GRUB in the MBR must displace some necessary code that is needed by Win98. I used to dual boot that stuff but I can’t remember and specific problems. I know I booted both ways, and it worked.

You might restore the Win98 MBR and then boot SUSE from the Winloader. Or, you can find another place for GRUB. Check the links I provided for the other chap.

Got 2 threads for same thing running here.

> Got 2 threads for same thing running here.

Ok, I’ll post on the other thread here :
10.3 install screws up W98SE dual boot - openSUSE Forums

Thanks for your reply.