Windows 8/12.3 dualboot - UEFI and Secure Boot issues foreseen

I have a Toshiba C850 satellite laptop which comes with Windows 8 pre-installed.

The laptop bios is UEFI compliant (as Windows 8 requires) and uses Secure Boot to protect against viruses.

I want to convert it to a dual-boot system - WIndows 8 and Opensuse 12.3.

I haven’t yet started but have just ordered a 12.3 DVD. I envisage lots of problems so this post is a request to help resolve those problems before I start.

The laptop will not recognise bootable DVDs unless I do 2 things in the BIOS - firstly disable Secure Boot, and secondly turn off UEFI mode (in other words enable legacy BIOS mode - known as CSM Boot). With these two configured, bootable DVDs are recognised by the laptop, but Windows 8 is no longer bootable!

So…
question 1 : if I install 12.3 will I no longer be able to boot WIndows 8?
question 2: in order to install 12.3 do I have to disable Secure Boot in the BIOS, and do I have to disable UEFI mode (ie enable CSM mode)?

I will copy the Windows 8 recovery paritition to a USB drive so can then delete the partition on the hard drive which will free up space to install 12.3 (if this indeed is possible).

I guess my general question is this - 12.3 claims to support UEFI and Secure Boot. What do I need to do to install it alongside WIndows 8 to get a properly working dual-boot system given the problems I have encountered about how to boot from bootable DVDs on the laptop I have?

On Tue 28 May 2013 01:26:01 PM CDT, spkrupa wrote:

I guess my general question is this - 12.3 claims to support UEFI and
Secure Boot. What do I need to do to install it alongside WIndows 8 to
get a properly working dual-boot system given the problems I have
encountered about how to boot from bootable DVDs on the laptop I have?

Hi
Are the bootable DVD’s your trying setup for secure boot? If not that’s
the reason you need to disable for booting. The openSUSE DVD will boot
in secure mode and UEFI if present.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.4-desktop
up 12:35, 4 users, load average: 0.27, 0.43, 0.39
CPU AMD Athlon™ II P360@2.30GHz | GPU Mobility Radeon HD 4200

My BIOS is a little different. It has a compatibility mode where it does UEFI but it can also boot MBR based systems. (It’s a Dell).

If I put a typical DVD in the drive, and hit F12 to get boot options, it boots straight into windows.

If I disable secure-boot, then hit F12 during boot, I do get boot options. First there’s a list of UEFI boot choices, and then there’s a list of MBR boot choices.

I didn’t actually try 12.3 with a DVD (I used a USB instead). I can leave secure-boot turned on, and hit F12 during boot. And, because 12.3 supports secure boot, I do see an option to boot it under UEFI choices. (There aren’t any MBR choices with secure-boot enabled).

My best guess is that the 12.3 DVD will work fine for you, with both UEFI and secure-boot enabled.

Here are a few catches to watch for:

In the boot settings for installing, there’s a box for secure-boot. Make sure that you check that box. It is not checked by default. If you don’t check it, you won’t be able to boot 12.3 unless you disable secure-boot.

If the installer wants to mount the existing EFI partition to “/boot/efi”, then make sure that it does not try to format that partition (that would mess up Windows).

Some people find that everything works until they boot into Windows. And, after that, they can not longer get into linux. You might want to take a look at my blog post Notes on UEFI, Windows and linux which mentions that problem.

I had no problems installing opensuse 12.3 onto my uefi based systems which had windows 8 already installed using the dvd. I had already switched off secure boot - prior to opensuse 12.3 being released.

the opensuse 12.3 boot menu automatically adds a windows 8 entry (using grub2-efi). My uefi boot option settings have windows 8 or opensuse. I have opensuse as the default which brings up the grub2-efi menu - which lets me choice opensuse or windows 8. The opensuse boot settings were added to the efi/boot partition.

If you hit any problems post back with details.

thanks to all for input.

Here’s an update :

  1. Started with 750GB hard disk with Windows 8 pre-installed
    4 partitions - 450MB Recovery Partition, 260MB EFI Partition, 687GB Windows Partition, 10GB Recovery Partition
  2. Shrank Windows Partition to 250GB
  3. Saved 10GB Recovery Partition to USB drive 1
  4. Deleted 10GB Recovery Partition - now I had 450GB unallocated disk space
  5. Backed up all important Windows User files onto USB drive 2
  6. Made sure that Secure Boot and UEFI Mode were both enabled in BIOS
  7. Booted (without any problems) from opensuse 12.3 DVD
  8. Enabled Secure Boot in installation software
  9. Installed (took 22 minutes from starts to final login) - no issues except when it asked to reboot and didn’t warn me to remove DVD, so had to manually remove it and reboot again
  10. Opensuse 12.3 boots fine in Secure Boot/UEFI mode as does Windows 8

The only thing I now have to do is to find out how to start NetworkManager service!!!
Once again thanks to all who gave advice - it couldn’t have been easier!
Steve

Check the Release-Notes.

Here’s an update.

Have spent the day quite happily booting between Windows 8 and 12.3 Opensuse until…

Was in Windows, restarted to get to 12.3 at which point Windows decided to do 4 updates - fine, that’s what it does. When they had finished I booted to 12.3 and installed emacs and Thunderbird along with a number of other packages the system wanted to install (total of 33 packages).

I then did a system update when 86 patches were installed including

  • a new kernel
  • a patch to shim
  • a patch to grub2
  • and all the rest

The system then requested a reboot, which I did, and lo and behold 12.3 had disappeared and the laptop would only boot into Windows - no shim, no grub menu, just Windows.

So instead of panic’ing (!!) I turned off Smart Boot in the BIOS menu and lo and behold the grub menu reappeared and I can now boot both again.

Something that was installed during the sequence I described above killed the ability of the laptop to recognise shim/grub/12.3 as a Smart Boot compatible system - shim update? grub update? new kernel?

Can anyone help? I have a working system but I would like to understand what broke!
Thanks

I don’t know your BIOS, so I can’t be sure of what specifically caused your problems. I’m also not sure what “Smart Boot” entails.

I can tell you roughly what happened.

The grub2 update caused grub2-efi to be reinstalled (in the sense of setting up booting again).
The “shim” update likewised cause it to be reinstalled.
The kernel update caused “mkinitrd” to be run, and when “mkinitrd” is run, grub2-efi is installed again – (parenthetic remark: I consider that to be wrong, a terrible idea; it should just run “grub2-mkconfig” and not try to reinstall grub2-efi).

Overall the grub2-efi booting was reinstalled several times. Each such install makes a call to the UEFI firmware, asking to put data in NVRAM.

The result - the behavior you saw - is how the UEFI firmware reacted.

My BIOS would have reacted differently from yours, but it would still have caused me problems such as only being able to boot Windows.

Could also be the Windows update turned smartboot on.

but nooo… MS would never do that…would they?

to nrickert: thanks a lot for your link and Infos in it.

You’re do-list above is probably an approximation, but you don’t say that you have disabled Fast Startup and Hibernation from inside W8. If you don’t do that, W8 will give you problems wrt EFI/Grub-2 booting some time in the future. Take a look here (the “Preparing Windows 8 for dual-booting”, item 4 -part): https://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/487837-how-dual-boot-preinstalled-windows-8-linux-uefi-etc.html#4. You need to disable both in the way shown. You may also want to take a look at posting #6 in the same thread.

Good luck!

dayfinger

Ha ha. I see that the quote above was a bit old, and you probably already did what I suggested above, but my comment is still valid.

dayfinger