Windows 8.1 Dual Boot Install Advice?

I’ve just bought a new laptop, a Lenovo Ideapad S210t, with Windows 8.1 on it (upgraded from 8).

I want to put opensuse 13.1 as a dual boot on it, but the problem I have is it has no less than
EIGHT partitions on it, which seems completely ridiculous to me:

Fortunately I first took a disk image of it using Clonezilla before fiddling about.

I shrank the C: drive to half its’ size and deleted the D: drive, making what was D: root, and home for the other
half of C:

I installed opensuse off a USB stick, but it failed to reboot after the initial install.

Looking back, I realised the install was complaining about root being too high a partition number (above 3),
so I imagine that’s why it failed.

I then tried a second install with boot from MBR enabled, but this time Windows wouldn’t boot.

At this stage I restored the disk image and am now back to plain old Windows.

Is the only way round this to shrink the C: drive, then move the partitions up the disk so that
I can create a root partition with a partition number of 3?

I assume I would also have to edit the Windows boot file to point it to the right partition,
as it would then have a different partition number?

The position should not be a problem on a modern machine the warning is meant for older machines who’s BIOS could not handle large partitions

You must install EFI mode if Windows is instilled via EFI which by default it would be. Without being able to look over you should it is difficult to guess what you did.

  1. provide the free space to use Linux ie resize/remove partition to give free non-partitioned space
  2. boot the install media in EFI mode note you may need to press F12 or other key to get to the BIOS boot menu (check docs on machine for the right key)
  3. it should be automatic but check the following correct if needed ( be sure to check the check sums and if using DVD run media check)
    a) boot loader is grub2-efi
    b) the EFI partition is mounted as /boot/efi and format set to FAT but not set to be formatted (unless this is a fresh install on a totally empty system)
    c) the secure boot box is checked ( note you have to do this one)
    d) 3 new partition for openSUSE swap (1-2X memory), root (20-30 gig), home (rest of provided space)
    e) be sure that the installer is pointing to the hard drive and not the installer if using USB
    If you follow this then you should have a good install
    Now that should install openSUSE. but some new machines seem only to want to boot Windows
    If you follow the above and still no boot again start the boot selector in the BIOS and see if openSUSE is in the list. If so you should be able to set it as default and boot it. Some EFI BIOS seem to want to put Windows first no matter what. If this happens there are tricks that can be used t work around the stupid BIOS

Thanks very much gogalthorp, that worked.

I had changed the boot type in the BIOS to “legacy” rather than uefi when booting from the USB stick.

By changing it to uefi and selecting boot from USB using F12 everything worked from then on in.

Cool mixing modes is not a great idea. In theory some BIOS say they support it but it seems like a lot of trouble even if it might work.


It is pretty much bound to fail, unless you boot from the MBR. That’s because the usual boot code in the MBR is unable to read the GPT partition table. To boot from a partition, you would need hybrid partitioning so that both the MBR and the GPT partition tables list the boot partition.

And, as you discovered, if you use any kind of traditional legacy booting, then you will have problems booting Windows. So going all EFI is the way to go.

I’m glad it has now worked out for you.