Windows 8.1 and Opensuse 13.1 Dual-Boot

I was hoping that someone could direct me into how to accomplish dual booting Windows 8.1 with Opensuse 13.1. This is on a brand new computer so both OS installs would be clean installs.

I tried to do this already, but to no avail. What I had done is as follows:

  1. Partitioned my hard drive
    • I made an extended partition, and then broke that up into three (swap, root, and home)
    • Made a Windows partition
    • Final partition would be a common NTFS partition between the two OS’s
  2. Installed Windows 8.1 (it made a smaller MSR partition and a larger partition for everything else)
  3. Tried to install Opensuse 13.1
    • Told it to use the previous partitions which I made
    • Everything else was fine, except I changed the bootloader to GRUB2-EFI. It said, “unsupported combination of hardware platform x86_64 and bootloader GRUB2-EFI”

As expected, it was complaining about the bootloader, mainly about how a distributor ID was not specified, but I could not find anything about that. Looking more thoroughly through the bootloader options, there was an empty field: Default Boot Section.

Windows works perfectly fine still, but no Opensuse.
Just about the motherboard, it’s an Asus Z87-A, BIOS Version: 1207 x64, Build Date: 07/01/2013

Also, I currently have no internet connection with the new computer, so doing anything requiring one is out of the picture right now.

Hopefully this is enough information for now. Any help would be much appreciated.

Installing Windows and opensuse on a computer with one hard drive is more of an art than science. It was this way since Windows XP, and recently the task became substantially more difficult. Manuals give only general guidance and rarely are enough to install. Expect to do a few installation attempts until you succeed.

For the beginning, try to install opensuse alone. Make a small installation. Let the installer do as much automatically as it wants. This shall take less than one hour. Try GRUB, GRUB2 and others. Most should work.

Note the functional boot settings.

If you can, erase the HD using Live opensuse. This will remove the partition table. Windows’s installer is sensitive to existing partition table. This step is questionable. If you cannot issue the dd command, ask.

Install Windows. Let it partition the HD as it wants. After checking that Windows works, if you can, defragment the large partition.

Attempt to install opensuse. Don’t select many packages. Don’t let auto istall run. Do the partitioning manually and squeeze the Windows’s NTFS partition. Try all boot loaders, including GRUB.

If all this fails, report here. Somebody more knowledgeable may direct you to manuals or give advice.

You can try my how-to here:

It handles openSUSE 12.3/W8(.0), but the differences between that and openSUSE 13.1/W8.1 is not significant. I have made a few comments about some of the differences here:

Some comments to the setup you describe:
If you have W8.1 preinstalled on your HDD, you cannot use the partitioning you describe (extended partition is MBR partitioning). Preinstalled W8/W8.1 is always GPT partitioning, and your computer will be UEFI equipped having SecureBoot enabled. You can disable SecureBoot, but see my comments regarding that in the links above.
So I take it that you have W8.1 readily available on a DVD for installation.

Provided your harddisk is less than 2.2TB (2.0TiB) in size, you can use MBR. If not, you need GPT partitioning to make use of your disk’s full capacity. For the sake of discussion, let’s assume your disk’s capacity is less than 2.2TB:
In that case, you can choose between MBR and GPT partitioning, and you can choose between UEFI and CSM setups. It is your choice. However, UEFI/GPT is the future, and gives quite a few interesting options not available with the older CSM/MBR setup: Multibooting OS-es is made easier by the ESP partition, and the concept of the Extended Partition is gone. You can practically have as many primary partitions as you want (with W8 installed, the upper limit is 128).
The drawback is a transitional one: These are the early days for UEFI, and there are some differences between the many vendor’s implementation of it. You may be one of those, but you also may not. I recommend to give it a try. If you get any problems, post back in this thread and explain, and we will try to help you out. I would say that the “risk” :wink: of being successful with UEFI/GPT in the end is pretty high, and the the award is that you are prepared for the future. An added bounus to do it now, is that you probably get better help to adjust for it now when the community here is prepared to handle it.

Tell us how you did. Good luck!


After a re-read of your OP, I recommend the following:

  1. Start again, erase everything from your harddisk - including partitions.
  2. Make sure UEFI is enabled (as opposed to CSM) in the “BIOS” setup.
  3. Ditto enable SecureBoot.
  4. It is generally recommended to install W8.1 first, as it doesn’t behave nicely with regards to other OS-es installed. So:
  • Install W8.1 and let it handle disk partitioning. W8.1 will select GPT partitioning, and will suggest the full disk’s capacity for itself.

  • You may accept that, but W8.1 will be a tad more efficient later on if you at install-time let it have only the part of the disk you later plan for it to have. You will also do without shrinking the W8.1 partition(s), which introduce its own set of challenges.

  • We’ll make adjustments to W8.1 after it has been successfully installed anyway, and the space for W8.1 to use can be part of that.

  1. What you have now, closely resembles a system with W8.1 preinstalled. Now, do as I suggest in the first two paragraphs above.


Have a look at this guide …
Linux on UEFI: A Quick Installation Guide

Something you could also do, with Win-8.1 installed, and openSUSE-13.1 installed, but only Win-8.1 booting no matter what you try, is contact our forum for help how to sort this situation. Many of us have encountered this scenario, and there are fixes possible.

One thing that is useful, is after this situation is encountered, is to boot to a live DVD or liveUSB stick of openSUSE, and then send some diagnostic commands to better understand why grub2’s efi setup is not working with the PC’s motherboard UEFI implementation. Our membership can provide the commands to you, if and after you report this situation.

Best wishes and good luck.

Alright, so I decided to restart from scratch. Reformated my drive, installed windows, then redownloaded and reburned the 13.1 iso disk. Thankfully, everything worked fine the second time around and UEFI is working properly. I’m assuming that I unknowingly messed up somewhere in the process which caused the original problem. Either way, thanks to everyone for replying and trying to help out, I really appreciated it.

***“EFI distributor id isn’t specified message.” *** Solution for my ThinkPad Edge E540
Restart with SuperGrubDisk2: Rescatux

  • [Detect any Operating System]
  • Start SuSE
  • mount “Efi System Partition (ESP)” to /boot/efi/
  • install Bootloader with Yast bootloader installation (grub2-efi) or
grub2-install --target=x86_64-efi /dev/sda
  • Have a lot of fun


I have a problem with installation of opensuse 13.1 on my new computer with windows 8.1. I have tried with secure boot enabled & disabled, with and without UEFI boot, but I always get the same error (in attachment). I tried making bootable USB from windows and opensuse 13.1 (on my other computer), with different software, but it is always the same.

I tried Xubuntu 14.04 installation, and it was OK. I had no problem to start opensuse 13.1 installation on my other computer (HP probook 4530s), so I think my bootable USB is fine, but I can’t tell where is this problem coming from.

Could you please help me with this?

CPU is AMD A10-7850K and MB is Asus A88XM-plus](

Thank You,

You should start your own thread, instead of trying to add to another thread. You very likely have a different problem.

Looking at your graphic, I do not see any obvious problem. When I boot the installer (using a USB), I get the same “polkitd” message that you are seeing. Then I get a similar message “Found a linux terminal …”. And that’s when the graphic installation screen appears.

My best guess is that you have a graphics problem. This often happens with nVidia graphics and sometimes with Radeon graphics. The solution is to boot with “nomodeset”, and then install proprietary graphics drivers later.

Boot your USB in UEFI mode. On the boot menu screen, use the “e” command to edit the boot command. Scroll down till you find a “linux” line (it is probably a “linuxefi” line). Then append “nomodeset” (without the quotes) to the end of that line (with a blank separator). Then hit the key to continue boot (it will say on the screen). Hopefully, you will be able to install that way.

If you are still having problems, then:

  1. Start a new thread with a distinctive title;
  2. Add a link to this thread (if you know how);
  3. Tell us what graphic card you are using, in addition to the other hardware details that you have given.
  4. Mention what you have tried and what happens (I’m guessing that you got a blank screen).

This solved my problem, thank you very much. I booted installer with “nomodeset” and managed to start installation.

This is how I got OpenSuse to dual boot with Windows 8 in UEFI Mode:


Actaully this is fairly simple and nothing to sweat generally. I’ve only had trouble with it

I have been dual booting windows and opensuse for several years now and building systems from scratch all that time. There is nothing magical or even difficult in duel booting a computer with windows and linux. The best way to do the job is to install WINDOWS first then install linux allowing the linux installer to handle setting up your partitions and boot loader. I always use the default options in the installers and have few if any issues.

This has rarely taken me more than 2 hours to install both operating system and the boot loader. With windows 8.1 it is a little harder but if you set your bios to use legacy partitions even that becomes simple. If you do this you should be able to get it installed first time every time with little if any difficulties assuming you dont’ use JOES hardware that is unsupported by the operating systems.