Windows 7 will not connect with VNC

This is totally weird, have never had this problem, until I upgraded to opensuse 11.3.

I try to connect to my opensuse 11.3 desktop with my Windows 7 notebook, but I keep getting a wrong password error, I have re-entered the password many times, even tried different passwords on my opensuse desktop, it never helps. I keep getting a wrong password error. I have tried tightvnc and realvnc both on my Windows 7 notebook, and still can’t get it past the login screen. I am at my wits end, please help.:frowning:

There are three flavours of vnc server available on openSUSE (and realvnc brings in a fourth). So please describe one of them and how you installed it, how you start the server for that flavour and what login screen you get.

Or if you just want to start again and follow one that does work, this might be worth a read: TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)

I’m using TightVNC (my altime favorite, and up until now the easiest to use), everything looks fine on my Opensuse Desktop, but on the Windows 7, I can’t get past the login screen.

BTW, used the default distro to install (used YAST), which is usually the best way to ensure it works right.

You should run the command to reset the password, here it is: vncpasswd
Run it as a normal user, yourself, not as root.

Still no joy, keep getting wrong password, even after resetting it.

Here’s a test that narrows the problem to either the server or the client. On the openSUSE server, run this command:

vncviewer a.b.c.d:1

except of course using the correct IP address instead of abcd and the correct channel number if it’s not :1. After that you’ll know if you have to look in the win 7 machine or the Suse machine.

I assume you’re talking about the VNC password and not the machine’s User Account username/password.

Have you tried setting the password to 6 characters or less?
(Is one of the reasons why I dislike using VNC)