windows 10 update on dual boot system

on one of my systems I dual boot with openSUSE 13.2 and Win 7.
I rarely use win7 - perhaps booting into it once every three or four months.
However, I try to keep it up to date and from today it has been prompting me to update to windows 10.

I’m kind of curious to see what it is like but concerned about how it will effect my being able to boot into openSUSE. I’m sure it will take over grub.

Anybody who has tried to upgrade and able to provide any hints / tips / suggestions and give any information on what I will need to do afterward to get my true dual boot system back in place (assuming win10 takes control of the boot system)?

I dual boot Win 8.1 and opensuse on my main desktop, Win 7 and opensuse on my laptop.

I’m not particularly concerned with problems. However, I am holding off the Win10 upgrade until I hear more reaction from users.

Where is grub installed? (In the MBR or in a partition?)

For my Win7 system, grub is installed in a partition (actually “/boot”). My expectation is that if I upgrade, I will then have to change the active partition so that I can get back into opensuse.

If, however, you have grub installed in the MBR, then Windows can cause greater problems. If I were in that situation, I would probably do:

# dd if=/dev/sda of=backup_MBR count=1

to save the MBR content into a file. I would save to an easy to find location (perhaps even a USB).

Then, after the upgrade, I would boot linux live media and try:

# dd if=backup_MBR bs=440 of=/dev/sda count=1

to restore the MBR content. I don’t know if that would actually work. Grub uses the unassigned space between the MBR and the first partition. I don’t think Windows overwrites that, but if it does then a grub reinstall would be needed.

There’s another possible problem. Windows might add partitions and change the partition numbering. In that case, it is necessary to also edit “/etc/fstab” (or, maybe not if it is using UUID for mounting).

If your box uses UEFI, then the problems are different.

Assuming mbr boot and NOT EFI boot Windows tend to take over. In fact it may do so with a UEFI boot also by a total rewrite of /boot/efi

If you want to peek at it do so in a VM much safer

I didn’t make any changes from the default during the recommendations during install so I believe grub is installed to the root partition (?) if I remember correctly.
no efi here

ok if you did not install grub to the MBR Windows in theory should do no more then change the boot flag. I still say if you only want to look at it and kick the tires install to a VM.

Glad you started this thread. I dual or even “duel” with 13.1 and Tumbleweed against Win7 but haven’t seen the Win10 prompt yet, maybe waiting for me. Probably on the same model of ThinkPad if you still have yours?

T’weed controls grub in a separate /boot partition so expecting boot flag movement at least, so gparted on rescue media at the ready. :wink:

I’ve done exactly what you are pondering. I have TW and Windows on the same SSD and use grub2 for dual-boot, installed to root. I just completed the Win10Pro upgrade to the Win7 partition and other than being a bit slow, worked like a charm and no ill-effects with grub2 and the dual-boot set up. I think the Win10 upgrade rebooted the system 5 or 6 times before completing, including my upgrade to the latest AMD video driver.

yep - still same thinkpad :slight_smile:
Think I’m gonna hang back for a bit to see what others experience . . .
But if all it takes is re-establishing grub2 as the bootloader with a rescue / live CD then that seems like no big issue.

so it didn’t touch grub2 at all and left it in place as the bootloader? Nothing outside of the windows partition (including mbr) was touched?

Fascinating! Anybody try the upgrade with an efi partition yet?

I for one suspect the worst. With Win 8.1, I had to reinstall GRUB2, IIRC.

Yes, I was amazed as well. I had fully expected to live boot a rescue and reinstall. I’m assuming it’s because I have grub2 set up to “boot from root”.

My first disk (SSD) has four primary parts in this order, 1=root, 2=home, 3=swap, 4=win/NTFS.
My second disk is just a single primary part NTFS vol.

alvanx wrote:

> Fascinating! Anybody try the upgrade with an efi partition yet?
> I for one suspect the worst. With Win 8.1, I had to reinstall GRUB2,

Yep - bit me in the butt by rearranging the disk layout when it removed and
replaced some of the magic data/backup partitions Win 8 had created
resulting in a shift of the gpt partition numbers in the table. So far as I
can tell, nothing is really destroyed but I had more than just a simple dual
boot: 3 separate linux installations all using a common swap partition plus
Win 8.1. Some how, the first reboot (there were at least 4) during the Win
10 install process let things alone as the system booted to my default
openSuse installation without problems but the next reboot wound up screwing
up the grub entries in the EFI system partition. I did get a usable boot -
but the / partition is mapped to a different version from the /home
partition used by that version so I have to be careful what I do.

I’m going to move the rest of this tale of woe to the Install-boot-login
group to see if I can get a little help straightening out Grub2 so anyone
with problems might want to follow there. Suffice it to say, all is not
necessarily painless with Win 10 updates unless you have a dirt simple base
setup - if then!

I have no case for staying with Win7, although I quite liked the UI, performance is not so good. Even if the Win10 update goes smoothly, I wonder what will happen with those Lenovo utilities supporting specific hardware functions on the ThinkPad, and the Fn keys for example…

Have you researched the Windows 10 upgrade from Lenovo’s angle. Apparently as example a Lenovo advisory for Win 8 recommended removing some Lenovo apps/utilities before the upgrade (not done here). I just started to research Lenovo for win10 from here:
You may need to change country at top of that page.

thanks - I’ve long ago removed most of the relevant applications but probably need to also remove “rescue and recovery”
considering the iso download option for win10 as that will let me download and install a 64bit system rather than sticking with the 32bit windows install I have now.

Just reporting in here to say the dual boot wasn’t affected when I updated from win 7 to 10 (on a PC)

went through with the upgrade last night and went very smoothly. Quite a long install I guess at about 40 mins + but stayed away from the bootloader and openSUSE partitions.

Performance of win10 seems quite good when compared with win7 - much faster for me . . . . but this could be because I selected to “keep nothing” during the install process, effectively wiping all of Lenovo’s flotsam from the system.
UI is much more win7 like than it is win8

That was brave, and augurs well for those yet to follow. Not as long re install time as I imagined. :slight_smile:

Performance of win10 seems quite good when compared with win7 - much faster for me . . . . but this could be because I selected to “keep nothing” during the install process, effectively wiping all of Lenovo’s flotsam from the system.
UI is much more win7 like than it is win8

Also good to hear. Was this clean install via upgrade from within 32bit Win7 or did you go for a 64bit ISO i.e. what is it now?

When the dust settles, it would help to know your tally of functioning ThinkPad Fn keys and the buttons on left of k/b? Particularly interested in Fn5 which brought up a [lenovo?] menu for indepentdenly turning on/off wlan radio/bluetooth/wwan radio.

On mine the wwan chip provides modem and GPS, maybe not on yours? Wondering if Lenovo’s ThinkVantage GPS utility might still work on Win10. I use it to check the hardware chip works. The rest of their stuff I can do without…

I did have “gpsd” and a client app working on openSUSE but not since it fails even on 13.1, and modem support was dropped due to lack of resource. I can’t test or activate the chip without the ability to issue basic AT commands to the modem using the command line and two instances of konsole.

been testing for a while now and I still think mostly an improvement over win7 on the SL510
some of the function keys work and some don’t
working - brightness, volume, screen lock, power management, multimedia control keys etc.
not working - fn/F5, mute, Thinkvantage (because I removed the thinkvantage software)

you can see in this post at Lenovo others have been querying the function keys

seems to be varying degrees of success in getting the keys to work with someone suggesting install the function key drivers for Win8 (haven’t tested myself)

Someone else suggested that Lenovo are not supporting the SL510 for Win10 but I doubt the accuracy of this statement as I have already found other software that has been updated for Win10 (including system update, Lenovo Solution Centre)

I have just done the upgrade myself on a desktop approx 18 months old running Windows and opensuse 13.1.

In not too long I anticipate to download the latest opensuse. I remember having problems getting dual boot initially but usually when I install the latest opensuse I do a fresh install. Is there a way to keep grub as it is as I can’t be bothered with all that fuss again!