Windows 10 update makes NTFS partition incompatible with linux

After a recent update of Windows 10 (November 2015) yast partition manager hangs, the bootloader editing in yast hangs, and the installers of Opensuse 13.2 and Opensuse Leap 42.1 freezes / hangs, showing only the green bar at the bottom of the screen. Presumably it also can´t read the partition anymore. Gparted shows problems with the NTFS partition of Windows and tells you to run chkdsk /f in Windows and reboot twice.
I found out that running chkdsk /f in Windows and rebooting just once (i.e. leaving the chkdsk /f -process half way through) renders the NTFS partition readable for Opensuse: yast-partition, bootloader editing and the installer-DVDs are running again. Once you reboot into Windows, however, the chkdsk /f process finishes and the partition can again not be read by Opensuse.
So what is going on here? After some research, I found out that Microsoft has changed their NTFS: it changed from LFS (Log File Service) 1.0 to LFS 2.0, which to Linux is an „unknown filesystem“. As far as I understand it, once you have made the Windows 10 update, you can not revert to LFS 1.0.
This of course is standard corporate strategy: as Satya Nadella talks about making Windows open to other platforms, Microsoft is doing the exact opposite: Working hard to make Linux unusable in dual-boot environments.
I hope that the coders of Linux / Opensuse soon develop software to circumvent the recent Windows 10 changes. Until then, dual-boot systems with the up to date Windows version are almost unusable.

Just checked two dual boot systems here, SLED 12 SP1/WinX with ntfs LFS2.0 present and openSUSE Leap 42.1/WinX with ntfs LFS2.0 present. I see none of the issues you describe, either via YaST or using Nautilus to mount.

Try disabling fast startup in Windows - does it help?

Yes, that as well, I also ensure a full shutdown with windows (shutdown /s /t 5).

In my Version of Win 10 x64 (1151 after update KB3118754) that option is gone. In settings-power-admin mode there is no box to check / uncheck "fast startup anymore.

Then there must be some additional specs. I´m on a Samsung 840 SSD, WinX x64 Version 1511, last update KB3118754?
It is 100% reproducible here with Opensuse > 13.1. Installer DVDs with 13.1 or below do not have the problem.
It occurs independent of what I use to format the Opensuse partition - ext4 or BTRFS - no difference.

Hardware problem, perhaps the SSD? Check out smart info, or samsung tools for the drive, if possible.

I ran the Samsung software, it says the drive is ok

In you /etc/fstab file put nofail option on lie for any Windows partitions you automount. This will stop bot failure in case of bad Windows partitions

This is almost always because Windows is not closing down its file system completely and leave it dirty thus non-mountable

Also check that the Windows is not set up as Dynamic Disk this is the MS equivalent of LVM but is proprietary thus can not be cloned in OS software.

One system on OCZ SSD (SLED), other WD320GB rotating drive (Leap), both systems all at WinX x86_64 - Home 1511 (build 10586).

I’ve never mounted windows partitions during install, always afterwards since I rescan the device before install to setup my partitioning.

The WinX partitions are not mounted in opensuse. Thus there are no entries for them in fstab. If I do try to mount them, a notice comes up that something is wrong with them.
I also assume that the whole problem is that WinX is not closing down properly. That used to be the case only for hibernation and seems to be the normal shutdown now. The filesystem is left in a state that currrent linux can´t read.

Abut Dynamic Disk: I have to check.

That is probably the cause. Also check system BIOS for fast boot option. Anyway, suggest you run the shutdown command I indicated and see if that helps.

OK, I checked your suggestions, but no luck:
The WinX is on a primary partition, no “dynamic disk”, extended disk or other.
In Bios, fasboot and secure boot are switched off. I never installed anything via UEFI, they were always switched off.
Shutting down WinX with “shutdown /s /t 5” does not help. When I reboot into Opensuse 13.2 again the partitioner fails to start, as does the bootloader editor. Otherwise Opensuse runs well. Just can´t read partitions anymore. If I insert an Opensuse Live DVD or USB, it does not start. It loads the drivers, the green bar at the bottom grows to the right side and stays there forever.
I can only heal that by running “chkdsk /f” in WinX and letting it reboot directly into Opensuse.
I´m on WinX Pro x64 1151

You can not turn off EFI you can use legacy boot but that generally requires making a change to the EFI BIOS

I think you confuse BIOS fast boot and secure boot with EFI BOOT. You can still do EFI boot even if secure boot and fast boot are turned off.

If you use plain vanilla NTFS in Windows Linux should have no problem. But we have covered the ways that it can be incompatible. So have you run chkdisk on the Windows side? If there is a problem with the NTFS the file system is considered dirty and will not mount.

To me it sounds like a hardware issue, is this a laptop or desktop? If a laptop, pull the drive and re-insert, if a desktop, check replace the SATA cable.

Maybe a re-image of the openSUSE 13.2 onto the USB device (you have run an md5sum on the iso image?) or image to a different USB device.

What about the SSD firmware, all up to date? What does smartctl in linux say about the device?

I don’t know if it’s related but there was a time(4 years ago?) when the Samsung 800 series was being reported by many as having a series of unidentifiable problems. A Google search today may not turn up much, although there was a time when people were complaining all over the place, I did a search on this within the last year and only found one hit.

If possible, recommend creating a new, small test share using something like FAT32 and see if it’s a problem or not.

You also didn’t say what location your share is pointing to… It’s also possible that MS tightened up its security and marked your location inaccessible remotely (Local Policy). Try accessing the files through something like SCP/WinSCP to test this.


I use legacy boot for WinX and Opensuse, both x64

please read my first post: after the WinX update to build1151 I can boot into Opensuse, but when I start yast-partitioner or any other module that needs to read the partition, they hang forever. Same with Opensuse Live Disks 13.2 or Leap. The Live Disk of 13.1 or below will start (!)

The only way to make Opensuse read the partitions again is boot into WinX, rund “chkdsk /f” and directly boot into Opensuse again.

I tried two Opensuse leap DVDs that run well on another machine, independent downloads, checksum tested, one 13.2 DVD and one USB of each 42.1 and 13.2. They all show exactly the same behaviour. WinX is running well, 13.2 is running well EXCEPT all modules that want to read the partitions.
SSD maintanance software from Samsung says all is fine with the drive.
smartctl shows no problems with either disk nor the partitions.

What is WinX?

This is potentially problematic, if this computer has UEFI firmware with Windows preinstalled and then you disable UEFI (which is very bad terminology used by some firmware vendors, what it actually means is enable legacy BIOS via a UEFI Compatibility Support Module). BIOS != UEFI, they are completely different firmware implementations, with completely different ways of booting including totally different bootloader binaries and the location they go in so the system finds and boots. There is no practical way to support UEFI Windows and BIOS Linux on the same system. So unfortunately you need to be more clear exactly what state the system is in; if UEFI is “switched off” when Windows was installed? Seems unlikely.

I think you need to attach and entire dmesg and maybe also a yast log to get more information on why it might be hanging. Any hardware problems should have some clue in the kernel messages what might be going on. Right now you’re having a problem no one else is having, so they’re just throwing spaghetti at a wall, there really isn’t enough information to know what the problem is.

Windows 10, probably.