window title, minimize, maximize and close buttons are gone!

though i have been trying linux here and there, i am fairly new to it. That being said, I am also new to openSUSE. I have only been using it for a few days but i love everything about it except for a flaw that i have recently run into that is causing me to get extremely upset. I logged on recently and found the frame of all the windows i would open up (the part with the title of the window, minimize, maximize, and close buttons) was gone. In addition, none of my desktop effects are working. I am running opensuse 11.0 with the gnome desktop. i’ve had this issue several times and have tried repairing the install and several reinstalls and always get the same result. it seems to be tied with an update for compiz-fusion because i tried uninstalling all the things with “compiz” in the name or description using the YaST and after doing so and loging out and back in, i got my windows back. i’ve tried to reinstall parts of compiz but i am still unable to use compiz or any desktop effects. I need the cube because having multiple desktops really is essential to me and i definitely need something stable enough to have frames on all the windows. I love openSUSE and i’d really like any help with this.

As you have realised, the problem is related to compiz; you may have to wait a little longer to have it resolved - which I am sure it will be.

Sometimes it happens that the window decorator is not loaded properly with compiz enabled. I found that is easy to solve, almost in my experience, reloading it. The easier way is to have fusion-icon installed. When done just right click on the icon an select reload window manager. Hope this helps

To fix this challenge you open a terminal window and reset your windows manager:

IE: compiz --reset

Your windows should now have control boxes with maximize and minimize buttons

You do know that 11.0 is no longer supported? 11.1 11.2 11.3 are the only version with active updates.

I’ve just upgraded from openSUSE 11.2 to 11.3 and I’ve got exactly the same problem - application control boxes and title bar has disappeared

The command compiz --reset doesn’t work for me :frowning:

Any ideas?

Hi,

Please open a terminal and provide the output of:

rpm -qa --last "*compiz*"

Take Care,

Ian

Output is


badzilla@laptop4:~> rpm -qa --last "*compiz*"
compiz-plugins-main-0.8.6-1.15                Tue 14 Sep 2010 12:56:34 BST
libcompizconfig-0.8.4-3.1                     Tue 14 Sep 2010 12:55:57 BST
compiz-manager-0.6.0-11.1                     Tue 14 Sep 2010 12:54:58 BST
compiz-0.8.6-3.4                              Tue 14 Sep 2010 12:53:30 BST
compiz-gnome-0.8.6-3.4                        Tue 14 Sep 2010 12:50:01 BST
compiz-branding-openSUSE-0.8.6-3.4            Tue 14 Sep 2010 11:52:28 BST
badzilla@laptop4:~> 

Hi,

Sorry I never got back until now. Been busy wil school. It’s because you do not have the emerald package. It’s an unofficial repository but you can find both emerald and fusion-icons here. Once the emerald package is installed you should be able to get your titlebar back.

Index of /repositories/home:/lOtz1009:/emerald

Take Care,

Ian