Window resizing slow on KDE 4.1.2 and ATI

Hello,

Apologies if this has been asked before, but having trouble finding a solution to this specific problem (most people complain about nVidia, not ATI).

I’m on OpenSUSE 11 with KDE 4.1.2. I have an ATI 4850, using proprietary driver version 8.52.3. With desktop effects enabled, most things are quite snappy. However, resizing of windows is extremely slow. Most of the time there are only two frames in a window resize - the initial size of the window and the end size, where I drag my mouse.

Does anybody have any solutions for this? Many thanks.

Clarification : I’m using fglrx 8.522.

Hi

Same problem here, but alas, no solution, with ATI Mobilitiy Radeon HD 3600 and fglrx 8.522 running on Core 2 Quad with 4GBytes.

I have also installed Kubuntu 8.10 RC on another disc on the same machine and the problem is not present in that distro.

Regards
A

Just chiming in with a me-too.

I have the same issue with an ati xpress 200M in my laptop.

Not sure what fglrx driver version I’m using (latest from ati repo as of this date). I’m using the factory repos for kde4 + community repos & the official opensuse ati repo.

It’s the same with either desktop effects on or off - resizing is choppy & slow on all windows.

One more of those me-too-messages, except that i am using icewm as my “desktop”, so not KDE nor Gnome here. Still this is s-l-o-w when using openSUSE 11 (64bit). Moving windows is slow, and even slower (if poosible) this is when scrolling a web page in a Mozilla Firefox 3 Beta 5 browser.

My ATI driver version is 8.54.3 when checked from Catalyst Control Center.

My PC HW has ATI Radeon HD 4870 X2, and with Windows XP Pro SP2 (32bit) it is fast as it should be when running latest FPS games, e.g. Crysis and Crysis Warhead.

I have also tried 32bit Debian (latest i386) and it was quite fast when updating my display without any ATI drivers even with KDE&Gnome. Normally is use fluxbox or something similar because i don’t need a desktop to start my programs.

Any hints what to do? How to make openSUSE 11 fast?
Has anybody fast graphichs or at least normal speed graphichs with openSUSE 11 with ATI?

This slowness i mentioned in previous post disappeared when i updated ATI drivers to the latest versions available today!
Now screen update is as fast as it should have been always.

When i check with command ‘glxgears’ the current frame rate it is 5 (yes, five) times more than with the previous version of ATI drivers i had.
The five second average with glxgears is now with updated drivers in my system about 9160 FPS.

Sorry to bump this old thread, but I’ve had the same slow resizing problem on opensuse 11.2 with an ATI card with all of the newer ATI drivers up to and including 10.1.

It appears that this is a well known “no backfill” bug, which exhibits itself when compositing is enabled.

There is a patch available for the Xserver:

Add the following repo :
Index of /repositories/home:/dgrafenhofer/openSUSE_11.2

and switch the system packages to it.

This will patch the Xserver.

You might want to reinstall the latest Ati drivers after that.

Hope this helps others.

lenwolf

One more of those me-too-messages, except that i am using icewm as my
“desktop”, so not KDE nor Gnome here. Still this is s-l-o-w when using
openSUSE 11 (64bit). Moving windows is slow, and even slower (if
poosible) this is when scrolling a web page in a Mozilla Firefox 3 Beta
5 browser.

My ATI driver version is 8.54.3 when checked from Catalyst Control
Center.

My PC HW has ATI Radeon HD 4870 X2, and with Windows XP Pro SP2 (32bit)
it is fast as it should be when running latest FPS games, e.g. Crysis
and Crysis Warhead.

I have also tried 32bit Debian (latest i386) and it was quite fast when
updating my display without any ATI drivers even with KDE&Gnome.
Normally is use fluxbox or something similar because i don’t need a
desktop to start my programs.

Any hints what to do? How to make openSUSE 11 fast?
Has anybody fast graphichs or at least normal speed graphichs with
openSUSE 11 with ATI?


carlvonkoff

carlvonkoff’s Profile: http://forums.opensuse.org/member.php?userid=16259
View this thread: http://forums.opensuse.org/showthread.php?t=398297

This slowness i mentioned in previous post disappeared when i updated
ATI drivers to the latest versions available today!
Now screen update is as fast as it should have been always.

When i check with command ‘glxgears’ the current frame rate it is 5
(yes, five) times more than with the previous version of ATI drivers i
had.
The five second average with glxgears is now with updated drivers in my
system about 9160 FPS.


carlvonkoff

carlvonkoff’s Profile: http://forums.opensuse.org/member.php?userid=16259
View this thread: http://forums.opensuse.org/showthread.php?t=398297