Window Manage

Problem today with Plasma crashing. Ran yast from cli and removed auto logon. Now just black screen. Installed xfce and set it to the default window manager. Same result just a black screen.

Where do I look next?

Sounds like a graphics driver problem.
The login manager apparently crashes as well (or has problems at least).

Try setting xdm as DISPLAYMANAGER in /etc/sysconfig/displaymanager, that will hopefully still work…

Will try that this evening.

Thanks!

Give us some details!

What graphics chip and drivers (are you using proprietary drivers?)
Have you run an update recently?
Do you see the Grub screen?
Do you see the desktop manager (login) screen?
What repositories are enabled?

Installed xfce and set it to the default window manager.

Do you mean that you selected an Xfce session in the SDDM ?

This worked. xfce came up and was able to login. Did not have time to work on it further this evening. Will reinstall sddm tomorrow and see how it goes.

Thanks wolfi323!

I installed, a few days ago, Leap on a laptop. The laptop has no Nvidia card and no nouveau driver is used. Plasma5 is used.

Updated. Reduced the Desktop Effects to almost nothing, set to Xrender.

In several hours of work, most of which I spent on configuring the OS, I encountered several crashes of Kwin, Qt, and perhaps something else.

Is this state going to be the future of opensuse? I don’t remember Windows 10 crashing on the same laptop.

And what does it have then?

For intel, see here:
https://forum.kde.org/viewtopic.php?f=289&t=127575

In several hours of work, most of which I spent on configuring the OS, I encountered several crashes of Kwin, Qt, and perhaps something else.

Is this state going to be the future of opensuse? I don’t remember Windows 10 crashing on the same laptop.

And I don’t remember Plasma5 or kwin crashing in the last two years here, on my (older) radeon and intel systems.
I’m on 13.2 though, but with always the latest Plasma5/KF5/Qt5 packages.

But I haven’t seen Plasma5 crash in my Leap and Tumbleweed VMs either.

If you use the DrKonqi to report the crash to the KDE folks (you will need to register with the KDE Bug Reporting system), please be aware that they prefer to have Crash Reports which contain the debug symbols.

In other words, in an ideal world, you need to install the “debuginfo” packages before the crash occurs – I haven’t yet discovered if there’s a ‘core’ file from my last KDE Plasma 5 “plasmashell” crash so’s I can resubmit the Crash Report with the debug symbol information the KDE folks would like to see.(I finally got around to installing the “debuginfo” packages after the last crash.) :shame:

Actually, drkonqi allows you to install the debuginfo packages even after a crash.
But you need to have the debug repos enabled for that to work.

In the case of the OP, the login screen crashed as well though (or at least only showed a black screen), so it’s likely no KDE problem.

I have reinstalled sddm and plasma pattern. Enabled sddm, set sddm as display manager, and set plasma5 as window manger. Same result black screen.

Just a note: you don’t have to set/switch the window manager. This is only the default, you can choose what you want on the login screen (unless you are using xdm…).
And sddm doesn’t even respect /etc/sysconfig/windowmanager currently.

So, I’d suggest to stick with xdm for now (or maybe try lightdm), so that you have at least a working graphical system (makes it easier to debug).

Then please post /var/log/Xorg.0.log and the output of:

glxinfo|grep render

(you probably have to install Mesa-demo-x first)

Also try to start sddm and/or Plasma inside a different desktop environment (e.g. IceWM or XFCE), maybe you get some helpful error message:

sddm-greeter --theme /usr/share/sddm/themes/breeze/ --test-mode
plasmashell

Please post the output you get.

You could try to set a different sddm theme in /etc/sddm.conf (e.g. maui or maledives), if that helps it’s a problem with Plasma (the default “breeze” theme does use some components of Plasma).