Window decorations disappear when window does not have focus

This is a new installation of 11.0 with Gnome. I am new to openSUSE but not to Linux; I have been an Ubuntu user for three years.

I installed the Nvidia x86_64 drivers. With desktop effects enabled, only the window with focus has its border decorations. I have tried a manual driver installation, and I have run sax2. The missing borders come back as soon as the window gains focus (but then of course the window that previously had focus loses its decorations). Not sure where to go from here.

Also, is there any way to improve subpixel font rendering? I have already gone to Appearance>Fonts and set the subpixel smoothing, but I know they can be better than this.

Thanks for reading.

I have the same problem on my recently installed openSuse-11-x64/Gnome system. After installing NVidia driver and enabling the desktop effects the window decorations are not drawn for all inactive windows. Disabling the desktop effects ‘fixes’ the problem.

What sort of a fix is that?? We don’t want to disable desktop effects, we want to just see inactive window, by the way, do You see sometimes inactive window but it’s glitchy?
P.S. Sometimes it works fine but just for a second.:confused:

That’s why I put ‘fixes’ in quotes :wink:

Yes, the title of inactive windows is sometimes glitchy.

Here’s a screenshot:](

I got solution for our problem mates.
I just recompiled newest Nvidia drivers kick me in the a** if i’m wrong but there’s something wrong with the compiled nvidia kernel module. I now have the newest kernel with 09 on the end :slight_smile:
One thing i can’t change is in display graphics and monitor to 8800GT but whatever I have 3d acceleration anyway so I don’t care then. and inactive windows work flawlessly (i haven’t changed any settings so they remain the same so it’s not the settings fault). Just follow instructions on Nvidia site and it will work fine.
P.S. I might have missed that but now i can see shadows around window decorations, could any of You confirm if You also have shadows with old module ?

I don’t see the shadows. As for compiling the driver, I think I will wait for the official package from NVidia, I’m tired of compiling stuff in Linux :slight_smile: But thanks for finding the cause of this bug!

Can you post a link to the instructions you used? I installed from, manual build, and I still have the problem.

Well what i basically done is i deleted the nvidia drivers i had installed, rebooted. (Before that I downloaded all necessary things like source, make, gcc and of course the driver).
The link is
Nvidia Installer HOWTO for SUSE LINUX users

P.S. 1 The only problem is that sax2 won’t recognize Your card but acceleration works witn no problems at all.
P.S. 2 I’m still working on the P.S 1 hehe

i too hav the same problem. i’m using the 32 bit version. Maybe the opensuse community should post a solution (release an update) soon as it seems to be a common problem for all the new suse 11 users.
Also how do u remove all the installed nvidia drivers? (i’m guessing doing a search for nvidia in synaptic n then removing everythin)