Win7 ate my SUSE after system restore :'(

Hardware issue forced me to restore Win7. Installed EasyBCD to boot into openSUSE, no work. Boot puppy, it shows space where SUSE should be as unallocated space. I think Puppy doesn’t see ext4 though. Can’t boot live KDE off USB for some reason, though I originally installed from that exact medium. Tried ACPI=off and nomodeset. Error says trouble mounting clic filesystem, mounted as read only. Something like that. Then reboot 120secs, which it never actually does. I don’t want to reinstall SUSE if I don’t have to.

You may try one of the usual SuSE installation CD’s, e. g. the one for network-based installation (because it is small): Index of /distribution/11.4/iso
It offers - if it can recognise - to boot into an already installed system. If not, use the emergency shell to call “fdisk /dev/sda” and then ‘p’ for the partition table. Does the output look familiar? Do you agree with the partition sizes? If not, then your SuSE partition is probably destroyed.

I have tried booting from live USB (its a netbook). It finds and “restores” the partition, then tries to use the journaling, which causes it to hang. I need to somehow tell it to ignore the partition and not use the journaling so it can boot completely, then I think it can be fixed. **** windows. Puppy can’t do it since it has no support ffor ext4, only ext3.

Do I understand you correctly: You have a live system which unfortunately tries to mount all hard disk partitions during boot-up. Because the file system ext4 is unsupported, the mount (with journal replay) of the SuSE partition makes your live system hang.

Then you should get another live system or what I said above - or find in its documentation a boot parameter that prevents HD partitions from being mounted. But the latter wouldn’t be very useful because you can’t do anything unless you mount them.

Installed EasyBCD to boot into openSUSE, no work
What does not work about it ? Any error messages ? Does it give a menu ? more info on its failure.

Why don’t you reinstall Grub? That will fix the problem.

See below:

Remember to have fun!


The bootloader is NOT the issue. Rather the live USB attempts to use the journaling of the damaged file system and will never boot. NEVER. As far as I know, there is no documentation for 11.4. Now other attempts to repair have destroyed the partition more completely, but for some ****able reason LiveUSB still hangs trying to use internal journaling. The more I fiddle with openSUSE, the less I understand why anybody bothers.

Just my two cents since all I’ve gathered is that Windows wiped the drive and you’re trying to boot Live.
If the system image you used to rescue Windows was made prior to you previous Linux installation, the partition was deleted. The Windows rescue returns the disc to the exact state it was, including all partition tables and paritions.
Any particular reason you’re positive it’s not the bootloader?

Hang on
Win7 breaks your SUSE install and you blame SUSE?

Parted Magic > Partition Manager >
Run a check on the Linux partitions


Now other attempts to repair have destroyed the partition more completely
Whatever this means? Sounds potentially self inflicted.

Don’t blame openSUSE. This was self inflicted…

The system restore will remove all references from the drive. This would be as if openSUSE was never installed. That’s what Windows does - wipes all references of another OS.

Win7(restore to factory) never affected Linux partitions before now. Its not the bootloader because I tried restoring a bootloader already, two types. The FS got screwed up somehow. I blame SUSE since it used to boot just fine off live media before, but now hangs after detecting the old SUSE partition “using internal journaling.” This sounds to me like it is trying to use features of the damages FS, and hanging.

Since then I have erased the partitions entirely hoping to get regular function back. OpenSUSE still refuses to finish booting. Tried Fedora 14 and 15. Neither would boot, though I had F14 installed before. Something very odd is going on. Believe me I hate Windows, and if I could get the 3G to work consistently I would have deleted windows entirely already.

Use Parted Magic to wipe the HD and re-partition it. Clean as a whistle

I may very well, however I have a netbook. So its install is off a partition. As I said, if I could just get the 3G working consistently I would happily be done with Windows. If theres a way I can get install and configuration assistance, then Windows shall die.

But you have been using usb media to install from have you?

Are you able to post your partitioning?

fdisk -l

Is it possible to repartition everything except windows?
Do you have the ability to boot to the windows install media to do a MBR repair?

If you could delete all partitions except those belonging to windows to leave a section of un-partitioned space ready for Linux. Repair your MBR, so you just have windows booting normally without any grub. Then lets start again from the beginning.

But I’d still be interested in the fdisk info first

I have cleaned up the non-win space and made it into unallocated. Fdisk is a Linux function I assume… in which case, I have no operating Linux at this time. Right, I use USB live media for install since I do not have a optical drive. Wish it was possible to put the DVD on a USB as live, so I could get the additional features. If Puppy has fdisk (it lacks many things) I’ll reinstall it (on USB) in order to get the fdisk.

What did you use to make the partitions to unallocated?

I just used the windows partitioner in this instance. I just want to make a fresh install at this point. I may purchase openSUSE for the support. Is 11.4 available for purchase yet?

Its not available on USB. Can I purchase the support alone? Or the manual alone?

openSUSE suse balsam ubuntu “linux distribution” “open-slx”

So did you have a Live USB of openSUSE? Do you still have it? Was it 11.3 or 11.4?
Unfortunately the windows partitioner is not a favoured tool in my books.
Have you actually been down this route before (removing all the partitions and starting from scratch?)

Tell me, what do you have to hand that you can use? You mentioned Puppy. What about others? (live CD’s on usb?)

I have USB disks, so anything netbootin has I can do. I had the 11.4 on USB, but I have had zero success with any tool except the imagewriter, and that will only work on SUSE. My netbook was the only system running SUSE. I don’t want to fiddle with the other machine that operates as a fileshare and backup. I have tried about 7 distros from Lice USB on the netbook before.