Win2K/Leap 42.1 inaccessible boot device

My system has two identical Maxtor 1GB hard drives and I have been trying to set it up as follows:

sda - Windows 2000/OpenSUSE Leap 42.1
sdb - Linux Mint 17.3

Open SUSE is the primary distro and GRUB detects everything; it and Mint boot fine, but Windows starts its booting splash screen for about fifteen or twenty seconds and then throws up a BSOD and message thus:

STOP: 0x0000007B (0xF601B848, 0xC0000034,0x00000000, 0x00000000)

To set up sda Windows went on first and would boot correctly - it only stopped booting once OpenSUSE was loaded as well. Gparted shows Windows occupying the first partition on that hdd, and GRUB was installed on the boot partition of the Open SUSE installation. It won’t boot in safe mode either.

I’ve done some research and this seems to be an issue when swapping Windows drives between different systems, but I can’t find anything about why it would do this here.

Incidentally, I have had Windows 2000 and an earlier version of SuSe Linux (I think it was 12x - it was a few years ago now) booting happily together on this same drive.

Any help would be much appreciated.

Is the Windows partition marked as active? Or is opensuse marked as active?

If the latter, try changing to Windows as active partition and see if Windows can boot then.

Make sure that you have bootable live media before trying that. You might need it to switch the active partition back to opensuse.

I tried that but it made no difference; W2K still fails to boot and behaves as described.

0xc00000034 STATUS_OBJECT_NAME_NOT_FOUND. Do you use dynamic disks in Windows by any chance?

No - I didn’t even know what a dynamic disk was until I researched it after reading this post.

Incidentally, I’ve since retried setting up the hard drives as described above using openSuSE 13.1 with the same result. I also tried it substituting Fedora but that wouldn’t install so I’ll try using yet another distro. I just can’t understand why Windows will boot when it’s the only OS on the drive but won’t when something else is installed alongside - I’ve done it before without problems.

When substituting PCLinuxOS for openSuSE - same result.