Win 8.1 partially visible after dual boot with openSUSE 13.2

Hi
I recently dual booted Win 8.1 with openSUSE 13.2 (after your help in this forum).I have two different partitions in Win 8.1 OS (pic below) the OS itself {145.97 GB NTFS} and another partition {viz. LOTR Minas Tirith} on which I save my data).

The Disk Management in Win 8.1 gives me this pic:
http://i.imgur.com/LcQLVUa.png

I am unable to access the Win 8.1 OS partition in openSUSE 13.2 as the option is invisible, but am able to mount the second partition(LOTR Minas Tirith) where I save my data.

The output to fdisk -l is as below:

Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: C257A73F-47DD-4A92-BA5E-317C326DD8A3

Device          Start        End   Sectors   Size Type
/dev/sda1        2048     616447    614400   300M Windows recovery environment
/dev/sda2      616448     821247    204800   100M EFI System
/dev/sda3      821248    1083391    262144   128M Microsoft reserved
/dev/sda4     1083392  307202047 306118656   146G Microsoft basic data
/dev/sda5  1024002048 1953521663 929519616 443.2G Microsoft basic data
/dev/sda6   307202048  311420927   4218880     2G Microsoft basic data
/dev/sda7   311420928  395311103  83890176    40G Microsoft basic data
/dev/sda8   395311104 1024002047 628690944 299.8G Microsoft basic data

Partition table entries are not in disk order.

The reply to
os-prober

WARNING: lvmetad is running but disabled. Restart lvmetad before enabling it!
  No volume groups found
/dev/sda2@/EFI/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi
/dev/sda7:openSUSE 13.2 (x86_64):SUSE:linux

I opened Yast Bootloader and the option of “Probe Foreign OS” is already enabled (ticked).

Please guide me how can I access Win 8.1 OS partition in openSUSE 13.2.

Everything looks okay.

My guess: You installed Windows for EFI booting and linux for traditional MBR legacy booting. That combination doesn’t work.

You can switch opensuse to use EFI booting, but you might find it easier to reinstall.

Either way – to switch or to reinstall – you need to be able to boot the install media to EFI mode. Possibly that requires BIOS settings changes.

A little unclear about where these things are invisible.

Turn off fast boot in Windows. It will prevent mounting of Windows partitions

If the option to boot Windows is not in grub it is probably as nrickert says, you mixed boot modes

On 2015-08-12 12:46, babloo75 wrote:

> I am unable to access the Win 8.1 OS partition in openSUSE 13.2 as the
> option is invisible, but am able to mount the second partition(LOTR
> Minas Tirith) where I save my data.

You mean that in Linux you can mount E:, but not C:?

Maybe because it was not cleanly shut in Windows. Fast boot, perhaps. If
you try to mount it in the CLI, the error message would confirm.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Probably I mixed boot the things (UEFI with Legacy)

Is there any way to find out where does the fault lie?

Look in “/boot/grub2”.

If there’s a directory “i386-pc” then you are using legacy booting for opensuse. If there’s a directory “x86_64-efi” you are using efi booting.

If both directories exist, then go by the one with the most recent date.

Both are present
“i386-pc” is empty
“x86_64-efi” contains 261 items.

This probably means that openSUSE is also in UEFI mode.

What could be the problem then, Why I cannot see the “C” drive in openSUSE.?

Please guide.

Is fastboot turned off in Windows that will make it unmountable if turned on

Yes Sir. It is turned off.

Still confused about the problem

Can you boot to Windows from grub? ie is Windows in the grub menu? Exactly where is the partition not visible???

Fast boot is a good place to start if it is off then run check disk (or what ever it is called these days) to fix any problems with the partition’s file system. Linux may not mount a damaged Windows file system.

On 2015-08-12 19:46, babloo75 wrote:
>
> Both are present
> “i386-pc” is empty
> “x86_64-efi” contains 261 items.
>
> This probably means that openSUSE is also in UEFI mode.
>
> What could be the problem then, Why I cannot see the “C” drive in
> openSUSE.?
>
> Please guide.

You have to clarify your situation. If you can boot both Windows and
Linux, then forget everything said about UEFI or grub or legacy. It is
not related to your problem.

If you «cannot see the “C” drive in openSUSE» you have to try to mount
it manually and find out out what error it gives.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

I will explain in the pics below:
http://i.imgur.com/xnJyh3T.png

In this pic, I cannot see my Win 8.1 “C” drive in the Devices list on the left side of the screen.

In the screen shot of Gparted:
http://i.imgur.com/ADurnAY.png
The “C” drive is very much there, … /dev/sda4 NTFS partition … 145.97 GB is there, but I cannot access it because it is not visible in the devices list on the left side of screen in Dolphin.

Please guide me how to mount it manually.

Did you try the device list on left in browser? It is not going to say C drive that is a made up Windows name

Show use

cat /etc/fstab

If not in the fstab it does not automatically get mounted.

Did you be sure that fast boot is off. You have never said. It will stop mount dead away since it leaves the MS file system in a undetermined state in order to have a faster boot but make it impossible for other OS’s to access it.

Command line mount as root

mount -t ntfs /dev/sda4 /mnt

that will mount it at /mnt in the file system

Yes Sir, Fast boot is off in windows.
The output to cat /etc/fstab

UUID=ddf3aba4-e531-4909-8203-67d6559ec03b swap swap defaults 0 0
UUID=d5996ee0-bb7f-412e-aeab-1edfc1344bc1 / btrfs defaults 0 0
UUID=d5996ee0-bb7f-412e-aeab-1edfc1344bc1 /boot/grub2/i386-pc btrfs subvol=boot/grub2/i386-pc 0 0
UUID=d5996ee0-bb7f-412e-aeab-1edfc1344bc1 /boot/grub2/x86_64-efi btrfs subvol=boot/grub2/x86_64-efi 0 0
UUID=d5996ee0-bb7f-412e-aeab-1edfc1344bc1 /opt btrfs subvol=opt 0 0
UUID=d5996ee0-bb7f-412e-aeab-1edfc1344bc1 /srv btrfs subvol=srv 0 0
UUID=d5996ee0-bb7f-412e-aeab-1edfc1344bc1 /tmp btrfs subvol=tmp 0 0
UUID=d5996ee0-bb7f-412e-aeab-1edfc1344bc1 /usr/local btrfs subvol=usr/local 0 0
UUID=d5996ee0-bb7f-412e-aeab-1edfc1344bc1 /var/crash btrfs subvol=var/crash 0 0
UUID=d5996ee0-bb7f-412e-aeab-1edfc1344bc1 /var/lib/mailman btrfs subvol=var/lib/mailman 0 0
UUID=d5996ee0-bb7f-412e-aeab-1edfc1344bc1 /var/lib/named btrfs subvol=var/lib/named 0 0
UUID=d5996ee0-bb7f-412e-aeab-1edfc1344bc1 /var/lib/pgsql btrfs subvol=var/lib/pgsql 0 0
UUID=d5996ee0-bb7f-412e-aeab-1edfc1344bc1 /var/log btrfs subvol=var/log 0 0
UUID=d5996ee0-bb7f-412e-aeab-1edfc1344bc1 /var/opt btrfs subvol=var/opt 0 0
UUID=d5996ee0-bb7f-412e-aeab-1edfc1344bc1 /var/spool btrfs subvol=var/spool 0 0
UUID=d5996ee0-bb7f-412e-aeab-1edfc1344bc1 /var/tmp btrfs subvol=var/tmp 0 0
UUID=6852-3922 /boot/efi vfat umask=0002,utf8=true 0 0
UUID=30de36b4-3757-48d8-bc98-d1ca37eba95a /home xfs defaults 1 2
UUID=d5996ee0-bb7f-412e-aeab-1edfc1344bc1 /.snapshots btrfs subvol=.snapshots 0 0

The second command answer is mount -t ntfs /dev/sda4 /mnt

Windows is hibernated, refused to mount.
Failed to mount '/dev/sda4': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

I think, hibernation option is still ticked “ON” in windows. I will recheck and return here.
Please wait.

Sir, I just verified, both “Hibernation and Fast Restarting” options are off in Windows. How should I proceed further?

http://i.imgur.com/9o5n1Zy.png

I opened Win 8.1. Ticked ON both “Fast Restart and Hibernation” options.
Rebooted into windows.
Now again turned OFF these two options “Fast Restart and Hibernation”
Rebooted into Win 8.1.
Verified they are still OFF.
Restarted my computer into openSUSE 13.2.
Tried again: mount -t ntfs /dev/sda4 /mnt

Windows is hibernated, refused to mount.
Failed to mount '/dev/sda4': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Result is still the same. It is again saying Windows is hibernating.

How should I proceed further?

On 2015-08-12 21:36, babloo75 wrote:

> Result is still the same. It is again saying Windows is hibernating.
>
> How should I proceed further?

You can try “fsck /dev/sda4”, let’s find out what it says.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Ok try hibernating Windows then restore it. The problem is on the Windows side for some reason the file system is set to hibernate and you can not mount such a partition. Maybe going trough the cycle will reset it properly

In my daughter’s laptop I also had to disable Intel’s SpeedStart (or a similar name) in the UEFI BIOS.

I don’t know if this relates to your problem, it was necessary due to the cache W8 used to hibernate, which used part of a smal (32GB) SSD. I nuked this fast boot gimmick and used the full SSD for oS root folder, while W8 still boots from the HDD.

Secure boot is in the BIOS but it need not be turned off if you properly install in EFI mode

There may be a Speed boot in the BIOS it should be turned off if it exists. And in Windows Fast boot should be turned off.