Will not boot without an install disk.

Hi All
Have a coworker that plays around with computers. He built a dual processor, 64 bit with 64mb of ram on a server board. Do not have the specs at this time. He installed purchased version of Suse 8.0 server. Using KDE. (Don’t know why he went this route. He is not setting up a server.) His problem is it will only boot from a CD. He can take out CD and it runs ok. A friend told me that there is a way to check the master boot file, but I do not know how to do it. I am learning trying to learn Unix/Linux programming. I can do some commands in terminal.

Thanks, Doug

I think that if I were playing around with a server, not intended for production use, why not start with the latest version of openSUSE? It may even be that the server has hardware than is not even known about in version 8 of SuSE. We are presently at version 11.2 of openSUSE and the download is free. Why not go to the top of the versions for just playing around? If the Server has four gigs or less of memory, try the 32 bit version else, if it has more memory, try the 64 bit versions. If it really has only 64mb of ram as you suggest, no operating system may even load on it. 256 MB would be considered the least amount to get anything useful to load.


Thank You,

64MB of RAM on a 64-bit motherboard sounds fishy. I don’t even think those old SIMMs are compatible with the latest motherboards. Please go back to your friend and get a complete spec of the hardware and software.

And purchased SUSE 8? How’s that? It would have to be a very old purchase.

Yes it is a very old distribution and, unless this is a hobby project, it would be best to go for something more modern. Strangely enough, this web page does show that 64MB would be sufficient:

DistroWatch.com: Put the fun back into computing. Use Linux, BSD.

To answer the original question, I think the boot flag is missing from the Suse partition. Post the inevitable:

fdisk -l

from a root terminal here. The boot flag is shown with an asterisk.

If it is missing,


cfdisk <disk device name>

to set it. More instructions later if needs be.

Ken_yap has a good point about the memory. On the installation CD, there may be a memory test facility. Run that.

If you cannot find, it search for, download and burn a CD for a thing called ‘memtest86+’. Perform 4 passes of 8 tests. If no errors in red you are OK.

Hi and thanks for the replys.

I missed typed on the RAM, it has 16GB. I do not know why he went the route he did. I wouldn’t have. He bought everthing thing cheap. Mother board was around $30. I will get the specs on Monday.

Thanks, Doug

Then why oh why Suse 8. That is like 10 years old. About the same as trying to install Win98 on a modern machine.

Also if he wants to actually use that 16gig then he will need a 64bit OS 32 bit will only address 3 gig.

I performed in root, fdisk -l and no asterisk in data. showed; /dev/hda1 start 1 end 131 linuxswap/solaris and /dev/hda2 start 132 end 4865 linux

Then I did cfdisk and that showed;
hda1 Primary Linux swap/Solaris 1077.52mb
hda2 Primary Linux ReiserFS 38938.48

I tried to copy output but I was unable to.

SUSE 9.2 Professional O.S. with KDE.
Motherboard is a ASUS K8N-DRE
AMD processors CPU family 15 model 33
Dualcore AMD Opertron 280
cpu speed 2400MHz cache 1024kb mem total 7649728kb.

Did notice when it was booting up I saw a

Thanks for the help.

OK you need to set the boot flag on the second partition.

From a root terminal enter the command:

cfdisk /dev/hda

This gives you a semi GUI (based on ncurses) for changing the partition data on the hard drive. You navigate between partitions and free space using the up and down arrow keys and navigate a menu at the bottom using the left and right arrow keys. The mouse does not work for this, by the way.

Make sure the hda2 partition is highlighted.

Make sure the menu entry is on ‘Bootable’ and press Enter. You should see the boot flag appear at the front of the hda2 entry.

Set the menu entry on ‘Write’ and press enter. It will then ask you to confirm that you wish to write the partition table and maybe destroy data. You must type the word ‘yes’ in full without the quotes and press Enter.

Then press ‘q’ for quitting the cfdisk utility.

Try a reboot without the CD.

Does it work?

How much memory does the system actually have? I cannot believe 64GB. Maybe you mean 640MB?

Think about upgrading to Suse 11.2. The problem with a very old OS such as Suse 8.0, is that the web browser will not be able to interpret most web pages. Hence frustrating.

~8GB according to the CPU line

Think about upgrading to Suse 11.2. The problem with a very old OS such as Suse 8.0, is that the web browser will not be able to interpret most web pages. Hence frustrating.

Yeah, I second that. I’m surprised it even managed to work after a fashion with such new hardware. OP or friend of OP, you are doing yourself a disfavour by using such an old distro like 9.2. You will be frustrated because you won’t have all the recent desktop goodies. You must have paid something this nice hardware, it would cost you very little to download or buy a pressed DVD with 11.2.

Sorry in my last post I meant ’ I cannot believe 16GB’

Ken_yap: I am wondering if the OP has a Suse 9.2 system and the OP’s friend has a Suse 8.0 system. In which case they should both upgrade.

If you insist on this old version be aware that older kernels did not have smp support built in You need to install a SMP version of the kernel to use both processors. There should be a SMP version on the install media. To be honest I really doubt that you can get this to work on the relatively new hardware. 9.2 is still over 6 years old.

It would also help if you said what the video card/chip is.

Thanks for the help.
I will advised him to upgrade. Does Suse use a package manager like Ubuntu? I tried to find it and couldn’t. I will find out what video card it has.

Thanks, Doug

YAST package management which is better IMHO

I put tha asterisk in front of hda2 partition and the write part also. Can not get it to boot into suse even with the disk. I can get to the install screen and not go any farther. Also found out today that computer will not perform post with 16gb of ram, remove 4gb and computer will post. The ram is 2gb sticks each and 266mhz speed. He told me he had 3 errors when install OS. I think the best thing to do at this point is to clean HD and start over. Video is ATI rage-XL and the mother board. I am going to do some checking on specs on the mother board. I started a mem test before I stopped working on computer.

Thanks again for the help.

That ATI rage could be a problem. I believe ATI has dropped support for it.

Thanks. I will look into that.


One question, video seems to work ok, why would that be a problem?

Thanks, Doug

Please, follow other repliers suggestion to download and install 11.2 64bit. And be aware of the fact that it is very well possible to build a system that will never boot, or never install an OS, i.e. will not run an OS.
Download a LiveCD 64bit and see if that runs on the system(s).

Thanks for all the help.

All I can do is to advise him it would be best to download a newer version, since it is not my computer.

Thanks again for the help.


Removing 9.2 and going to install 11.2. See how it goes.

Thanks, Doug