Will not boot in Kernel 4.9.5.1, ACPI Error, flashing screen, unresponsive

Hi,

The following happens in kernel 4.9 and higher. I was waiting till the next update to post, since this issue is similar to one in another thread. I am running a Lenovo E550 laptop with tumbleweed. If I boot with kernel 4.8.x everything works fine.

With 4.9.5, when I boot up, I get ACPI Error: Method parse/execution failed, AE_AMLBUFFER_LIMIT

Could not capture code, so here’s a picture of the screen:
i.imgur.com/vIHVVGo.jpg

The screen then goes black with 3 green ??? for a couple seconds

Then back to the same ACPI errors above, but the screen flashes on/off repeatedly about 3 times per second.

KDE does not start. I cannot log in.

I see the shell login prompt, but the keyboard is almost completely unresponsive. If I keep punching a key, every once and a while a character will show up, but only once every 100 presses.

Any help is greatly appreciated.

Thanks,

Lorin

Hi and welcome to the Forums!
Yes, kernel 4.9.x had problems recently, but if you went as far as to see the three green question marks (that’s Plymouth in text mode BTW) you are likely not affected by those problems.
I would disregard the ACPI problem: kernel 4.9.x is far more “picky” with ACPI and that doesn’t necessarily mean real trouble.
What you describe seems more likely related to a video driver problem: try booting with the “nomodeset” option and see what happens.

At the GRUB menu screen press “E” for edit; look for a line beginning with “linuxefi” (or “linux”) and append “nomodeset” (without quotes) at the end.
Press F10 to boot.
You may be greeted by a low resolution screen, but at least you should be able to look at the logs like /var/log/Xorg.0.log for clues.

Thanks. Booted up fine in nomodeset.

I think there is a radeon issue in that kernel.

Errors from Xorg.0.log:

lorin@albuquerque:/var/log> cat Xorg.0.log | grep EE
    13.610] Current Operating System: Linux albuquerque.local 4.9.5-1-default #1 SMP PR**EE**MPT Fri Jan 20 10:22:06 UTC 2017 (699d1c
6) x86_64
        (WW) warning, (**EE**) error, (NI) not implemented, (??) unknown.
    13.681] (**EE**) open /dev/dri/card0: No such file or directory
    13.681] (**EE**) open /dev/dri/card0: No such file or directory
    13.682] (**EE**) Screen 0 deleted because of no matching config section.
    13.689] (**EE**) AIGLX: reverting to software rendering

Warnings from Xorg.0.log:

    13.616] (**WW**) The directory "/usr/share/fonts/misc/sgi" does not exist.
    13.681] (**WW**) Falling back to old probe method for modesetting
    13.682] (**WW**) Falling back to old probe method for vesa


lspci output showing my AMD graphics card:

05:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Opal XT [Radeon R7 M265] 

Right now, with nomodeset, seems like everything is running fine under the intel graphics in the CPU:

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)

I don’t know where else to look. I saw that 9.5.1 had some updates to radeon issues (this card has never been an issue before). Not sure if those were in this build. Otherwise, where should I look for specific clues to the issue with the radeon driver?

Or, in the meantime, how could I just run the system off of the intel graphics chip (not a problem, the AMD is really only crucial for the autodesk software I use on my tiny windows partition).

Thanks

P.S. So glad to be back to openSUSE. I ran SUSE 1999-2004, followed by dark days with mac OSX. Tried Ubuntu and Mint to see what everyone was talking about a year or two ago, didn’t care for it. Installed Leap 42.0 as soon as it came out, moved to Tumbleweed. Love it. I’m learning a lot more now too, since switching to tumbleweed (solving issues like this helps me learn a lot more than I knew before).

Sorry, never had a Radeon here so I cannot help further.
Maybe appending “blacklist radeon” to /etc/modprobe.d/50-blacklist.conf is enough to engage only the Intel GPU, but I don’t know for sure.
To help other experts help you, more details about your HW might help, like make/model number or BIOS details…
Good luck.

I might ran into similar problem, after one of last updates (it might very well be this kernel update) i’m getting infinite loop of display going on/off.
My Xorg.0.log seems pretty similar.
In my case the problem seems to be that the kernel is missing firmware for AMDGPU driver (according to dmsg). I have set amdgpu in Xorg config.
The problem is probably in creating init images as mkinitrd complains about not being able to find single radeon/.bin and amdgpu/.bin (this holds true even for older kernels that were OK before),
althought these files exist in /lib/firmware/
I further tried to block amdgpu module by “modprobe.blacklist=amdgpu” on kernel commandline in grub2, this gets me into kind of flickering
(but workable – probably X restarting in loop) shell.
The thing pointing to init images is that i can run amdgpu as usual if i do simple “sudo modprobe amdgpu” in the shell after boot it works
and X starts up in few seconds… after that i can login and plasmashell runs normally, even with OpenGL support.

I tried to reinstall package containing firmwares and rerun mkinitrd, but without luck.

That makes sense if needed firmware is not included in the initrd and the system tries to load the radeon module early, when local filesystems are not yet mounted.
That behaviour should be fixed by rebuilding the initrd with:


dracut --host-only --fwdir /lib/firmware/amdgpu --force

but, as already written, I cannot test…

Thanks a LOT, that did the trick (at least for my amdgpu issue). I had to use:

 dracut --host-only --fwdir /lib/firmware --force 

But it makes me wonder, what is default “fwdir” path if i simply run “mkinitrd”? I thought “/lib/firmware” is default…

My issues were fixed by:


dracut --host-only --fwdir /lib/firmware/radeon --force
 

My card is an older card (R7 M265), so the best driver is the radeon driver. In my case, I did have to specify “firmware/radeon”. The amdgpu driver also worked for me, but could not support second monitor via VGA or HDMI, nor audio out on HDMI. All works well with the radeon driver.

Based on my research, AMD cards with GCN architecture 3 & 4 and higher should use amdgpu driver. This is the newest driver, just added to the kernel in 4.9.

For older AMD cards, it is recommended to use the radeon driver. There is a useful chart showing drivers for various AMD architectures here: Xorg - ArchWiki

Nice to read both of you are up and running again. And thanks for sharing the additional details.
Have Fun.

Actually, i updated to Kernel 4.9.6-1 and it ofcourse broke down again.
Is kernel update using “mkinitrd”? because it still can’t find firmware files.
So I would consider this rather a workaround than fix… and I have no idea, what could be broken or how to fix this permanently.
Otherwise I’m stuck with having to run dracut manually after each kernel update.

Yes, a kernel update triggers a rebuild of the initrd as a post-install task, since the kernel package itself doesn’t know the exact needs of each system where it is going to be installed.
To make your changes permanent you have to add the firmware directory to the dracut configuration.
You can do so by creating a file named, for instance, /etc/dracut.conf.d/02-early-video.conf with the following content:


fw_dir+=/lib/firmware

if that setting worked on the command line.
For details please see:


man dracut.conf

Indeed! And accordingly in my systems (no AMDs…) I find the firmwares I need in the initrd without any special config.
So this seems an hiccup related to AMD graphics and the new kernel 4.9 setup.
You may consider filing a bugreport on https://bugzilla.opensuse.org/

Hi
Just to toss something into the mix… my Mullins R5 (GCN 1.1) card runs fine with the 4.9.6 kernel and amdgpu driver… not had a hiccup at all with Tumbleweed (or Leap 42.2 [multiboot system]), one thing I do note, my Xorg log files are stored at user level (~/.local/share/xorg/) not system level…

I don’t run plymouth…first thing to go and lock the packages and rebuild initrd… plus use the GNOME DE.

So it was my fault after all, i tried amdgpu-pro driver and it adds its config files into “/etc/dracut.conf.d”.
Anyways thanks for explanation of dracut.

Hello!
I am having a similar problem with the 4.9.6 kernel and Tumbleweed after running zypper dup yesterday, and now I cannot boot into it. It keeps pointing out to missing amdgpu drivers (I have Mullins R5). Adding nomodeset to grub allows me to get into the command line after it fails to boot into X, otherwise X freezes into a blank screen.
Once I manage to access tty1 I get [drm] *VGACON disable radeon kernel modesetting and *No UMS support in radeon module!
I have tried to dracut workaround, but to no avail. I still cannot boot into X and dracut points that there are missing drivers (one of them being the mullins driver).
I am an end user; not an engineer nor a developer, but I’ve been using openSUSE since 13.1 without a glitch, and have been using Tumbleweed since last year without problems; so I’m a bit at a loss here (and in dire need of my computer. :’()

Hi and welcome to the openSUSE Forums!
Mullins firmware are in the /lib/firmware/radeon directory, so the workaround should be that described in post #8.
But Malcolm reported no problems in post #13 with a Mullins, so maybe you have a different config?
Hope that Malcolm is reading this later today (Time zone counts…)

Hi
I use a /X11/xorg.conf.d/20-amdgpu.conf file containing;


Section "Device"
   Identifier "AMD Graphics Core Next GPU"
   Driver "amdgpu"
   Option "DRI" "3"
   Option "TearFree" "true"
EndSection

And blacklist the radeon driver with a /etc//modprobe.d/50-radeon.conf file containing;


blacklist radeon

Then rebuild the initrd with mkinitrd

lol!Brilliant! Worked like a charm! Thank you, Malcolm!

Having the same problems as mentioned (wont boot with kernel 4.9.6, or any other kernels), stuck at screen flashing, and have the ACPI errors for kernels > 4.9.0 My case is a little bit different though, namely:

  1. NVIDIA Graphics card (using the proprietary drivers, though I have to re-install them with every kernel change)

  2. Cant boot with any of my available kernels (stuck at the flashing screen). I have 4.9.6, 4.9.6, 4.9.0, 4.8.13, 4.8.8

  3. the nomodeset fix for the flashing screen does not work

I’ve actually had this problem for a while, I was just able to sometimes log in fast enough before the screen started to flash and was then able to re-install my graphics drivers which let me use my computer. Now after doing a zypper -dup I am unable to ever get past the flashing screens. I also noticed that when I do a hardware shutdown (press the power button) the screen stops flashing for a second before it shuts down.

At this point I cannot log in at all on my desktop (my laptop running 4.9.5 with intel opensource drivers has never had this problem, guessing it has to do with graphics) and need to find a way to stop the screen from flashing before I can do anything.

Thanks

On 02/04/2017 05:36 PM, 8ofspades wrote:
>
> Having the same problems as mentioned (wont boot with kernel 4.9.6, or
> any other kernels), stuck at screen flashing, and have the ACPI errors
> for kernels > 4.9.0 My case is a little bit different though, namely:
>
> 1. NVIDIA Graphics card (using the proprietary drivers, though I have to
> re-install them with every kernel change)
>
> 2. Cant boot with any of my available kernels (stuck at the flashing
> screen). I have 4.9.6, 4.9.6, 4.9.0, 4.8.13, 4.8.8
>
> 3. the nomodeset fix for the flashing screen does not work
>
> I’ve actually had this problem for a while, I was just able to sometimes
> log in fast enough before the screen started to flash and was then able
> to re-install my graphics drivers which let me use my computer. Now
> after doing a zypper -dup I am unable to ever get past the flashing
> screens. I also noticed that when I do a hardware shutdown (press the
> power button) the screen stops flashing for a second before it shuts
> down.
>
> At this point I cannot log in at all on my desktop (my laptop running
> 4.9.5 with intel opensource drivers has never had this problem, guessing
> it has to do with graphics) and need to find a way to stop the screen
> from flashing before I can do anything.
>
> Thanks
>
>

At the grub prompt use the second choice, select the kernel you want to
boot to, press e to edit the boot parameters, cursor to the line that
starts with linux, press the “end” key to get to the end of the line,
add a space and 3, hit F10 to boot. This should boot you to a text login
screen on tty1 where you can log in and rebuild your Invidia driver.
This is what works for me.


Ken
linux since 1994
S.u.S.E./openSUSE since 1996