Will Not Boot After Update

After todays kernel update openSUSE 11.2 will not boot. I have both Ubuntu 9.10 and openSUSE 11.2 dual booting and since I installed Ubuntu first, it is using the Ubuntu GRUB as my boot menu. After todays kernel update, when I select openSUSE 11.2 from the GRUB menu I get Error, you must open kernel first: Press any key to continue… Pressing a key reboots the machine. I’m thinking that the update did not update the GRUB menu from Ubuntu to open the new version kernel. How can I manually edit it or get GRUB to scan for the new kernel so openSUSE will boot?

A little confused by this because if you installed Ubuntu then SUSE you would be using SUSE’s grub.

Please try and clarify which bootloader you have been using. SUSE’s is a nice green splash image, but Ubuntu is plain text by default.

Never mind… Went over to the Ubuntu Form and found the answer.

From the terminal type: “sudo update-grub”

This updated my Ubuntu GRUB to reflect the change in the version number of openSUSE.

Hope this will help someone else who may run into this problem.

Which means you were using Ubuntu grub
This might be handy for you
https://wiki.ubuntu.com/Grub2

With regard to the confusion on which GRUB I’m using, I am using the UBUNTU GRUB menu. Why, OpenSUSE is installed on a separate physical drive from Ubuntu. When I installed SUSE, in order to reduce confusion during the install, the Ubuntu drive was unplugged. After SUSE was up and running, I rebooted with the Ubuntu drive plugged in. The Ubuntu GRUB went out and found the SUSE drive and added it to the GRUB menu. When I did todays update, apparently the Ubuntu GRUB would,could not update by itself hence the manual “sudo update-grub” fixed the problem… Hope this answers your question…

Clear to me.
Ubuntu Grub2 is nice. I just wrote an article on it for Linux Format

I have the same problem with loading the operating system, opensuse 11.2, after upgrading the kernel to 2.6.31.8. After the discovery of errors, I loaded the operating system Ubuntu, mounted the root partition opensuse. Discovered that there is missing file /boot/initrd-2.6.31.8-0.1-default.

Hi,

I have an server with two versions of openSUSE (11.1 and 11.2) and I use the XEN kernel. There is also a primary partition with windows. The openSUSE linux 11.2 is located on disk 6.

I updated the kernel yesterday and could not reboot the XEN kernel 11.2 nor the default kernel. “Error 17 file not found” as far as i remember

I found one more entry (SUSE LINUX) in the boot options that allowed booting and I had a look to grub in Yast
The XEN kernel and my old default kernel were bad defined >:(

The entry were prefixed by (hd0,0) which refers to the windows partition. :stuck_out_tongue:

###Don't change this comment - YaST2 identifier: Original name: xen###
title Xen -- openSUSE 11.2 - 2.6.31.8-0.1
    root (hd6,0)
    kernel (hd0,0)/boot/xen.gz
    module (hd0,0)/boot/vmlinuz-2.6.31.8-0.1-xen root=/dev/cciss/c0d6p1 ipv6.disable=1 vga=0x317
    module (hd0,0)/boot/initrd-2.6.31.8-0.1-xen

I removed all (hd0,0) and thereafter reboot occurs without problem with the XEN kernel

Seems also that the update want to work with device by ID and maybe doesn’t work correctly with the old device name.
Here is my grub menu:
3 first entries were all modified with the prefix (hd0,0,) and the fourth entry ( SUSE LINUX) added by the update

default 3
timeout 8
gfxmenu (hd6,0)/boot/message

###Don't change this comment - YaST2 identifier: Original name: xen###
title Xen -- openSUSE 11.2 - 2.6.31.8-0.1
    root (hd6,0)
    kernel /boot/xen.gz
    module /boot/vmlinuz-2.6.31.8-0.1-xen root=/dev/cciss/c0d6p1 ipv6.disable=1 vga=0x317
    module /boot/initrd-2.6.31.8-0.1-xen

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 11.2 - 2.6.31.8-0.1
    root (hd6,0)
    kernel /boot/vmlinuz-2.6.31.8-0.1-desktop root=/dev/cciss/c0d6p1 resume=/dev/disk/by-id/cciss-3600508b1001033363820202020200004-part1 splash=silent quiet showopts ipv6.disable=1 vga=0x317
    initrd /boot/initrd-2.6.31.8-0.1-desktop

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.2 - 2.6.31.8-0.1
    root (hd6,0)
    kernel /boot/vmlinuz-2.6.31.8-0.1-desktop root=/dev/cciss/c0d6p1 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x317
    initrd /boot/initrd-2.6.31.8-0.1-desktop

###Don't change this comment - YaST2 identifier: Original name: linux###
title SUSE LINUX    
    root (hd6,0)
    kernel /boot/vmlinuz root=/dev/disk/by-id/cciss-3600508b1001033363820202020200008-part1 resume=/dev/disk/by-id/cciss-3600508b1001033363820202020200004-part1 splash=silent quiet showopts ipv6.disable=1 vga=0x317
    initrd /boot/initrd

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- SUSE LINUX
    root (hd6,0)
    kernel /boot/vmlinuz root=/dev/disk/by-id/cciss-3600508b1001033363820202020200008-part1 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x317
    initrd /boot/initrd

###Don't change this comment - YaST2 identifier: Original name: menu###
title opensuse 11.1
    root (hd1,1)
    configfile /boot/grub/menu.lst

Strange problem

Regards
Philippe

Sometimes the initrd doesn’t get built after a kernel update.
fire up the dvd or net install cd from repair installed sysem
boot installed system then in a console as root enter the command mkinitrd
check your boot loader via yast and definetely check /boot to make sure your kernel and initrd are there.

I get in and out of the habit of checking /boot after a kernel upgrade:P

Yes, with the help of your tips turned out to restore the boot the operating system. For other people who may be to solve the same problem, do these steps:

  1. Boot from the DVD OpenSUSE, select Rescue mode
  2. Register as root
  3. Mount the partition with the operating system, mount /dev/sda7 /mnt
  4. chroot /mnt
  5. On my system, there was no file /dev/sda7, create it, mknod /dev/sda7 b 8 7
  6. Create a new initrd file without updating the bootloader, mkinitrd-B
  7. Load the operating system Ubuntu. Refresh the bootloader - sudo update-grub