wiimote and opensuse 11.3?

I have tried to compile cwiid on OpenSUSE 11.3 and no luck, so I installed it from factory and the wmgui works, but wminput doesn’t.
I get:

unable to open uinput

Both when trying to run it as root and as a non-privileged user.
It works fine on 11.2.
Does anybody know what’s wrong, or if there is an alternative to it?

Bluetooth installed and working?

Yes, and I’ve got it working with xwii, but would prefer wminput because of its configuration simplicity.

I am having the same problem. I assume bluetooth is working, I can open wmgui and pair a remote and see all the button data and control the leds and stuff that wmgui lets you do. wminput causes an error unable to open uinput.

I was able to compile from 11.3, but I had to modify some of the source code. #74 (libcwiid/bluetooth.c hci_remote_name should be hci_read_remote_name)](http://abstrakraft.org/cwiid/ticket/74) deals with the only part of the compile I had trouble with.

as an aside, did you have any problems getting XWii to work? I get:

[INFO] Found wiimote (00:1C:BE:15:3C:58) [id 1].
connect() output sock: Invalid argument
Failed to connect to any wiimote.

when I try to connect with XWii

No, XWii just works fine for me, aside from it being a little to chatty with my bluetooth dongle.
I did compile it from source though and I run it with start_xwii.py.

I got cwiid to work. I ran

/sbin/modprobe uinput <----might have to be sudo depending on set up
sudo wminput -d -c [PATH TO CONFIG FILE]

Yep that fixes it, I guess 11.2 loades the uinput module by default, but 11.3 doesn’t.