wifi stopped to work after kernel upgrade


i use opensuse 11.4 with tumbleweed repository after i upgraged to kernel

wifi stoped to work, led is not enable and i’m not able to connect to router

wifi info

06:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
        Subsystem: Intel Corporation Device [8086:1050]
        Flags: bus master, fast devsel, latency 0, IRQ 45
        Memory at cc000000 (32-bit, non-prefetchable) [size=4]
        Capabilities: [c8] Power Management version 2
        Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [e0] Express Legacy Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number 00-19-d2-ff-ff-0d-19-02
        Kernel driver in use: iwl3945

dmesg return me

 1931.429768] iwl3945 0000:06:00.0: Card state received: HW:Kill SW:On
 1931.441174] iwl3945 0000:06:00.0: Not sending command - RF KILL
 1931.441183] iwl3945 0000:06:00.0: Error sending REPLY_RXON: enqueue_hcmd failed: -5
 1931.441189] iwl3945 0000:06:00.0: Error setting new configuration (-5).
 1931.442097] iwl3945 0000:06:00.0: MAC is in deep sleep!.  CSR_GP_CNTRL = 0x040003DD
 1941.165405] ADDRCONF(NETDEV_UP): wlan0: link is not ready

any idea?


Check it with rfkill

You may need to install it:

zypper in rfkill

Then to check

/usr/sbin/rfkill list

If blocked at all

su -
rfkill unblock all

rfkill list return me

0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

rollbacked to previous kernel, work well

Please make a bug report then
login is the same as forum

tried to upgrade to kernel head 3.x… same problem…
i done a bug report… but now i don’t find the lastest kernel who worked fine…

try to install backports modules wireless and/or new drivers

Download - Linux Wireless