Wifi shared ap with password


this is my first post, i want to ask question why when i make Wifi shared ap without password i can connect to it with my mobile but when make password wpa/wpa 2 personal
my mobile can not connect always incorect password.


I don’t have an answer.

Here, I have my AP configured for WPA2, and my mobile device is connecting without problems.

Did i make wrong configuration:question: but i make from the default kde network manager i fill up everything i don’t touch anything else.


It is hard to know what is going wrong.

I doubt that your KDE settings are causing this problem. Perhaps the settings on the AP configuration itself. Or, at least, that is where I would look.

is there anything wrong with this :question:

id=New 802-11-wireless connection







I don’t see an obvious problem.

Comparing that NetworkManager file with mine, I do see a few differences, but they mostly don’t look important.

In the “wifi-security” section, you have “psk-flags=1”. I don’t have anything equivalent to that.

In both “ipv4” and “ipv6” sections, I have “method=auto” which is different from what you have.

I don’t know enough about NetworkManager internals to be sure whether those differences are relevant.

Neither know I, but likely “psk-flags=1” means “no passphrase” (and the OP writes that with no passphrase everything seems correct).
In that place I have: “psk=<my passphrase is written here>”
The passphrase can be changed in nm-connection-editor (hit ALT+F2 and enter nm-connection-editor in the popup box).
No other difference seems relevant to me too.

EDIT: in both [ipv4] and [ipv6] I have method=shared, so the OP should be fine with the current setup.

do you know how the process in opensuse that make my mobile connect to ap always incorrect password :question: and is it possible that i change manually from terminal or dolphin the configuration :question:


There’s an “nmcli” and an “nmtui” for configuring a connection from the command line. But they are probably hard to use, especially when you are having problems.

Here’s something to try. Go into the Connection Editor (right click on network icon in the tray). Go to the security settings for this connection. And there are choices on where to store the password. The default is to store in “kdewallet”, and that’s probably what you are using. There’s another choice to store in a file unencrypted. You could try that.

With that change, the password is saved in that file you showed from “/etc/NetworkManager/system-connections” (and readable only by root). And maybe then you can manually check whether the correct password is saved there.

Immediately following your failure to connect to your AP,
Run the following and post…

systemctl status NetworkManager.service

Many things can cause a connection failure, so this is a first try to get some useful log info.
If the above doesn’t work, then there are other tries like doing a journalctl search.

Speaking of which…
Try launching the following in a console which will enable you to read entries to the system log in real time, then while the console window is still open, try connecting to your AP. Any failures and errors written to your system log should appear immediately in the following window

journalctl -f