Wifi only when plugged in?


I am a bit desperate because I’ve been working for hours getting openSuse to recognize my Broadcom network card (on a Lenovo 3000 C200 laptop), and finally got it to work with ndiswrapper. (You need to know that my experience with Linux dates back only to yesterday, when Windows stopped working and I decided it was a nice opportunity to switch to something else. So I am a newbie here.)

However, now I see that my wireless network only works when the computer is plugged in. I remember I had more or less the same problem with Windows, but I was able to go somewhere and tweak the card’s parameters and its power usage. However, with openSuse I don’t know where to go to do that.

Could someone help me with that. Please be very explicit, as I’ve found some explanations but wasn’t able to understand them!

Thanks a lot,


If you choose from the Application Launcher “Configure Desktop (Personal Settings)” and then click on the “Advanced” tab and choose the icon for “Power Management,” you might be able to tell the computer to work the same way unplugged as it does plugged in. There’s probably a much better solution, but that might get you by until you learn more.

Hi, there is a setting for the powersaving feature of your network card buried in yast. Open yast, goto network devices, network settings, edit your wireless card, click next to go to the second screen, click expert settings and tadaa, uncheck “use power management”
If that fails to have an effect, install Wicd, that works better for me than networkmanager at the moment so it may be worth a try.