Wifi on Raspberry Pi3

Hey all,

So i’ve recently joined the forums here after hanging out in the Raspbian and DietPi forums for a while.
I wanted to use an operating system that supported the Arm8 architecture.

Although LEAP 4.2.2 seems to detect the onboard wifi, and I can use it for a little time.
When I attempt to setup the device into AP mode using hostapd and dnsmasq, the OS completely loses the onboard wifi device.

So my question is this…

How can I reinitiate the device as yast seems unhelpful in this area.
Coming from the previous RPI OS’s, it seems like things are setup a little different.
Where can I find the config files to manually reconfigure this, and what driver is opensuse using?

Any help gratefully appreciated.

Hi and welcome to the forum :slight_smile:
The file to check is /etc/dracut.conf.d/raspberrypi_modules.conf you need to remove the # from the omit_drivers and rebuild initrd (mkinitrd).

Hi and thank’s for the response…

So I checked /etc/dracut.conf.d/raspberrypi_modules.conf and the # was all ready removed from omit drivers.
I did a mkinitrd and a reboot, this did not resolved the issue.

There is no card listed when I do either a ifconfig or iwconfig.
If I go into the yast network management I see the card listed, but cannot get it to scan for any networks.

It looks like the driver isn’t being loaded.
If I go to the hardware details under yast, and look at the kernel module, there is nothing there, and no available options to select.

Hi
OK, a few more steps by the looks… see Re: [opensuse-arm] Still no wlan on Raspberry 3 - openSUSE ARM - openSUSE Mailing Lists

Ok so I finally got this working again, here’s what I did:-


cd /bin
wget https://raw.githubusercontent.com/Hexxeh/rpi-update/master/rpi-update
chmod 755 rpi-update
./rpi-update
reboot 

After this:-


nano /etc/dracut.conf.d/raspberrypi_modules.conf etc

add_drivers+=" sdhci-iproc bcm2835-sdhost bcm2835_dma mmc_block "
# Workaround for Wifi
# omit_drivers+=" sdhci-iproc"


And edit the file, removing sdhci-iproc from the add drivers, and uncommenting the omit_drivers


nano /etc/dracut.conf.d/raspberrypi_modules.conf etc

add_drivers+=" bcm2835-sdhost bcm2835_dma mmc_block "
# Workaround for Wifi
omit_drivers+=" sdhci-iproc"


Save, exit and then run.

mkinitrd

The key to this working I think is the rpi-update. When I tried editing /etc/dracut.conf.d/raspberrypi_modules.conf before doing the rpi-update it killed my system
Ill run some test and see if its stable…

Hi
If you want to update the firmware, please use the openSUSE files from hardware repo…

You need raspberrypi-firmware-2017-04-04 and raspberrypi-firmware-config-rpi3-2017.04.04

http://download.opensuse.org/repositories/hardware/openSUSE_Leap_42.2/noarch/