Wifi on Dell Latitude 2100?

Hello everyone,

I did some spring cleaning this weekend and discovered an almost-forgotten Dell Latitude 2100 netbook on my shelf that had been collecting dust for the last couple of years.

I thought I might put this device to use once more and tried to install Tumbleweed on it, only to discover that apparently the Wifi interface was not detected.
Before that, it had Ubuntu 12.04 installed, where the wifi interface did work, but support for 12.04 ended quite a while ago, and obviously it has been a while since I installed it, so I do not remember if I had to take any additional steps to get Wifi to work.

In case it matters, the ethernet interface was detected, but since I have no free ports on my switch, I did not attempt to connect it. Maybe there is an additional driver package or something. I have tried a couple of other distros, too, but Wifi did not work on any of them, at least not out of the box.

Has anyone managed to get Wifi working on openSuse on this device?
If not, it is not a big problem, but it would be kind of a shame to let a working computer go to waste. I vaguely remember that Wifi used to work just fine out of the box on Ubuntu, but that was a long time ago, and netbooks apparently went out of style since.

Google was not very helpful in this case. Apparently there is a Linux driver for it, but the only download I found offered drivers for RHEL/CentOS. :frowning:

Thank you very much for any insights you might be able to share with me,

Sounds like it might be a broadcom device, which needs the broadcom-wl package and kmp from the packman repository.

Can you post the output from the lspci command, eg;

 /sbin/lspci -nnk |grep -A3 Network
0c:00.0 Network controller [0280]: Broadcom Corporation BCM43224 802.11a/b/g/n [14e4:4353] (rev 01)
    Subsystem: Dell Wireless 1520 Half-size Mini PCIe Card [1028:000e]
    Kernel driver in use: wl
    Kernel modules: bcma, wl

Thank you very much! I made another attempt at installing Tumbleweed today, but the installer could not access the network via good old ethernet. :expressionless:
I’ll try again in the next days using a different cable and report back

Once more, thank you very much!

Okay, so I made another attempt last night, after getting a new ethernet cable. It all worked well, until I tried to install the broadcom driver, at which point I got an error that I think complained that the broadcom driver module was compiled for a different kernel version. 4.12.something?

At this point I remember three things:

  1. I have a USB wifi dongle lying around that came with my Raspberry Pi; that one should probably work, if I am willing to sacrifice a USB port.
  2. While I think it is a shame to let a working computer go to waste, the machine in question is severely constrained in almost every significant aspect: The CPU is /very/ slow, the single gigabyte of RAM means that I cannot run a modern browser on it, which is just as well, because the display has a native resolution of 1024x576 pixels. TL;DR, this is a toy computer (although it does come in a very nice, rugged case).
  3. I already own, like, four moderately outdated notebooks that I adopted because I thought it was a shame to throw a working computer away. I won’t throw it away, but I have no use for it now.

Thank you very much for your help!

An option for those laptops might be another distro such as LinuxLite or Bodhi. They are very good on machines with older hardware and fewer resources.