Wifi not working

You’ll need a new driver for that card, it was described recently.
https://forums.opensuse.org/showthread.php/517984-Unstable-realtek-WIFI-connection

Well, the device node is there, just not activated for some reason.

That’s interesting. It may well be a newer driver build is worth trying, but the ‘wlan0’ device node is being created, and the dmesg results don’t show any obvious issues. I just wonder if a restart will do the trick.

I did install the drivers suggested in the link earlier on but doesn’t make a difference.

I’ve restarted my pc a couple of times now. No visible changes. All remains the same. I’m afraid I’ll have to re-install the OS afresh.

Yes, it’s not clear to me that although the driver is loaded, the device is not active as expected. You could try upgrading the kernel as explained here (post #3), although I’m not certain that it will help.

As a test, switch to using wicked, then configure it to associate with your wireless network as explained here

https://doc.opensuse.org/documentation/leap/reference/html/book.opensuse.reference/cha.basicnet.html#sec.basicnet.yast.netcard.global

The ‘wlan0’ device node should be present. This will list active network device nodes

/sbin/ifconfig

This will list all network device nodes, active and inactive

/sbin/ifconfig -a

If it is only present with the last command (ie inactive), you can manually bring it up with

ifup wlan0

One more thing, any error messages reported if you unload and reload the driver?

modprobe -r rtl8723be
modprobe rtl8723be

You could also review the advice thread which describes loading the driver with particular options…YMMV…

http://askubuntu.com/questions/590414/wifi-problems-with-rtl8723be-in-ubuntu-14-04

echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf

Then unload and reload the driver (or reboot).
](http://askubuntu.com/questions/590414/wifi-problems-with-rtl8723be-in-ubuntu-14-04)

Both commands return nothing. In the meanwhile let me try your other suggestions.

All the other options failed to make any change. However, I upgraded the kernel (though I normally update, weekly, my OS using this same repo you gave) and I noticed some change:
/sbin/ifconfig returns:

eth0      Link encap:Ethernet  HWaddr 70:5A:0F:B8:23:05   
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000  
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback   
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:72 errors:0 dropped:0 overruns:0 frame:0
          TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1  
          RX bytes:4120 (4.0 Kb)  TX bytes:4120 (4.0 Kb)

usb0      Link encap:Ethernet  HWaddr AA:BB:CC:DD:EE:FF   
          inet addr:192.168.42.132  Bcast:192.168.42.255  Mask:255.255.255.0
          inet6 addr: fe80::a8bb:ccff:fedd:eeff/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2805 errors:4 dropped:0 overruns:0 frame:4
          TX packets:3396 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000  
          RX bytes:1143676 (1.0 Mb)  TX bytes:788247 (769.7 Kb)

wlan0     Link encap:Ethernet  HWaddr 44:1C:A8:73:69:81   
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000  
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)


However, after following the advice from this answer, i rebuilt the modules and this is what /sbin/ifconfig returns now:

eth0      Link encap:Ethernet  HWaddr 70:5A:0F:B8:23:05   
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000  
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback   
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:72 errors:0 dropped:0 overruns:0 frame:0
          TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1  
          RX bytes:4120 (4.0 Kb)  TX bytes:4120 (4.0 Kb)

usb0      Link encap:Ethernet  HWaddr AA:BB:CC:DD:EE:FF   
          inet addr:192.168.42.132  Bcast:192.168.42.255  Mask:255.255.255.0
          inet6 addr: fe80::a8bb:ccff:fedd:eeff/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6865 errors:5620 dropped:0 overruns:0 frame:55
          TX packets:6875 errors:10 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000  
          RX bytes:3962657 (3.7 Mb)  TX bytes:1447735 (1.3 Mb)

With wlan0 active, did you then try configuring via NetworkManager?

However, after following the advice from this answer, i rebuilt the modules and this is what /sbin/ifconfig returns now:

Why did you rebuild the module again? I only suggested changing the module options (via /etc/modprobe.d/). I would reinstall the kernel again…

zypper in --force kernel-default

Despite wlan0 being active, the wifi icon still didn’t display on the network manager pop-up.

As a test, change to wicked and configure using YaST.

I don’t know how to configure Wicked but I realised that it could scan for a network and the configurations I saved could be utilised in nm. Nonetheless, I have little knowledge on networking thus I can’t configure things like DHCP and Hostname.

I gave you a link to openSUSE documentation (a few posts back) showing you how to do that :wink:

YaST > System > Network Settings > Global Options

Anyway, it was just for test purposes… and you mentioned that you could scan for a network and configure (successfully)? So, now you should be able to use NM to activate the connection. From a terminal, your available connections can be shown with

nmcli c

You should be able to get connected to “name of connection” using something like

nmcli con up "<name of connection>"