Wifi not working

I am accustomed to tethering my pc to my phone to use internet. However, i recently noticed that my wifi icon is not available in the status bar and disabling/enabling wicked service and NetworkManager doesn’t seem to help, neither does turning on/off airplane mode. Any help would be much appreciated.

Start from the top. Identify your hardware and post output here

/usr/sbin/hwinfo --netcard

If the machine doesn’t have wired internet connectivity, then copy/paste to a text file and transfer to a machine that does via memory stick. We need to know whether a working wireless network driver is associated and loaded.

This will tell us if NetworkManager or wicked is in use…

system status network

BTW, it’s worth reading the sticky posts at the beginning of the wireless forum first. Lots of valuable info there to help progress wireless issues like yours

https://forums.opensuse.org/forumdisplay.php/676-Wireless

This screenshot shows the problems am facing.

I have installed the required drivers but I cannot see the wifi icon. It says my wireless card is not configured. I cannot add some configuration nor edit any. Please help.

/usr/sbin/hwinfo --netcard

returns


22: PCI 700.0: 0200 Ethernet controller                          
  [Created at pci.366]
  Unique ID: rBUF.r+RBLbxlra0
  Parent ID: hoOk.KHXNuk4yHk2
  SysFS ID: /devices/pci0000:00/0000:00:1c.2/0000:07:00.0
  SysFS BusID: 0000:07:00.0
  Hardware Class: network
  Model: "Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0x8136 "RTL8101E/RTL8102E PCI Express Fast Ethernet controller"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x80c1  
  Revision: 0x07
  Driver: "r8169"
  Driver Modules: "r8169"
  Device File: eth0
  I/O Ports: 0x4000-0x4fff (rw)
  Memory Range: 0xc5000000-0xc5000fff (rw,non-prefetchable)
  Memory Range: 0xc5100000-0xc5103fff (ro,non-prefetchable)
  IRQ: 46 (no events)
  HW Address: 70:5a:0f:b8:23:05
  Link detected: no
  Module Alias: "pci:v000010ECd00008136sv0000103Csd000080C1bc02sc00i00"
  Driver Info #0:
    Driver Status: r8169 is active
    Driver Activation Cmd: "modprobe r8169"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #15 (PCI bridge)

23: PCI d00.0: 0282 WLAN controller
  [Created at pci.366]
  Unique ID: y9sn.kOSB13gZvM0
  Parent ID: HnsE.QmBtm58PSc3
  SysFS ID: /devices/pci0000:00/0000:00:1c.5/0000:0d:00.0
  SysFS BusID: 0000:0d:00.0
  Hardware Class: network
  Model: "Realtek RTL8723BE PCIe Wireless Network Adapter"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0xb723 "RTL8723BE PCIe Wireless Network Adapter"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x804c  
  Driver: "rtl8723be"
  Driver Modules: "rtl8723be"
  Device File: wlan0
  Features: WLAN
  I/O Ports: 0x3000-0x3fff (rw)
  Memory Range: 0xc3000000-0xc3003fff (rw,non-prefetchable)
  IRQ: 16 (no events)
  HW Address: 44:1c:a8:73:69:81
  Link detected: no
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v000010ECd0000B723sv0000103Csd0000804Cbc02sc80i00"
  Driver Info #0:
    Driver Status: rtl8723be is active
    Driver Activation Cmd: "modprobe rtl8723be"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #16 (PCI bridge)

27: USB 00.0: 0291 USB Host-to-Host link
  [Created at usb.122]
  Unique ID: 2UT6.TNypVmT7Rz0
  Parent ID: k4bc.2DFUsyrieMD
  SysFS ID: /devices/pci0000:00/0000:00:14.0/usb1/1-3/1-3:1.0
  SysFS BusID: 1-3:1.0
  Hardware Class: network
  Model: "Samsung Electronics GT-I9070 (network tethering, USB debugging enabled)"
  Hotplug: USB
  Vendor: usb 0x04e8 "Samsung Electronics Co., Ltd"
  Device: usb 0x6864 "GT-I9070 (network tethering, USB debugging enabled)"
  Revision: "4.00"
  Serial ID: "420323fd617c2100"
  Driver: "rndis_host"
  Driver Modules: "rndis_host"
  Device File: usb0
  Speed: 480 Mbps
  HW Address: aa:bb:cc:dd:ee:ff
  Link detected: yes
  Module Alias: "usb:v04E8p6864d0400dc02dsc00dp00ic02isc02ipFFin00"
  Driver Info #0:
    Driver Status: rndis_wlan is active
    Driver Activation Cmd: "modprobe rndis_wlan"
  Driver Info #1:
    Driver Status: rndis_host is active
    Driver Activation Cmd: "modprobe rndis_host"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #26 (Hub)


system status network

returns

If 'system' is not a typo you can use command-not-found to lookup the package that contains it, like
 this:
    cnf system



23: PCI d00.0: 0282 WLAN controller
  [Created at pci.366]
  Unique ID: y9sn.kOSB13gZvM0
  Parent ID: HnsE.QmBtm58PSc3
  SysFS ID: /devices/pci0000:00/0000:00:1c.5/0000:0d:00.0
  SysFS BusID: 0000:0d:00.0
  Hardware Class: network
  Model: "Realtek RTL8723BE PCIe Wireless Network Adapter"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0xb723 "RTL8723BE PCIe Wireless Network Adapter"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x804c  
  Driver: "rtl8723be"
  Driver Modules: "rtl8723be"
  Device File: wlan0
  Features: WLAN
  I/O Ports: 0x3000-0x3fff (rw)
  Memory Range: 0xc3000000-0xc3003fff (rw,non-prefetchable)
  IRQ: 16 (no events)
  HW Address: 44:1c:a8:73:69:81
  Link detected: no
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v000010ECd0000B723sv0000103Csd0000804Cbc02sc80i00"
  Driver Info #0:
    Driver Status: rtl8723be is active
    Driver Activation Cmd: "modprobe rtl8723be"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #16 (PCI bridge)

Okay,so your wireless device is detected and the rtl8723be driver is loaded.

The last command should have been

systemctl status network

You need to ensure that the wireless device is not soft-blocked with rfkill (you may need to install package of the same name first)

/usr/sbin/rfkill list

Please keep your posts related to your wireless issue in one thread. I’ll merge this one.

Just to be clear, you only need to configure the wireless network device via YaST if you’re using wicked.

I get

0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: yes
        Hard blocked: no


How to unblock it?

i ran

rfkill unblock 1

but still i get no icon in the System Tray.
I am using Network Manager.

It’s best if you demonstrate that it is unblocked now with the rfkill command, so that we can see for ourselves :wink:

rfkill list

Then check for the existence of a wireless network device node

/sbin/ifconfig

What is reported by the following?

nmcli g

Duly noted:)

rfkill list


0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no


/sbin/ifconfig


eth0      Link encap:Ethernet  HWaddr 70:5A:0F:B8:23:05   
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000  
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback   
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2215 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2215 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1  
          RX bytes:169367 (165.3 Kb)  TX bytes:169367 (165.3 Kb)

usb0      Link encap:Ethernet  HWaddr AA:BB:CC:DD:EE:FF   
          inet addr:192.168.42.132  Bcast:192.168.42.255  Mask:255.255.255.0
          inet6 addr: fe80::a8bb:ccff:fedd:eeff/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10988 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10040 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000  
          RX bytes:8889689 (8.4 Mb)  TX bytes:1906049 (1.8 Mb)

nmcli g


STATE      CONNECTIVITY  WIFI-HW  WIFI      WWAN-HW  WWAN      
connected  full          enabled  disabled  enabled  disabled

PS: I am currently connected to the internet via tethering to my phone.

Okay, this confirms NM wifi is disabled


STATE      CONNECTIVITY  WIFI-HW  WIFI      WWAN-HW  WWAN      
connected  full          enabled  disabled  enabled  disabled

Try the following (as regular user)

nmcli radio wifi on

Then check NM status again. Once ‘WIFI’ is reported as enabled, check for a wireless network device node again

PS: I am currently connected to the internet via tethering to my phone.

Yes, I can see that :wink:

nmcli g

STATE      CONNECTIVITY  WIFI-HW  WIFI     WWAN-HW  WWAN      
connected  full          enabled  enabled  enabled  disabled 

/sbin/ifconfig

eth0      Link encap:Ethernet  HWaddr 70:5A:0F:B8:23:05   
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000  
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback   
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2215 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2215 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1  
          RX bytes:169367 (165.3 Kb)  TX bytes:169367 (165.3 Kb)

usb0      Link encap:Ethernet  HWaddr AA:BB:CC:DD:EE:FF   
          inet addr:192.168.42.132  Bcast:192.168.42.255  Mask:255.255.255.0
          inet6 addr: fe80::a8bb:ccff:fedd:eeff/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:43827 errors:9 dropped:0 overruns:0 frame:1
          TX packets:33308 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000  
          RX bytes:43413385 (41.4 Mb)  TX bytes:6169757 (5.8 Mb)


I guess there i no wireless device node still?:frowning:

Okay, at least wifi is enabled

STATE      CONNECTIVITY  WIFI-HW  WIFI     WWAN-HW  WWAN      
connected  full          enabled  enabled  enabled  disabled 

I guess there i no wireless device node still?:frowning:

No, but useful to check for inactvie device nodes too. Do that with

/sbin/ifconfig -a

If ‘wlan0’ is not present, then we might need to check for missing firmware perhaps.

Let’s see what is reported by the kernel for your wireless device…

dmesg|grep rtl
   14.702878] Bluetooth: hci0: **rtl**: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
   14.702882] Bluetooth: hci0: **rtl**: loading **rtl**_bt/**rtl**8723b_fw.bin
   15.944481] Using firmware **rtl**wifi/**rtl**8723befw.bin
   15.944710] **rtl**wifi: channel plan 0x20
   15.944712] **rtl**wifi: country code 11
   15.948607] ieee80211 phy0: Selected rate control algorithm '**rtl**_rc'
   15.948890] **rtl**wifi: wireless switch is on


That looks okay. What about the ‘/sbin/ifconfig -a’ command output I requested?


eth0      Link encap:Ethernet  HWaddr 70:5A:0F:B8:23:05   
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000  
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback   
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2215 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2215 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1  
          RX bytes:169367 (165.3 Kb)  TX bytes:169367 (165.3 Kb)

usb0      Link encap:Ethernet  HWaddr AA:BB:CC:DD:EE:FF   
          inet addr:192.168.42.132  Bcast:192.168.42.255  Mask:255.255.255.0
          inet6 addr: fe80::a8bb:ccff:fedd:eeff/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:71966 errors:14 dropped:0 overruns:0 frame:6
          TX packets:57656 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000  
          RX bytes:66931416 (63.8 Mb)  TX bytes:11060932 (10.5 Mb)

wlan0     Link encap:Ethernet  HWaddr 44:1C:A8:73:69:81   
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000  
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)