Wifi not starting on boot

Om every boot recently the wifi does not start
ip a says it is down. I can bring it up by running iwlist scan
Not found any other way.

Machine is Thinkpad X270

How can I get autonatic wifi back?

Is this new or did it function before? When it is new, did you do some update?

How is the network configured? Using NetworkManager or Wicked?

Etc. We are not clairvoyant, you have to explain everything to us so we get some idea about your setup, way of working, etc.


It happened after I inadvertently hit the “no wifi” button. It took some time to get wifi back but it settled on the current case. It started on 13 or 14 December. I regularly update on Saturdays or Friday with zypper.

No network manager so I assume wicked.

Setup is no desktop system, x windows with fvwm2. Wifi throughout the house with one access point.

Use mainly emacs and xterms with Seamonkey. Anything else I can say ?

I do not know if there is any connection to my earlier unresolved booting issue with keyboard layout reported here so time back.

Which “no wifi” button? Where, in what application, tool or whatvever. Such a button isn’t supposed to hang around on your screen.

And still no answer to: Wicked or NetworkManager.

I thought I said wicked

On many laptops there is a way to turn off wireless communication (think airplane mode) and on Thinkpads it is given to a shifted Fn8 key. I was trying to type Fn8 when it started as far as I can tell.

I thought I said wicked
Sorry I missed that, probably because you did not seem to be very certain about it.
But when it is Wicked, the interface should indeed start connecting to the network on boot.

Maybe something is switched off in the hardware/firmware. Not my specialty (let us hope for someone with Thinkpad internal knowledge). Can’t you check in the BIOS if some setting is there.

I ran rfkill evetuakly aftr eevenr and irt seemed to react to the button/key. Currently it says

 # rfkill
ID TYPE      DEVICE                   SOFT      HARD
 0 bluetooth tpacpi_bluetooth_sw   blocked unblocked
 2 wlan      phy0                unblocked unblocked

so I am sure this is not the issue.

If iwlist can associate the wifi with the access point it must be half up at the end of the boot.