WIFI no longer working after update

I need help solving an issue with my laptop. It started right after I upgraded to a new version of Tumbleweed, after roughly one week since the last “zypper dup”.

Upon restarting, the machine stopped showing WIFI connections in the network manager widget of the KDE system tray. The WIFI checkbox is there and enabled, the network card is definitely recognized… it’s just that there are no connections.

I noticed something peculiar that might offer a clue: When the computer boots, it lists the following job failure:

A start job is running for Network Manager Wait Online
Failed to start Network Manager Wait Online

Curious to see more, I next went to YaST - System - Services Manager and asked it to show me the log for this process. This is what it says:

● NetworkManager-wait-online.service - Network Manager Wait Online
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager-wait-online.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 2019-08-08 16:57:51 EEST; 3min 58s ago
     Docs: man:nm-online(1)
  Process: 1430 ExecStart=/bin/bash -c if  ${NM_ONLINE_TIMEOUT} -gt 0 ]; then /usr/bin/nm-online -s -q --timeout=${NM_ONLINE_TIMEOUT} ; else /bin/true ; fi (code=exited, status=1/FAILURE)
 Main PID: 1430 (code=exited, status=1/FAILURE)

Aug 08 16:57:21 linux-qugf systemd[1]: Starting Network Manager Wait Online...
Aug 08 16:57:51 linux-qugf systemd[1]: NetworkManager-wait-online.service: Main process exited, code=exited, status=1/FAILURE
Aug 08 16:57:51 linux-qugf systemd[1]: NetworkManager-wait-online.service: Failed with result 'exit-code'.
Aug 08 16:57:51 linux-qugf systemd[1]: Failed to start Network Manager Wait Online.

I’ll need to use my laptop soon so I must fix the connectivity. Any idea why this might be happening and what I should debug next? Thank you.

I don’t seem to have the ifconfig command, but here is the output of iwconfig on my laptop:

wlan0     IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=16 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
lo        no wireless extensions.

eth0      no wireless extensions.

The command “iwlist wlan0 scan | grep ESSID” does correctly list all available WIFI connections. No doubt the system is seeing them… perhaps a KDE specific issue is causing them not to get listed in the system tray?

Running “netconfig update -f” as root didn’t solve it either.

You can use

ip address

for similar output to “ifconfig -a”. Or you can install “net-tools-deprecated” if you want the old commands back.

You could maybe try using “wicked” for your WiFi connection.

Output of the “ip address” command:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 00:26:2d:84:6b:db brd ff:ff:ff:ff:ff:ff
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether de:3a:6e:6e:bf:80 brd ff:ff:ff:ff:ff:ff

I should add that I was able to connect the laptop to the internet by plugging it to the router via LAN cable, which also showed up in the tray list properly. This confirms only WIFI is affected, possibly just detection by Plasma. I need wireless internet where I’m going, and rely on the ability to see and use wireless connections from the KDE system tray (IIRC Wicked disables this).

Yes, “wicked” won’t have that tray icon. However, if you are able to connect to WiFi with “wicked”, that gives information on what is going wrong. If that also doesn’t work, then that too helps narrow down the problem.

Fair enough, but I never used Wicked and have no idea how to connect to a WIFI connection with it. Are there any clear instructions, what commands I should use to preform this test?

It’s a little less convenient to configure a wifi connection using wicked (especially if changing network environments frequently), but it’s not hard. Use YaST > System > Network Settings

Here’s the openSUSE guide
https://doc.opensuse.org/documentation/leap/reference/html/book.opensuse.reference/cha.network.html#sec.network.yast

I’m sure you can navigate your way through this.

With regards to the graphical NetworkManager connection utility, if you click on the icon do you see available networks? Does the connection editor still show your defined wireless networks? Is airplane mode on perhaps?

BTW, you can also control NetworkManager via CLI commands as well.

Will show if wifi is disabled…

nmcli g

Will show if NM is managing a given network interface…

nmcli d

Will show available connections…

nmcli c

And it can be used to activate a particular connection as well.

For more info, refer to

man nmcli

One of many guides…
https://www.tecmint.com/configure-network-connections-using-nmcli-tool-in-linux/

I got a little help to further investigate this on IRC. It appears the NetworkManager service might be itself acting up.

First of all “nmcli dev wifi” does not list any connections. I understand they should appear there, as they currently are on my desktop computer.

The output of “sudo systemctl status NetworkManager” is also rather dubious: https://pastebin.com/raw/VYLRr2vX

I also did a “sudo journalctl -b -t NetworkManager” which I hope will offer further information: https://pastebin.com/raw/NfqZrpFn

Okay, something is happening: I ran “sudo systemctl restart wpa_supplicant” followed by “sudo systemctl restart NetworkManager.service”. This caused all the WIFI connections to appear and the laptop automatically connected successfully to my router. Perhaps this error explains what might be happening?

Aug 08 18:13:39 linux-qugf NetworkManager[1269]: <warn>  [1565277219.8370] supplicant: failed to acquire wpa_supplicant proxy: Wi-Fi and 802.1x will not be available (Error calling StartServiceByName for fi.w1.wpa_supplicant1: GDBus.Error:org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'fi.w1.wpa_supplicant1': timed out (service_start_timeout=25000ms))

If I restart the machine, I need to run the commands again to get Wifi running. I did a forced update of the wpa_supplicant package: The connections still didn’t work automatically after restarting, but running just “sudo systemctl restart NetworkManager.service” fixes it after I log in. Now to resolve the problem permanently.

Here’s what I would try:

Boot to single user mode. Or boot rescue media and mount your system. The idea is to be accessing your system with NetworkManager not running.

Remove the connection definition file in “/etc/NetworkManager/system-connections/”

Remove the connection state files in “/var/lib/NetworkManager/”

Reboot to graphic mode, and configure your connection. This should now be like configuring just after a clean install, with nothing remaining from what was previously there.

(Before removing those files, you can first copy them to elsewhere in case you want to undo this).

I temporarily removed /etc/NetworkManager/system-connections and almost everything from /var/lib/NetworkManager, after running “sudo systemctl stop NetworkManager.service” and ensuring the service was down (the system tray icon disappeared to confirm this). No results after restarting unfortunately. What else do you suggest trying next?

Hi
You don’t seem to provide info on the chipset in use, not a broadcom device?

As root user post the info from;


hwinfo --network

33: None 00.0: 10701 Ethernet                                   
  [Created at net.126]
  Unique ID: usDW.ndpeucax6V1
  Parent ID: rBUF.amNVgiHJezE
  SysFS ID: /class/net/eth0
  SysFS Device Link: /devices/pci0000:00/0000:00:1c.0/0000:03:00.0
  Hardware Class: network interface
  Model: "Ethernet network interface"
  Driver: "tg3"
  Driver Modules: "tg3"
  Device File: eth0
  HW Address: 00:26:2d:84:6b:db
  Permanent HW Address: 00:26:2d:84:6b:db
  Link detected: no
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #1 (Ethernet controller)

34: None 00.0: 1070a WLAN
  [Created at net.126]
  Unique ID: AYEt.QXn1l67RSa1
  Parent ID: y9sn.0_PmERRIX24
  SysFS ID: /class/net/wlan0
  SysFS Device Link: /devices/pci0000:00/0000:00:1c.1/0000:05:00.0
  Hardware Class: network interface
  Model: "WLAN network interface"
  Driver: "ath9k"
  Driver Modules: "ath9k"
  Device File: wlan0
  HW Address: 92:93:f4:7d:a2:fb
  Permanent HW Address: 00:17:c4:dc:ab:f3
  Link detected: no
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #18 (Network controller)

35: None 00.0: 10700 Loopback
  [Created at net.126]
  Unique ID: ZsBS.GQNx7L4uPNA
  SysFS ID: /class/net/lo
  Hardware Class: network interface
  Model: "Loopback network interface"
  Device File: lo
  Link detected: yes
  Config Status: cfg=no, avail=yes, need=no, active=unknown

It seems I managed to find a permanent solution, which was pointed out in the early stages of this issue. Funny enough it was the NetworkManager Wait Online service causing it. Likely because WIFI doesn’t activate at boot time, and without a LAN cable plugged in the machine doesn’t have early internet connectivity thus the service errors out. I disabled it as a boot time optimization after looking it up and seeing that it’s useless, but after restarting I noticed all my connections are immediately working again.

sudo systemctl disable NetworkManager-wait-online.service

As that service is pointless on my laptop and I have no reason to re-enable it, I can consider the issue resolved in my case. This still isn’t normal behavior and will likely cause headaches to other users, so I’m leaving the discussion open for the team to debug it. I’d suggest booting a machine that’s not connected to the internet via any connection that can be immediately detected (eg: cable internet) to get a complaint from NetworkManager Wait Online, then seeing if this causes WIFI connections to be missing after you log in.

After applying Tumbleweed 02072020 my wifi stopped working on my HP laptop. Short of it; Kernel vmlinuz-5.5.1-1 and vmlinuz-5.5.2-1 do not work with the wifi adapter. I booted vmlinuz-5.4.14-2 and got back online.

So, wazzup???

Apparently it’s a bug in the latest wpa_supplicant, where the order of the startup sequence has been reversed - this is consistent with the observations in this thread that manually starting services in the right order works just fine… As a work-around, revert and lock to
wpa_supplicant-2.6-lp151.4.4.x86_64

Details here 1166933 – Wicked network setup of wifi fails with wpa_supplicant version 2.6-lp151.5.3.1-x86_64 .