WiFi Link 5100 not avaible?

For some reason I don’t understand SUSE tells me there are no network devices available. I’ve checked for any ‘firmware’ and ‘kill’ in both boot.msg and hardware information.

I’ve got an ACER Aspire 8935G with WiFi Link 5100 (Intel).

The only info I found that could point to the reason is:

  <6>    8.455470] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27kds
  <6>    8.455475] iwlagn: Copyright(c) 2003-2009 Intel Corporation
  <6>    8.455693] iwlagn 0000:09:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
  <7>    8.455742] iwlagn 0000:09:00.0: setting latency timer to 64
  <6>    8.455876] iwlagn 0000:09:00.0: Detected Intel Wireless WiFi Link 5100AGN REV=0xFFFFFFFF
  <4>    8.612754] iwlagn 0000:09:00.0: Failed, HW not ready
  <6>    8.612812] iwlagn 0000:09:00.0: PCI INT A disabled

Other info:

38: PCI 900.0: 0280 Network controller
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_8086_4232
  Unique ID: x1VA.PDTfCPuk4g7
  Parent ID: HnsE.Gg7kbdesig6
  SysFS ID: /devices/pci0000:00/0000:00:1c.5/0000:09:00.0
  SysFS BusID: 0000:09:00.0
  Hardware Class: network
  Model: "Intel Wireless WiFi Link 5100"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x4232 "Wireless WiFi Link 5100"
  SubVendor: pci 0x8086 "Intel Corporation"
  SubDevice: pci 0x1201 
  Driver: "iwlagn"
  Driver Modules: "iwlagn"
  Memory Range: 0xba100000-0xba101fff (rw,non-prefetchable)
  IRQ: 17 (342 events)
  Module Alias: "pci:v00008086d00004232sv00008086sd00001201bc02sc80i00"
  Driver Info #0:
    Driver Status: iwlagn is active
    Driver Activation Cmd: "modprobe iwlagn"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #22 (PCI bridge)
  114: udi = '/org/freedesktop/Hal/devices/pci_8086_4232'
  pci.subsys_vendor = 'Intel Corporation'
  linux.hotplug_type = 2 (0x2)
  linux.subsystem = 'pci'
  info.udi = '/org/freedesktop/Hal/devices/pci_8086_4232'
  info.subsystem = 'pci'
  info.product = 'Wireless WiFi Link 5100'
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1c.5/0000:09:00.0'
  info.parent = '/org/freedesktop/Hal/devices/pci_8086_294a'
  pci.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1c.5/0000:09:00.0'
  info.linux.driver = 'iwlagn'
  pci.product_id = 16946 (0x4232)
  pci.vendor_id = 32902 (0x8086)
  pci.subsys_product_id = 4609 (0x1201)
  pci.subsys_vendor_id = 32902 (0x8086)
  pci.device_class = 2 (0x2)
  pci.device_subclass = 128 (0x80)
  pci.device_protocol = 0 (0x0)
  pci.vendor = 'Intel Corporation'
  info.vendor = 'Intel Corporation'
  pci.product = 'Wireless WiFi Link 5100'

There is one more thing that could be related: I’ve got some touch-buttons to the left of the keyboard that turn wifi and bluetooth on/of. The bluetooth one works, but nothing happens if I press the wifi one.

I also know that this hardware worked on fedora 11 and 12, so it’s probably only a matter of settings/additional packages.

If you respond, please keep in mind I can’t use any internet connection-based commands, as the system doesn’t accept the hardware responsible for cable connections either. I can download files if needed.

BIOS-Problem, try booting without ACPI for a start.

ACPI=off in the kernel options? Failed to start. Was at splash screen, which got clugged up with some output similar to the boot.msg file. I couldn’t find anything related to the WiFi device in there. It stopped after the bluetooth device which I think is just before the WiFi in the boot.msg file.

Also I fail to understand why it’s BIOS problem if on the same machine it works on Windows and worked on Fedora just before it was wiped out by SUSE?

  • ACPI-Code is proven to be nasty, regressions/problems depending on kernel versions happen regularly.

  • BIOSes are proven to be buggy (and get patches from “vendors” to fix their Windows installations, try installing a “blank” windows on a machine with buggy BIOS and be surprised).

So after all, a machine running under $DISTRO1 with $KERNELVERSION1 or $WINDOWSVERSION with $VENDORPATCHES to fix a buggy BIOS does not exclude BIOS/ACPI-Problems under $DISTRO2 with $KERNELVERSION2.

To give you a very similar example:

https://bugzilla.novell.com/show_bug.cgi?id=555608